Jump to content

Why Two Icons in Taskbar?


Recommended Posts

Since the latest update for my Evernote (Windows 10, desktop, 64-bit), Evernote creates two icons in my taskbar whenever it's open. There's the shortcut which is always there, then there's the second icon (see picture, on right) whose purpose I do not see. Clicking on it doesn't even open Evernote! It appears to be just distracting clutter.

How did this change occur? Maybe it was a Windows update, maybe it was an Evernote update, or maybe it was both.

My first picture shows the taskbar working just fine with a Chrome and Evernote shortcut.

My second picture shows what the taskbar looks like when Chrome and Evernote are both open. Chrome highlights its shortcut. Evernote adds a second icon and then "neutralizes" the original Evernote shortcut so that it does nothing whether or not Evernote is "on top", open, maxed, minimized, etc.

You may be able to tell: I dislike clutter! Is there any way to get rid of this?

 

evernote double icon stuff.jpg

 

evernote double icon stuff 2.jpg

Link to post
  • Evernote Employee

What version of Windows are you on? (There is an issue on versions of Windows 10 before build 10586, but we should be catching that - it was actually a bug in the OS)

Link to post
On 4/6/2016 at 4:05 PM, dconnet said:

What version of Windows are you on? (There is an issue on versions of Windows 10 before build 10586, but we should be catching that - it was actually a bug in the OS)

Why would the bug affect some programs and icons but not others? I had the same issue with Firefox before, but that has been fixed, I think, by a Firefox update. I haven't had any problems with Chrome or any other program or icons.

Does this suggest the bug is with Evernote and not Microsoft?

Is it possible for Evernote to issue an update to fix this? Or do we have to wait for Microsoft to fix this problem? (An event that will likely never occur.)

Link to post
  • Evernote Employee

Since we put a fix in, we haven't seen it since. And it hasn't been repro'd here yet.

The bug in the OS was if a program called a specific API (SetCurrentProcessExplicitAppUserModelID), that triggered the multi-icon. Our "fix" was to identify build 10240 and not call that api.

Link to post
On 4/12/2016 at 4:24 PM, dconnet said:

Since we put a fix in, we haven't seen it since. And it hasn't been repro'd here yet.

The bug in the OS was if a program called a specific API (SetCurrentProcessExplicitAppUserModelID), that triggered the multi-icon. Our "fix" was to identify build 10240 and not call that api.

Weird.

The problem I reported here occurred on my desktop.

Yesterday, my laptop's Windows 10 decided to update and then the double icon problem occurred there, too. (For that and a bunch of other reasons, I undid that Windows update.)

Is there anything I can do to fix this?

Link to post
  • 2 weeks later...
On 4/25/2016 at 1:20 PM, ahendarman said:

I can fix mine by pinning to task bar when Evernote is actually running. 
Pin the active icon (with the blue bar on the left) and remove the inactive one.

Next time you open Evernote, it'll be just one icon on the task bar

 

 

It worked! Thanks!

 

Now to get Evernote and Microsoft to talk to each other and fix this for good...

Apparently, I am not the only one annoyed by this.  

https://www.reddit.com/r/Evernote/comments/4hixk0/everytime_evernote_updates_the_most_visable_change/

Link to post
  • 3 weeks later...
On 5/3/2016 at 7:53 AM, JerrySNB said:

I just installed 6.0.6.1769 on Windows 10 and see the same issue. So far as I know, Windows 10 is up-to-date.

Did you try the solution mentioned above?

i.e.

  1. Exit Evernote completely.
  2. Delete the taskbar icon.
  3. Open Evernote.
  4. Pin that icon to the taskbar.

That's what I did and it worked.

Hopefully, Evernote and/or Microsoft will fix the glitch and make this process unnecessary, but it sounds like that won't happen.

Link to post

Thank you, that fix worked for me too.

FYI, this bug happened to me after the Update to EN 5.9.8:

And it has stayed with me even after the EN 6 Update, and through alle Updates since then (I'm on EN 6.0.6 right now).

Link to post

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...