Jump to content

SSL/Proxy errors with Mac Desktop client - "Could not connect to server"


Go to solution Solved by BSR,

Recommended Posts

Hi There.

I'm using Evernote 6.5 (453175) on a Mac at work, and I cannot connect to Evernote. Access via the Browser works fine, however with the desktop version I get "Could not connect to server" (see attached screenshot).

I access the Internet through a proxy, which does some SSL insertion/replacement and is authenticated via SAML/NTLM (yes, scary). What this means in normal speak is:

I access any https:// website, and the proxy then unpacks the data (i.e. snoops in it) and then resigns it with our corporate proxy's SSL cert. So every certificate we see on https is signed by the corporate server, which my computer trusts. Furthermore, it requires authentication to work - using NTLM/SAML (i.e. Active Directory-like authentication). 

Since I'm on a Mac, and I don't like having to type my password in all the time, I use cntlm on my mac. I have my system proxy settings setup as:

  • Web Proxy (HTTP): localhost:3128
  • Secure Web Proxy (HTTPS): localhost:3128

and then these connect to cntlm on my local mac, which then in turn connects to our corporate proxy.

The error below (from my logs) looks like it's trying to connect, sees our corporate re-signed cert, and then barfs. Since I can't set an manual proxy settings, how can I fix this?

Thanks,

 

Ryan.

Error Log:

********
* The Activity Log may contain information about your account and notes.
* For example, the titles of some of your notes may be mentioned in this log file.
* When providing log information, feel free to edit the file to remove anything
* you do not want to send us.
********

  Version: Evernote Mac 6.5 (453175) [App Store]
   Locale: en-AU-AU
       OS: 10.11.3
   WebKit: 601.4.4
  WebCore: 601.4.4
 Username: <not signed in>
    Email: <not signed in>
Mac Model: MacPro4,1
 CPU Type: Intel
CPU Count: 16
CPU Speed: 2.260000 GHz
      RAM: 14.000000 GB
     Date: 2016-03-22 05:38:36 +0000

2016/03/22 16:38:03:039 I|*   -[ENVideoLoginWindowController bringLoginToFrontIfVisible] main | Making login panel key and front.
2016/03/22 16:38:03:055 I|*   -[ENVideoLoginWindowController bringLoginToFrontIfVisible] main | Making login panel key and front.
2016/03/22 16:38:09:445 I|*   -[ENVideoLoginWindowController retryBootstrapConnection:] main | Retry
2016/03/22 16:38:09:446 I|*   -[ENVideoLoginWindowController askForCredentials] main | ask credentials
2016/03/22 16:38:09:446 I|*   -[ENBootstrapManager performEDAMGetBootstrapInfo]  | Bootstrap url: https://www.evernote.com/edam/user
2016/03/22 16:38:09:563 E|*** -[ENBootstrapManager performEDAMGetBootstrapInfo]  | caught: TTransportException: Could not make HTTP request
  userInfo = {
    error = "Error Domain=NSURLErrorDomain Code=-1200 \"An SSL error has occurred and a secure connection to the server cannot be made.\" UserInfo={_kCFStreamErrorCodeKey=-9824, NSLocalizedRecoverySuggestion=Would you like to connect to the server anyway?, NSUnderlyingError=0x7f9cea00a290 {Error Domain=kCFErrorDomainCFNetwork Code=-1200 \"(null)\" UserInfo={_kCFStreamPropertySSLClientCertificateState=0, _kCFNetworkCFStreamSSLErrorOriginalValue=-9824, _kCFStreamErrorDomainKey=3, _kCFStreamErrorCodeKey=-9824}}, NSLocalizedDescription=An SSL error has occurred and a secure connection to the server cannot be made., NSErrorFailingURLKey=https://www.evernote.com/edam/user, NSErrorFailingURLStringKey=https://www.evernote.com/edam/user, _kCFStreamErrorDomainKey=3}";
}
2016/03/22 16:38:09:571 I|*   -[ENBootstrapManager performEDAMGetBootstrapInfo]  | Bootstrap url: https://app.yinxiang.com/edam/user
2016/03/22 16:38:11:170 E|*** -[ENBootstrapManager performEDAMGetBootstrapInfo]  | caught: TTransportException: Could not make HTTP request
  userInfo = {
    error = "Error Domain=NSURLErrorDomain Code=-1200 \"An SSL error has occurred and a secure connection to the server cannot be made.\" UserInfo={_kCFStreamErrorCodeKey=-9824, NSLocalizedRecoverySuggestion=Would you like to connect to the server anyway?, NSUnderlyingError=0x7f9ce0cdbcb0 {Error Domain=kCFErrorDomainCFNetwork Code=-1200 \"(null)\" UserInfo={_kCFStreamPropertySSLClientCertificateState=0, _kCFNetworkCFStreamSSLErrorOriginalValue=-9824, _kCFStreamErrorDomainKey=3, _kCFStreamErrorCodeKey=-9824}}, NSLocalizedDescription=An SSL error has occurred and a secure connection to the server cannot be made., NSErrorFailingURLKey=https://app.yinxiang.com/edam/user, NSErrorFailingURLStringKey=https://app.yinxiang.com/edam/user, _kCFStreamErrorDomainKey=3}";
}


 

evernote error.png

Link to comment
  • Evernote Staff

Hey @ryanhunt, thanks for bringing this to our attention. Our developers are aware of this issue and are working hard on a fix. We don't have a workaround at the moment, however in the meantime you can still access your account at evernote.com.

I've created a support ticket on your behalf. One of our Technical Agents will be contacting you soon.

  • Like 1
Link to comment

Thanks @BSR. As a workaround, our WiFi network doesn't have this issue of proxies etc and it 'just works' - so I installed a WiFi card in my Mac Pro to get it working. I can test again at any time by disabling the WiFi card and connecting via Ethernet. 

Link to comment
  • Evernote Staff

Hey @ryanhunt. We sent this via the ticket, but I wanted to follow up here as well.

Thanks again for reporting this to us. We've passed this along to QA and our development team to further investigate. For now, there are two options for working around this issue.

You can:

1. Use Evernote Web for the time being (recommended)
2. Regress Evernote to version 6.4, if that version worked for you previously

If you decide to regress to version 6.4, let us know via the support ticket and we'll be able to provide instructions for that. 

Link to comment
  • Evernote Staff

Hi @ryanhunt,

Regressing to a previous version of the application also means rolling back any issue fixes and features from the current version, and is generally not advised. 

For users who want to roll back to a previous version of Evernote, we recommend opening a support ticket where we would be able to provide specific instructions and guidance on the process of going back to an older version.

 

Link to comment
  • 3 weeks later...
  • Evernote Staff
On 4/25/2016 at 3:10 AM, Unexxx said:

Same problem over here... just logged a support ticket to make sure you are aware this is not an isolated problem.

Hey there @Unexxx, welcome to the Forums.

Would you post the ticket number here so I that can follow up on it? Thanks!

Link to comment
  • 2 months later...
  • Evernote Staff
22 minutes ago, FMeu said:

Hi,

when do you plan to fix this? I prefer to use the desktop version and not the web version and I'm impacted by this issue.

Thanks!

Hi @FMeu; our development team is currently looking into this. While I am unable to provide a timeframe, please keep your eyes posted on our Mac Product Feedback thread for updates, issue fixes, and release notes for new versions. Thank you for your patience.

https://discussion.evernote.com/forum/218-mac-product-feedback/

Link to comment
  • 3 weeks later...
  • Evernote Staff
6 hours ago, jim0266 said:

I have a brand new iMac. Cannot connect to server. Brilliant job Evernote. So glad I am now paying for Evernote.

Hi there @jim0266, welcome to the Forums!

Would you mind using the link in my signature to create a support ticket so we can take a look at your activity log? Once the ticket has been created, let me know the ticket number here so I can follow up on it. Thanks!

Link to comment

already have a ticket open. My laptop running Mac OS 10.9 still works fine on our network. My new iMac running 10.11 throws an SSL error when connected to ethernet and will not sync. but works on the wireless network. Since the laptop still works with wired ethernet on our work network, this tells me the issue is between Evernote and Mac OS 10.11 and not an internal network issue.

Link to comment
  • 3 weeks later...

@BSR,

this becomes very annoying. I do pay for this software and I really don't feel the "love". This has a major impact on the way I use Evernote and this is a regression as this was working with previous releases. The answers you're giving here ("keep your eyes on ..." or "open a ticket ...") don't help us. Can you please give an ETA for the fix? If not, I'll consider moving to another product for this. 

Thanks for your comprehension,

Link to comment
  • 3 months later...
  • Evernote Staff
  • Solution
3 hours ago, Jason Lazerus said:

Was this ever fixed?  I'm having this problem too.

 

@Jason Lazerus would you mind submitting a support ticket? These issues typically occur when the internet connection is slow or the computer is connected through a firewall/VPN. If you let me know the ticket number here I'll be able to follow up on it for you. Thanks!

Link to comment
  • 4 weeks later...
  • Evernote Staff
On 1/13/2017 at 2:30 PM, rochellefp said:

I'm having the same issue. I can't submit a ticket since I'm on a free plan. I'm on a MacBook OS X 10.11.6.

Hi @rochellefp, I've created a support ticket on your behalf. Let me know if the email doesn't appear in the inbox or spam folder of the email address used for your Evernote account!

 

Link to comment
  • 1 month later...
  • 1 month later...
  • 5 weeks later...

Another paid user having this issue over a year after the original post. I've opened a ticket but it's taking forever to hear back. The browser version of Evernote is almost unusable. Please fix this - or AT LEAST provide a link here for users to roll back to the version that didn't have this issue.

Link to comment
  • 3 weeks later...

On my Mac, Evernote App could not establish the link to evernote server even though VPN is disconnected. Several attempts with deleting and reinstalling the APP are futile. Anyone experiences this?

Screen Shot 2017-06-12 at 10.58.21.png

Link to comment
  • 5 months later...
  • 3 weeks later...
  • 8 months later...

So it's now 8th of August in 2018 and I still have this problem.

And the thread is saying "you content will need to be approved by a moderator". Instead of that, can't we just get the problem fixed?

At this point I don't regret going from paid to an unpaid user, since things are just never fixed and new features are not added.

Link to comment
  • 2 weeks later...
  • 1 month later...
  • 1 year later...
  • Level 5

You are posting in a thread that is more than 1 year old, and related to Mac, not iOS. Don't you think the forum would go berserk if there was a connectivity problem since ?

I am using EN on iPad, iPhone, Mac and Windows, no connectivity issue at all. Probably there is something in between like a firewall that stops your EN from connecting.

If you have LTE/4G on the iPad, does it work with this ? Alternatively, if you set up a personal hotspot on the mobile and connect the iPad to it, does it sync ?

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...