Jump to content

Search Results are Wacko

Recommended Posts

  • Level 5*
1 hour ago, hendernote said:

Has anyone else had a problem searching for text in Evernote Windows? The online version returns what I would expect, but the Windows desktop version returns nothing useful

We need more info to help you:

  1. What versions of OS and Evernote are you running?
  2. The exact text you are using in the Search box
  3. What do you mean by "returns nothing useful"?  Notes that don't match the Search expression?
Link to comment

I am using Windows 7. I search for "Tri-S" with and without the quotes (same result). In the online version, it returns all of the notes that begin with "Tri-S Series" etc. About 15 returns in all. In the Windows version, it returns just a couple of miscellaneous notes, but none of the "Tri-S Series" that the online version returns. 

I have seen this phenomenon before with different variables. I thought it was a generic flaw. Any thoughts about how it's supposed to work? Could there be some settings that might affect this?

Link to comment
  • Level 5*

Try dropping the minus sign from your search.  For one, the minus is used in the search logic to eliminate notes.  In your example the -S may be eliminating all notes that have a word starting with s.  Also, EN does not search for the minus sign at all, not even in quotes.  Try searching for Tri S Series on all platforms.

It has been a complaint for some time that search isn't precisely the same across platforms, but the above may help in your instance.

Link to comment

Bingo! That was it! Thank you Thank you Thank you. Wonderful. I tried csihilling's suggestion on both platforms and it worked (Windows 7 desktop and online). That is, I left out the dash (which the Search function (for the desktop version only) must have taken as a minus sign). 

My confusion was that the same actions in the online application yielded a different result in the desktop application. Now I know what was going on. Thank you again.


Link to comment
  • 1 month later...


Sorry to hijack this thread, but I am having the same problem as Hendernote. Now this is my situation: All files I have in evernote that the - sign, ex: Grod-medical-bill-01-05-16.pdf So instead of using a regular space I use the - is that a bad thing for searching purposes?

ETA: When searching in the windows application, search does not work (cant find what im looking for) but when I search it in the web option, whatever im looking shows up.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...