Jump to content

Can't Copy formatted section when note is open

Recommended Posts

I don't know if this is a bug, user error or something else...

When I have an open note in EN, if I have used any bullet points or formatting I can only select (& copy) by small sections, piece by piece instead of the whole note or larger sections.

When I try to select text to copy, it 'stops' when I get to anything with formatting & I can't select the paragraph before or after at the same time.

I have to select each section seperately:

It only allows me to select say:

The non- 'formatted' text before the bullets/list/etc

--then separately--

The section that I have bullets in

--then separately--

The next paragraph (which may or may not have bullets).

I can copy the whole note if I am viewing but not editing.

This is making it really hard to move data around in my note, or copy pieces of the note to add to another document.

I am on Galaxy Tab 4 with android 5.0.2.



Link to comment
  • Level 5*

Hi.  Are your bullets created in another version of Evernote?  In a desktop version say?  Evernote are just rolling out a new editor that should allow more consistency between apps but AFAIK the current production version of desktop and mobile editors are not fully compatible,  hence the piecemeal editing.

Link to comment

Nope. I am only using Evernote on my android tablet.

This is happening in the note generated and edited 100% within the android app.

It also happens on my LG Android phone.

I can select text that is formatted with bullets if I don't open the note, but I lose the bullets when I paste it.

Very frustrating. I don't *think* it happened when I first started using EN on the first Galaxy Tab...or I probably would not have begun using it...although it is only lately that I have been really using EN for research and such, so I may have missed it.

This problem may actually be a deal breaker for me. It is WAY too time consuming to have to piecemeal edit...especially within the same version.

Link to comment
  • 1 month later...

I'm getting the same issue on Evernote Web. At least, I think it's the same issue as the OP?

If I copy a whole multi-line, multi-paragraph plain text document into Evernote, it seems to treat it as a single block. That is, e.g.  I highlight a few of the lines to put them into a bullet list and it makes the entire document one single bullet point, indenting everything. I'm talking here only about copying from another program into Evernote. Manually going through and hitting Enter each line from within Evernote is going to be quite a gruelling ordeal - it isn't an option for me, for at least this note.

I've tried: on Windows 7 and 10. Both new and old versions of Evernote Web.Copying from different text editor (Word, Notepad, ...), seemingly regardless of what format (.odt, .doc, .rtf, .txt; UTF-8, ANSI). And the paste without formatting thing (SHIFT+CTRL+V). No good :-(

Edit: I actually successfully made a bullet point by copying the text into the body of an email, emailing myself, opening the email on an iphone (didn't work opening on desktop) and then coping it into a note on the Evernote App. Well, still less work than entering line breaks manually each line of this text...

Link to comment
  • 2 weeks later...

Except, I don't have any Android devices. :-p
This is more an issue with Evernote web, which I use more than any installed version, because I'm jumping between computers the world-over. The portability of Evernote was one thing that drew me to it in the first place.

Update to my last post: I couldn't reproduce the (very inefficient) success of me emailing my iPhone the text I want to have with line-breaks. I'm stuck again with notes containing just one huge block of text that won't play nicely at all with any formatting.

Link to comment
  • Level 5*

Hmmn.  Android thread here,  hence our slight confusion;  so what are you copying from exactly?  You're describing a multi-line plain text document,  but if that's displayed in a web browser,  you're seeing HTML formatting,  not standard ASCII text.  Have you tried using the dekstop feature of Simplify (or remove) Formatting on the note before you try changing the layout?  Or pasting the content into Notepad on your desktop and then copy/pasting from there into your note?

Link to comment

Wow, sorry! I don't know how I missed that. I specifically checked last time I came here to make sure it wasn't an Android thread and still failed somehow. My apologies to all.

Gazumped, yes that seems to be what's happening. I don't know the inner workings of Evernote, but I suppose it's HTML (especially if it's the online version). I have tried the copying to Notepad first technique. I didn't notice any "Simply formatting" feature last time I used the desktop version. Is this a new feature for the desktop versions? Looks like this note won't happen until after update.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...