Jump to content

Bug: Note displayed in notebook, but not in notebook stack

Recommended Posts

I have a notebook stack that has 6 notebooks in it. Some of them are local, and others are shared.


I'm using Evernote 6.2 in OS X 10.11.1.


I started a new note in one of the local notebooks in this stack. After working on it for a while, I moved it into one of the shared notebooks in the same stack.


After doing so, the note does not show up in my list when I select the top-level stack in the sidebar. If I select the notebook that it's in in the sidebar, it does show up. The note is there, and it's synced.


But if I select the stack that the notebook is in, the note is no longer visible in my list.


If I move the note back into the (local) notebook that I originally created it in, things work as expected: the note shows up in my list when I select the notebook it's in or the stack that that notebook is in.


But if I move it to a different notebook again, it is again hidden from view when I select the stack in my sidebar.


The bug seems to be that when you move a note between notebooks, it doesn't update Evernote's database regarding which stack it's in -- even if it stayed within the same stack.


This is really, really frustrating, as I usually rely on stack view, not individual notebook views. Now I have to constantly switch between notebooks.


Reported as bug #1303178.

Link to comment

More information: this appears to only occur when moving between local and shared notebooks.


I just tried to reproduce it by creating a note in a local notebook and moving it to a different local notebook within the same stack, and when moving between two local notebooks everything worked as expected: the note showed up in my note list when I had the entire stack selected.


It seems that my specific workflow, of creating a note in a local notebook and moving it to a shared notebook in the same stack, seems to be a key to this bug.

Link to comment

One more bit of info: it doesn't seem to matter which direction you go in; I just reproduced the bug by creating a note in a shared notebook and then moving it to a local notebook in the same stack. Same result: the note no longer showed up in the notes list when the stack was selected.


So whether you go local->shared or shared->local, it appears that moving notes between notebooks of different sharing levels causes the note to no longer be visible in stack view.


Which is really, really frustrating; it pretty much undoes the utility of stacks because you have to keep switching between notebooks.

Link to comment
  • 4 months later...


This topic is now archived and is closed to further replies.

  • Create New...