Jump to content

Evernote not installing after upgrade to Lollipop 5.1

Recommended Posts

I am running 5.1 Lollipop on a new BLU XL Pure octa-core


I have had no problems with installing dozens of other apps on the phone.


Only Evernote gets the 504 error when I try to install the app.


I have tried all the suggested 504 error fixes that are on the net. Nothing works.



Link to comment
  • Level 5*

Thanks for the link,  but that's like juggling live hand grenades - like the man says,  one wrong selection in the process can brick your phone.  I'd suggest you avoid this fix unless it's already absolutely impossible to use the device for anything!!

Link to comment

Actually the Evernote team also suggested the same finally and I'm pasting the same below. Somehow I have not been able to reach this menu on powering up


Our product team has one other suggestion. The instructions are a bit involved so please let me now if you need any clarification.

  1. Power off your phone
  2. Press the volume down button and press the power button. Hold both together for 5 seconds and then release.
  3. You will re-directed to the boot menu
  4. Use the volume down button to highlight 'recovery option' from the menu.
  5. The volume button will select the option. Press volume up when recovery option is highlighted.
  6. A new screen will appear with Android logo showing 'no command'
  7. Press the volume up button and the power button and hold both together for 5 seconds.
  8. A new menu will appear. Use the volume down key to highlight 'clear cache partition'
  9. Use the power button to select the option here. Select the clear cache partition option.
  10. Your cache will be wiped clear.
  11. Your phone might automatically restart. If it doesn't then wait until the "cache partition has been cleared" message displays.
  12. Now highlight reboot phone now. Select this option using the power button.
  13. The phone should restart.
  14. Now install Evernote
  15. If successful it will install without the error

Please let me know if this works for you.

Link to comment
  • Level 5*

Try a support ticket - click Troubleshooting in the Help Center (link below in my sig) and scroll to the bottom of the page to see the 'Contact Support' button.


It's always useful to report glitches - it gives Evernote a sense of how urgent the issue is,  and incentivises them to get things fixed!

Link to comment
  • Level 5*

@AtulBS - I was responding to @geneonlbk who I don't think has contacted support yet,  I realise you have.  Please feed back to them that clearing the cache partition doesn't work - they'll have to find another fix for this...

Link to comment

Thank. Tried other 504 error fixes such as deleting email account and recreating it. There is some discussion about the 504 error being a server timeout issue, but my error occurs after the download process, during the install phase. It does seem to take a long time before the error screen appears after the install process has started.

Link to comment
  • 3 weeks later...
  • 1 month later...
  • 1 month later...

I found this thread when looking for a solution to the same problem myself.  As others have said none of the normal fixes worked.

My phone came with 5.1installed, a blu pure xl which is the same as one of the other posters.  However, just like that other posters every single other app works great.

Downloading version 6.3 from the link aboveworked.  (Thanks for that).

I'll open another support ticket and mention that fact in it.  Maybe that will help narrow it downn.

Link to comment
26 minutes ago, Matt W. said:

Hello all,

Using Evernote 6.3 and then going through the update process like previously mentioned has been found to work on some devices. We are looking into what could be causing this, as it only seems to happen on a few devices.

Hi Matt,

Installing 6.3 worked for me.  Actually I didn't realize it would but when I go into the play store I can see that I have an update available so I guess eventually whenever this is fixed it can automatically update.

I'm just happy I got some version of Evernote now.  It would be a real problem for me if I wasn't able to get something working.

  • Like 1
Link to comment
  • 3 weeks later...
  • Level 5*
On 09/03/2016 at 2:48 AM, Bronxite said:

I receive the 504 error when trying to install Evernote.  I tried previous versions and I found version 5.8.5 works on Android Lollipop.  My device is a Blu Pure XL.  Make sure to disable autoupdate for Evernote in Google Play Store app. http://evernote.en.uptodown.com/android/old

Thanks for the workaround.  I'm running 5.1.1 with Evernote quite happily on a Samsung - I'd suggest contacting support with a bug report if you haven't done so already...

Link to comment
  • 4 weeks later...
  • 4 weeks later...

I am surprised that since 2015 that the issue raised above had not been solved.

NOw, Ever since the android upgraded to Lollipop 5.1 I'm unable to install Evernote from Google Playstore and am getting error 504. On trying to install from apk file also it fails to install.

Link to comment

Thanks for everyone for your suggestion, I have come to agree with others that the problem here is from Evernote. I followed this suggestion "I tried previous versions and I found version 5.8.5 works on Android Lollipop.  My device is Infinix Hot Note.  Make sure to disable autoupdate for Evernote in Google Play Store app. 

Link to comment
  • 3 months later...
  • 1 year later...

Hi. I have an oddball Jaike V12 android phone with only 8M memory. I loaded Evernote in February and it worked great and synced with my laptop. Then it said memory ws full and the phone quit working. I installed  32 M card but I couldn't transfer anything over from the phone's memory. I did a factory reset and the phone started using the card. Now I can't install Evernote experiencing the above issues. I tried the fixes mentioned including downloading the APK file. That method gives me a parse error, "There was a problem parsing the package. I tried using the current version and 2 earlier versions of evernote. I had this program working on my phone earlier. Why can't I get it working now?  Thanks  hoader



Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...