Jump to content

Pasting Images into notes


Recommended Posts

  • 8 months later...

Hi, the quickest work around I've found for this is to take a screenshot with the web clipper, save it to the default notebook and then copy it from that newly created note and paste it wherever you want it to go. For me this is a lot faster than using the 'attach image' function within Evernote, especially as the image always ends up at the bottom of my note and I have to re-position it manually. I really hope the team can implement a simple copy/paste for us at some point though. 

  • Like 1
Link to post
  • 1 month later...

I have lots of complex, VERY long notes where I need to add images in the middle of the note...

-it is VERY frustrating that there is no way to do this in the Web version of Evernote!!!  we need a Paste facility, at point of cursor

Link to post
  • 4 months later...
  • Evernote Staff
On 10/19/2016 at 0:41 PM, stevenbarnett@webmail.us said:

this was possible a couple months ago - I'd been pasting images from the clipboard directly into my notes (in the web browser version of the editor - on both linux and windows). then it stopped working out of the blue. what gives? this was one of the most useful features of evernote!!

 

Since not all browsers handle copied and pasted images in the same way, we discovered that in some cases (primarily in Chrome on Windows) images that were pasted were not actually saved to the note and instead were linked to the note. This resulted in the loss of the image when the linked file was removed. To prevent this type of loss, the paste functionality was disabled in Evernote Web. This is something we do plan to support again but I currently do not have a timeline for when this will be available. In the meantime, the drag and drop functionality should work correctly so another workaround would be to drag and drop an image onto your desktop (or other location) and then drag and drop it into a note. 

  • Like 1
  • Thanks 1
Link to post
  • 2 months later...

Is there any update on the copy/paste function. I find it SUPER annoying that this feature worked for me and since October it just stop. Applications like google docs handle it also, so why is evernote not finding a solution? For me this is a big issue and a reason why I WON'T upgrade my account. This is such a basic and important feature!!!! So please, give us a time line!!!! Using the desktop application is also not an option for me since I'm using Linux....

Link to post

The problem is due to Chrome browser.  It cannot copy and paste images to Evernote web.

Try this:

1. Open a non-Chrome browser (Firefox works for me)

2. Right-click to copy the image.

3. Got the Evernote web. Place the cursor you want to place the image.

4. Paste the image (Ctrl-V works).

Hope this helps.

Link to post
  • 3 months later...

The way to do on Mac is to use the Evernote app.

I tried multiple browsers, but couldn't get it to work (there's a reason why I have to use a browser, but that's another issue!).

Hope this helps.

 

Link to post
  • 2 months later...

This is a highly desirable feature, to me.  I take detailed notes, and often wish to embed small screen capture images into the text.

 

ETA: I see from the replies above that it is Chrome specific, which is unfortunately my browser of choice (and most of the rest of the world's).  Please work on this.

Link to post
  • 1 month later...

It is now SEPTEMBER OF 2017. I read these suggestions and requests dating from 2015. 

 

Tonight I created a new note which resides in a new notebook. Then, I used the standard Windows 10 screen shot program, selected the part of the screen I wanted, and saved it to my hard drive. I them opened that same image, drug it the Evernote note I just created, and let go of it so I could move my cursor off of the screen. As soon as I click anywhere the screen shot I just planted in the note vanishes. Gone, MIA, moved to Las Vegas or Boston or maybe both where it commutes by Southwest. 

 

WHY IS THIS HAPPENING TWO YEARS AFTER PEOPLE COMPLAINED? 

 

I hope I did something wrong and that you will tell me what it was I did.

 

Please advise.

Screen Shot 1.JPG

Bad Boating Weather in Houston.jpg

Drive Thru Home.jpg

Roof Remains Intact.jpg

Link to post
  • Level 5*
52 minutes ago, Challenger said:

Tonight I created a new note which resides in a new notebook. Then, I used the standard Windows 10 screen shot program, selected the part of the screen I wanted, and saved it to my hard drive. I them opened that same image, drug it the Evernote note I just created, and let go of it so I could move my cursor off of the screen. As soon as I click anywhere the screen shot I just planted in the note vanishes.

Just tried it and dragging worked for me (Mac, Safari, using latest web version)

In fact, when dragging the picture, a Drag File message appeared in the note59b369d0dde41_ScreenShot2017-09-08at21_08_43.thumb.png.77d50e382dc146b1a86f0f062af8d4e9.png

Link to post
  • 2 months later...

Evernote works only for Desktop and Mobile App.
If you are on Linux or in the Browser, don't use evernote!
Slack has a very nice Linux Client.
Right now we have Evernote, i am using the Chrome App on Linux, but its no solution for this problem.
Before i tried nixnote2 and nevernote, those destroyed most of our notes (formatting)

Link to post

How can this not be default behaviour? In gmail, Thunderbird (set to html) I just paste an image and it's right there. All these lasters and you have not added this simple feature tot he web app?  Why?

I can take all the extra steps to save a clip to a file unnecessarily and then drag that file into the note, which works but it not very usable in this day and age!

Link to post

I am sorry for my rant.
But i found an idea for a small improvement.

If your screenshot is somewhere in the cloud. At least it worked with the default FireFox Screenshot tool.
From there i was able to copy it (right click copy picture to clipboard) into my chrome evernote app.
And hey i could paste it everywhere.
Its another improvement since local files are always put to the very end of the note.

Maybe some of you find this helpful and you may find better workflows.

Link to post
  • 8 months later...
On 9/9/2017 at 7:03 AM, DTLow said:

Just tried it and dragging worked for me (Mac, Safari, using latest web version)

In fact, when dragging the picture, a Drag File message appeared in the note59b369d0dde41_ScreenShot2017-09-08at21_08_43.thumb.png.77d50e382dc146b1a86f0f062af8d4e9.png

tried it on firefox in ubuntu 16.04, does not work, 2018 august

Link to post
  • 5 months later...
On 1/24/2017 at 2:07 AM, lchow said:

The problem is due to Chrome browser.  It cannot copy and paste images to Evernote web.

Try this:

1. Open a non-Chrome browser (Firefox works for me)

2. Right-click to copy the image.

3. Got the Evernote web. Place the cursor you want to place the image.

4. Paste the image (Ctrl-V works).

Hope this helps.

I am using Ubuntu 16.04.

I can copy/paste an image from Firefox to Evernote web (in Firefox).

But it does NOT work copying an image from Libreoffice Impress to Firefox.

Drag and drop still not working.

Link to post
  • 1 month later...
On 10/23/2016 at 3:18 AM, kgg said:

Since not all browsers handle copied and pasted images in the same way, we discovered that in some cases (primarily in Chrome on Windows) images that were pasted were not actually saved to the note and instead were linked to the note. This resulted in the loss of the image when the linked file was removed. To prevent this type of loss, the paste functionality was disabled in Evernote Web. This is something we do plan to support again but I currently do not have a timeline for when this will be available. In the meantime, the drag and drop functionality should work correctly so another workaround would be to drag and drop an image onto your desktop (or other location) and then drag and drop it into a note. 

Still having the same issue on chrome and windows any idea how to fix it?

I tried various ways direct screenshot copy and paste doesn't work. I pasted here copied and pasted it in the note and it works any idea why?

Link to post
  • 2 weeks later...
  • 5 months later...
  • 3 months later...
On 9/1/2019 at 1:06 AM, PMS1 said:

Im reading this complain from 2015. Its 2019 and it seems it still doesnt work. Am I missing something? Is there a way to paste an image from the clipboard into the note?

No, it still not ) You can edit a note, write your ideas, but you can't insert a picture inline. Probably, you are supposed to index and reference them :)

Unbelievable !!!

Link to post
  • Level 5*
4 hours ago, china6k said:

No, it still not ) You can edit a note, write your ideas, but you can't insert a picture inline. Probably, you are supposed to index and reference them :)

Unbelievable !!!

In the "Classic" and beta web applications, drag/drop of an image from the Windows file explorer seems to work fine. Copy/paste from a Windows File Explorer window doesn't seem to work, but curiously, you can paste from the Windows Evernote screen clipper or the Windows image viewer. Kind of inconsistent there.

In the web beta, you can use the "Insert..." menu at the right hand side of the editing panel.

Link to post
  • 1 month later...

Amazingly it's 2020 and it still doesn't work. It was working a few weeks ago but since then the UI changed and it lost functionality. Is it a bug or is it coming back? It's helpful to use the Snipping Tool to put things into my Evernote Notes. I was literally about to upgrade my subscription but this completely turned me off. It's such a simple feature, it makes no sense why it's not supported.

Link to post
  • 7 months later...

Just echoing the previous post. How has this problem existed for 5 years without resolution? It would seem like a simple thing. I'm not upgrading my subscription until there's a fix. 

Link to post
  • Level 5
On 9/16/2020 at 10:40 AM, landeck said:

Just echoing the previous post. How has this problem existed for 5 years without resolution? It would seem like a simple thing. I'm not upgrading my subscription until there's a fix. 

Hi, and welcome to the forums. In fact the problem seems to exist only with certain browsers. I just tried it in Opera, for instance, and it works fine to paste an image into a note in the Web editor. Are you by any chance using Chrome? There have been many reports of problems between Evernote and Chrome, including earlier in this thread.

Link to post

Thanks for your reply. I had been using Chrome, but I downloaded Opera. However, it's still not working for me. The images paste without any problems into a Gmail message, for example. 

Link to post
  • Level 5
2 hours ago, landeck said:

Thanks for your reply. I had been using Chrome, but I downloaded Opera. However, it's still not working for me. The images paste without any problems into a Gmail message, for example. 

That's a puzzle, then. Does it matter what the source of the image is? For example, is there any difference between an image copied from a Website and an image copied from your computer?

Link to post

It works fine in chrome if you are using the "new web interface" (the one with the black background on the left hand menu).

It doesn't work in the older interface. 

The downside of the "new" interface is that to go to the hyperlink of notes that were added using the web clipper it now takes 5 steps :

  • Click the 3 dots in the top right
  • Click note info
  • Click in the url field
  • Press control A to select the whole link
  • then right click to select the option to go to that link 

on the previous version it is just displayed in the top right hand corner and you can click on it!

Hey that is so much easier isn't it NOT!!!!

  • Like 1
Link to post
58 minutes ago, technonath said:

The downside of the "new" interface is that to go to the hyperlink of notes that were added using the web clipper it now takes 5 steps :

  • Click the 3 dots in the top right
  • Click note info
  • Click in the url field
  • Press control A to select the whole link
  • then right click to select the option to go to that link 

on the previous version it is just displayed in the top right hand corner and you can click on it!

Hey that is so much easier isn't it NOT!!!!

That ist the reason why there is allready a separate and reactivated issue for this additional topic, see:

 

Link to post
5 hours ago, technonath said:

It works fine in chrome if you are using the "new web interface" (the one with the black background on the left hand menu).

It doesn't work in the older interface. 

The downside of the "new" interface is that to go to the hyperlink of notes that were added using the web clipper it now takes 5 steps :

  • Click the 3 dots in the top right
  • Click note info
  • Click in the url field
  • Press control A to select the whole link
  • then right click to select the option to go to that link 

on the previous version it is just displayed in the top right hand corner and you can click on it!

Hey that is so much easier isn't it NOT!!!!

Thank you! Switching to the new web interface got it working for me. 

  • Like 1
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...