Jump to content
  • 0

Web Clipper 6.5 for Chrome, Opera, and Safari



  • Ex Employees

Web Clipper 6.5 for Chrome, Safari, and Opera is now available! 


Web Clipper works great with any site, but saving the sites you browse most often is now improved. Clipping from Gmail, LinkedIn, YouTube, or Amazon? These sites are treated differently to allow you to clip only the portions of the page that you want. Then, save it to Evernote as a clean and clutter-free note. In Gmail’s case, Web Clipper will even include the email’s attachments!




Updates will happen in the background and typically a browser restart will force the update to trigger. Sometimes if users have problems with the Clipper it may have updated in the background and then it will only work properly on new or refreshed tabs.


You can learn more details on the Evernote Blog: https://blog.evernote.com/blog/2015/06/30/new-web-clipper-popular-sites-perfectly-captured/


Happy Clipping! 

Link to comment

11 replies to this idea

Recommended Posts

  • Level 5*

Loving the updates! But there are some bugs... For example, when I clipped from YouTube, it tried to use your brand fonts (Caecilia and Gotham Book) as opposed to the default note fonts. Using the latest version of Chrome on a 64-bit Windows 7 Pro machine.


Header font setting: Caecilia, CaeciliaLTStd, Caecilia LT Std, Caecilia LT Std 55 Roman, CaeciliaLTStd-Roman, CaeciliaRoman, Cambria, Georgia, serif

Body font setting: Gotham Book, GothamBook, Gotham SSm, Gotham, Helvetica Neue, Helvetica, Arial, sans-serif



Link to comment
  • Ex Employees

I have a Mac Book Pro, Safari is up to date, using Yosemite and updated the new Safari web clipper listed above. The web clipper is downloaded, but does NOT Work!


Anyone else having this problem?


Sorry to hear that you are having this issue. I've converted your post into a support ticket and you should be contacted shortly via email to begin further investigating your issue. 


Let me know if you have any questions about this :)

Link to comment



Are you using Yosemite and latest version of version of Safari?

I have been having this problem since I updated to Yosemite. I thought this new Webclipper app would correct this problem, but it has not!


Be sure to request assistance by going to support and filling out a ticket. I have done and awaiting a response. Very frustrating since I am paying for Evernote and has not worked on safari for a couple of months. Good luck, if I learn anything I will let you know.

Link to comment

Safari 7.1.7 on Mac OS 10.9.5. Web Clipper does not work‚ clicking toolbar button does nothing.


Restarted Safari; re-installed Web Clipper extension; restarted Mac; even reset PRAM — all to ZERO effect.


Please fix this ASAP. Will be deleting Evernote and switching to something more reliable.

Link to comment

For those who are having trouble with Safari Evernote Web Clipper!


I, too, had a problem with the new Safari web clipper not working but it is resolved. My Macbook pro Mac  isrunning Yosemite 10.10.4 and Safari 8.0.7. Evernote Web Clipper says it's 6.5 .

This is how you resolve the issue.
Restart your computer
go to Safari browser at the top of your computer screen, top left
at the top left of screen, click on the word Safari
you will see a dropdown menu, then click on Preferences
you will see a box with a choice of areas in the computer, for General, Tabs, Autofill, Passwords, Search,Security, Privacy,Notifications, Extensions,..
click on Extensions
you will see another box with your Extensions listed, there is also and on and off switch
My computer showed the switch on, on the left side of screen showed my One Extension Evernote Web Clipper. 
On the right of the screen it said Evernote Web Clipper 6.5.1, the box was checked for Enable Evernote Web clipper.
Click on Uninstall button for Evernote web clipper 6.5.1 and any other Extensions listed (you can reinstall those extensions once the clipper is download and working. Restart your computer.
Now Reinstall Evernote Safari Web Clipper and Restart your computer.
The Safari Evernote Web clipper should be working now, check again in Safari Preferences and you should see it Reinstalled.
My problem was that my husband uses the same laptop, has in own log-in, ... He was the one with Extensions, so I had to follow the above steps to prevent the Extensions from blocking me. Now that all is working it is ok to reinstall your Extensions.
Good luck.
Link to comment
  • Level 5*

Amazon's regional site should be supported in the next release. 


Really like how it works on the US site, looking forward to the UK version so I don't have to go through and fix aluminum every time...

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...