Jump to content

evernote adding styling to my html in phpstorm

Recommended Posts

Why is it that when I graB an html file and put it in PHPStorm I get this code added


<style id="style-1-cropbar-clipper">/* Copyright 2014 Evernote Corporation. All rights reserved. */
.en-markup-crop-options {
top: 18px !important;
left: 50% !important;
margin-left: -100px !important;
width: 200px !important;
border: 2px rgba(255,255,255,.38) solid !important;
border-radius: 4px !important;

.en-markup-crop-options div div:first-of-type {
margin-left: 0px !important;


how do I stop this?


I have removed evernote from my computer but it is still doing it.

  • Like 1

Share this post

Link to post

Hi - Evernote user forum here,  so we're not necessarily fully up to speed on this sort of thing - when you say 'grab an HTML file' - where did that file come from and how are you grabbing it?  The extra code looks like it's related to the Evernote clipper - do you still have that installed in your browser add-ins?

Share this post

Link to post

Hey, it should be the Evernote Clipper's problem. 

If you have installed Evernote Clipper extension into your browser, there they are in your codes.

Share this post

Link to post

I was in Chrome browser and hit right-click 'save as' 'web page complete' - No Evernote extension involved (Yes I have the extension installed, but never asked for 'help' as I am trying to clone a website page  in html). Got the same 'error'. If I had used your web page clipper I'd understand. Somehow, the extension is injecting itself into every page displayed in the browser and not restricting itself to "When I ask for help"

Share this post

Link to post

Have you tried clearing the browser cache and loading a new copy of the page?  If you tried the Clipper extension at some stage,  the extra HTML might have been saved in the cache and be served up to you by the browser each time.  If you reload a new version,  that might not have the added code...

I just used a 'save page' option in Firefox (Clipper installed) to save a page to HTML and there was no 'Evernote' code anywhere.  Then clipped the page and re-saved and... there was still no code.  Odd.  Maybe it's a Chrome thing?

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...