Jump to content

Purchased Evernote Premium Through Android - Not Working

Recommended Posts

I bought Evernote Premium a little bit ago, and i've been charged for it on my bank account, but it still says free (yes, i've tried syncing).  I've looked at other posts, but they say to start my own post.  Also, every time i lock my Nexus 5 phone, i get a home screen message along the lines of "you're upgraded to premium.  Click here to change your settings."  Just hoping this can get fixed.

Link to comment

The same thing happened to me on my Samsung GS5. 


I managed to get premium content working without the aid of technical support, but this issue and Evernotes response is unacceptable.  At the very least, a fix should be posted in the main forum since so many people seem to be impacted.   It is unreasonable for the Evernote team to expect each individual user to submit a ticket and wait days for a response. 


It's especially insulting because the support staff insist on the querent submitting proof of purchase before they will offer help.  If you, as a business, don't have a record of my proof of purchase you are doing something seriously wrong at the management level and should consider taking a first year business class. 


This is not the support I expect from a "modern workspace" that "helps" me be my "most productive self."


The Fix that Worked for Me


Uninstall Evernote from your device.

Turn your device off.  Leave it off for about two minutes.

When you turn the device on, reinstall Evernote.

Log in with your username and password.


After logging into the reinstalled app, I was able to access premium features.


Please post here if this fix worked for you. 

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...