Jump to content

Backspace-delete key not working in notes


Recommended Posts

Hey,

I've recently found out that my backspace-delete key isn't working the usual way that i have been using it since always. When i'm editing text note it doesn't go back to line above?

Example i'm using numbering or checkboxes to enumerate some tasks to do and when i use return key to go to another line i can't go back with delete key? I've always have been using this button.

Why is that?

 

Mac Yosemite 10.10, Evernote 6.0.8

Link to post
  • Level 5*

Sorry, I don't have any definite fixes to offer.

 

I'm on a different EN ver and Mac OS than you, but I can't duplicate the behavior you are seeing.

I'm running EN Mac 6.0.7 on Mac OS X 10.9.5 Mavericks, and the backspace/delete key works fine.

Do you see the same behavior in all Notes, including new ones?

 

I have not seen this reported by any other users here.

 

I'm also assuming that you are NOT seeing this behavior in any other Mac app, and that you have already tried a Mac restart.

Obviously, if you are seeing the behavior elsewhere, the problem is most likely NOT Evernote, but something more basic, like your keyboard.

 

If you want to try some things, here are some ideas, but I have no idea if they will help.

Before you start fixes #2 and below, do a full backup of your Evernote data folder and app.  If you have any Local Notebooks, you might want to export each NB to ENEX file as an additional backup.

See Location of Evernote Data Folder for EN Mac  

After you try each of the below, run the same test in EN Mac to see if it has been fixed.

 

Before you start any of these, make sure you understand the process and are comfortable with it.

If not, ask questions.

 

Possible Fixes (test after each)

  1. Sign out of Evernote Mac, restart your Mac, sign back into to EN Mac.

    -- Do a Full Backup before starting below --

     
  2. Reinstall just the Evernote App
    1. Quit EN Mac app and the Helper menu
    2. Move the Evernote app to the Mac Trash
    3. Restart your Mac
    4. Download EN Mac from Evernote.com
    5. Install EN Mac
    6. Allow it to run a while (at least one hour) to make sure the essential install items have completed)
  3. Downgrade to a Prior App Version
    1. ​This could be risky, particularly if there were data structure changes between versions
    2. So be sure you have a full backup before you start
    3. This will be the simple downgrade of just the app, leaving your data in place
    4. Follow the steps under #2, but download the EN Mac Ver 6.0.7 from here.
    5. Install and test
  4. If none of the above have worked, you can try a clean install of a prior version
    1. See How to Completely Remove and Reinstall EN Mac 

Again, be sure to make a full backup and export any Local Notebooks before you start fixes #2 and on.

 

Please feel free to ask any questions if you don't understand or are unsure about the process.
 

 

 

Link to post

Thanks for an answer.

 

I've downgraded app to 5.7.0 and it started working. Then i've checked also 5.7.2 and it was working too. But i've also wanted to check 6.0.7 cause of the new design of an app.

And it stopped working on 6.0.7

 

I can record a video of that bug if you want!

 

Cheers for help!

Link to post
  • Level 5*

Glad you're up and running.

 

Please submit a bug report so Evernote can get it fixed:

 

Submit a BUG report via an EN Support Ticket. In the Support Form, select "Report a bug", and start the Ticket Title with "BUG:  " to make it clear.  Reporting a bug should be available to all users, including Free Account owners.  Other Ticket types available to Free users are "Data Loss", "Crash", & "Sync Issue".

Link to post
  • Evernote Staff

Hmm.. I am not able to replicate this issue on 6.0.8.

 

As suggested above, you may want to create a support ticket to report this issue. 

If you message back your ticket #, I'd be happy to further investigate the problem. 

Link to post
  • 3 weeks later...
  • 2 weeks later...
  • 2 months later...
  • 2 weeks later...
  • 1 month later...
  • 2 months later...

I have the same issue here, right after I upgraded to "Version 6.3 (452849 App Store)".

I'm on Mac OS: 10.9.5.

PS. The problem is really Evernote-specific since I can alt-tab to any other application and the backspace key will behave normally.

PPS. LUCKILY I am used to the Emacs-style Cocoa key bindings (which are sadly partly broken in the present textfield!) and I have therefore not a problem in my notes; just wanted to mention this as it will definitely be very annoying to many users and should be fixed.

Link to post
6 hours ago, Ytsen said:

I have the same issue here, right after I upgraded to "Version 6.3 (452849 App Store)".

I'm on Mac OS: 10.9.5.

PS. The problem is really Evernote-specific since I can alt-tab to any other application and the backspace key will behave normally.

PPS. LUCKILY I am used to the Emacs-style Cocoa key bindings (which are sadly partly broken in the present textfield!) and I have therefore not a problem in my notes; just wanted to mention this as it will definitely be very annoying to many users and should be fixed.

Version 6.3 requires you to use the key command 'Command + Delete' to delete notes from your notes list now.

Link to post
  • Level 5*
On 12/18/2015 at 11:21 AM, amanda_h said:

Version 6.3 requires you to use the key command 'Command + Delete' to delete notes from your notes list now.

This is a huge improvement, preventing the accidental, unknown, deletion of notes that has been reported by many users.

It is also the Mac standard, take the Finder as an example.

Link to post

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...