Jump to content

Lost Indentation on copy/paste in Evernote


Recommended Posts

When I copy this code:

 

  def traverse trail = [], &block    trail = trail + [self]    runtime_dependencies.each do |dep|      dep.to_specs.each do |dep_spec|        block[self, dep, dep_spec, trail + [dep_spec]]        dep_spec.traverse(trail, &block) unless          trail.map(&:name).include? dep_spec.name      end    end  end
 
And paste it into evernote, it becomes this code:
 
def traverse trail = [], &blocktrail = trail + [self]runtime_dependencies.each do |dep|dep.to_specs.each do |dep_spec|block[self, dep, dep_spec, trail + [dep_spec]]dep_spec.traverse(trail, &block) unlesstrail.map(&:name).include? dep_spec.nameendendend

Which since I use evernote to draft up technical blog posts (in markdown) makes each post take 2-3x longer. This started happening relatively recently (I don't remember this being a problem before). Is there some setting I maybe accidentally triggered or is this a bug in the client?

 

On the mac client version 6.0.6 from the app store.

 

 

Link to post
  • Level 5*

Hi.  I don't remember any change that might have caused this - have you tried settings the standard font for new notes to a fixed-width font,  or simplifying/ removing formatting for the note?

Link to post
  • Level 5*

Hmmn.  The only other options seem to be:

  • uninstall/ reinstall Evernote in case this is some sort of glitch.
  • see if you can find a plain text editor that will preserve your formatting,  and edit your content in that,  attaching the file to an Evernote note.  You can open the file again from that note to edit or to add more text and save changes back to the attached file. 
  • submit a bug report (you probably won't get any feedback from it though) by choosing "report a bug..." in the first dropdown after logging into this link > https://www.evernote.com/SupportLogin.action
Link to post

My ticket was #987895. Maybe open up a new ticket, reference this forum post and my ticket number.

 

I'm able to reproduce this issue. I went ahead and escalated your ticket to urgent status and assigned it to our Mac specialist. 

 

If anyone else is experiencing this issue, will you please open up a support ticket via https://evernote.com/contact/support/ and let me know the ticket number? Please include an activity log in your ticket as well: https://evernote.com/contact/support/kb/#!/article/23394137.

Link to post

I reproduce the same issue when my evernote crash and I install version "Version 6.0.7 (451372 Direct)".

 

The problem is that when ever I copy and paste content (eg, java source code from online source file) from other place, the format got mass up.

 

The issue occur after my usage reach to the 60M limit and reset later.  I am using the Mac version.

Link to post
  • Level 5*

This issue has been previously  reported in other Mac threads.

Here's an example:

BUG: Paste kills indents (ver. 6.0.6)

 

Hi.  I don't remember any change that might have caused this - have you tried settings the standard font for new notes to a fixed-width font,  or simplifying/ removing formatting for the note?

 

@GAZ:  It helps to understand the issue you actually use EN Mac.

 

 

My ticket was #987895. Maybe open up a new ticket, reference this forum post and my ticket number.

 

I'm able to reproduce this issue. I went ahead and escalated your ticket to urgent status and assigned it to our Mac specialist. 

 

If anyone else is experiencing this issue, will you please open up a support ticket via https://evernote.com/contact/support/ and let me know the ticket number? Please include an activity log in your ticket as well: https://evernote.com/contact/support/kb/#!/article/23394137.

 

 

Thanks for your support in getting this resolved.  It will be a very big help to those of us that like to store code snippets in Evernote.

I'm pretty sure this behavior exists for most, if not all, users.  Nothing really special about our environment.

Hopefully since you have been able to reproduce the issue, that will be enough for a formal bug report.

Link to post

Just to let you know that when I downgrade to version 6.06 (remove 6.07 and re-install 6.06), the issue can NOT reproduce any more.

Now what I can do is not to upgrade to 6.07 and wish it can be fixed in next release...

 

Thank you for the confirmation. Will you please open up a support ticket via https://evernote.com/contact/support/ and let me know the ticket number? We'd like to get some additional information from you and submit a formal bug report. 

Link to post

As I mentioned above, I got this issue when I am using Mac version 6.07. And issue can NOT reproduce after I downgrade to 6.06.

Today, when 6.08 comes, I upgrade to 6.08 and can still reproduce this issue. 

I submit the ticket #1000718 per Lawlitta's request. 

 

 

I don't see a support ticket under this number nor do I see one under your email address. Did you submit one via https://evernote.com/contact/support/?

Link to post
  • Level 5*

I am running EN Mac 6.0.6 on Mac OS X Mavericks, and when I paste code from Applescript Editor, the INDENTS are ultimately lost.

 

  1. When originally pasted into Note, formatting, including indents, was retained.
  2. I sync'd, and everything is OK.
  3. BUT, after I click on another note, and then back to this Note, INDENTS are removed.

This is very repeatable.  I've observed this behavior many times.

 

If you'd like, I can share this Note, that includes the AppleScript file.

Link to post

when I open https://evernote.com/intl/zh-cn/contact/support/I can not find a place to submit ticket (bug or issue report).

 

Then I notice following lines in JMichael's reply:

 

Bugs?             Submit Support Ticket  | How To Prepare Support Ticket 

 

I click the "Submit Support Ticket  " and submit the ticket which return me the number #1000718.

 

I remember the ticket submit form is in chinese, it is send to you your evernote chinese system (yin xiang bi ji)?

 

Don't you have a simple system to report bugs? there are lots of open source system (eg. Jira)...

Link to post

when I open https://evernote.com/intl/zh-cn/contact/support/I can not find a place to submit ticket (bug or issue report).

 

Then I notice following lines in JMichael's reply:

 

Bugs?             Submit Support Ticket  | How To Prepare Support Ticket 

 

I click the "Submit Support Ticket  " and submit the ticket which return me the number #1000718.

 

I remember the ticket submit form is in chinese, it is send to you your evernote chinese system (yin xiang bi ji)?

 

Don't you have a simple system to report bugs? there are lots of open source system (eg. Jira)...

 

If you visit https://evernote.com/contact/support/ and click on "Contact us for support.", you should be able to submit a ticket. Are you in China? Yes, it's possible you've submitted the ticket to the support system in that region. 

 

Regardless, the issue has been documented in our bug reporting system and we're on it!

Link to post
  • 2 weeks later...

Dear evernote support,

 

is there any progress with this bug?? I have been experiencing the problem for number of months and problem still persists. Currently I'm using v6.0.8.

 

I guess this is pretty critical bug for users who would like to paste e.g. some code snippets or basically any plaintext with indentation ..

 

Thanks for your feedback.

Link to post

Dear evernote support,

 

is there any progress with this bug?? I have been experiencing the problem for number of months and problem still persists. Currently I'm using v6.0.8.

 

I guess this is pretty critical bug for users who would like to paste e.g. some code snippets or basically any plaintext with indentation ..

 

Thanks for your feedback.

 

Hi there -

 

Progress has been made and an update with a fix will be released shortly. Please stay tuned.

 

Appreciate your patience!

Link to post
  • 2 weeks later...

Do you have instructions on installing betas or a link to downloads? I've got evernote installed via the mac app store.

 

You'll need to have the direct download version installed (from our website). This version is currently not available via the MAS. If you'd like, you can uninstall/reinstall.

 

You can make sure that your content is up to date and intact via your web client (sign in via www.evernote.com), and then uninstall the MAS version and install Evernote directly from our website.

 

Please let me know if you have any questions. 

Link to post

I just upgrade to 6.0.9 Beta 2 (on my Mac with osx 10.8.5).  My observation is that, the issue is FIXED and BE BETTER than the version before observing the issue.

 

Here is my observation:

1. The most important improvement is that, in previous version, one the content is paste in Note, I can not modify it (will lose all format immediately for any modification), but now I am able to modify.

 

2. Now when copy/paste any content, the content is well formatted with format (indent/font/size..) that I set for the default note settings. In previous version (before the issue occur), the content is formatted with format FROM the source (where I copy the content).

 

 

#1 is definitely what I dream for a long time for EverNote. But #2 may not please the user.  The perfect fix I expected should be keeping the all format of the content from the source while letting us modify it without losing the format.

 

 

Anyhow, this version did fix the issue that "indent lost". So I would keep this version and say "THANKS YOU" for your great work.

Link to post

 

Will you guys please update to version 6.0.9 Beta 2 and let me know if the issue persists?

 

Issue is still there on Version 6.0.9 Beta 2 (451485 Direct)

 

 

What's your support ticket number?

Link to post

I just upgrade to 6.0.9 Beta 2 (on my Mac with osx 10.8.5).  My observation is that, the issue is FIXED and BE BETTER than the version before observing the issue.

 

Here is my observation:

1. The most important improvement is that, in previous version, one the content is paste in Note, I can not modify it (will lose all format immediately for any modification), but now I am able to modify.

 

2. Now when copy/paste any content, the content is well formatted with format (indent/font/size..) that I set for the default note settings. In previous version (before the issue occur), the content is formatted with format FROM the source (where I copy the content).

 

 

#1 is definitely what I dream for a long time for EverNote. But #2 may not please the user.  The perfect fix I expected should be keeping the all format of the content from the source while letting us modify it without losing the format.

 

 

Anyhow, this version did fix the issue that "indent lost". So I would keep this version and say "THANKS YOU" for your great work.

 

Thank you for your feedback and I'm glad that you're no longer running into the issue!

 

I've tested this on my end and can confirm that the issue is no longer taking place. Note that I'm on Mac OS X Yosemite 10.10.3 and Evernote version 6.0.9 Beta 2 (direct download). 

Link to post

 

 

Will you guys please update to version 6.0.9 Beta 2 and let me know if the issue persists?

 

Issue is still there on Version 6.0.9 Beta 2 (451485 Direct)

 

 

What's your support ticket number?

 

 

Do not have one.

 

RamboWang is right, issue seems to be fixed in 6.0.9 Beta 2

Link to post
  • 2 weeks later...
  • Level 5*

The indent issue is NOT fixed in EN Mac 6.0.10, running Mac OS X Mavericks (10.9.5).

 

Initially, the indents are preserved.  But after a sync, the indents are removed.

Link to post

Interesting, as it seemed to be fixed for me in 6.0.10 EN (OS X 10.9.5). Then I upgraded to 6.0.11 and it's been fine for me so far as well ..

 

Now I would really appreciate to have more colors for text highlighting - not only one (yellow) ;-) .. I still not get why only 1 color is supported and if you need more, you simply have to do that in other app (e.g. in MS Word) and copy then back to Evernote. Anyway maybe now, when very important Evernote for apple watch is ready (I guess max. 0,001% of users will find usage for such an app at the moment) they would be able to concentrate on "less important" details like Evernote editor in desktop version etc. ;) (sorry for such a sarcasm, but that's exactly what I've been feeling about during long existence of the indentation bug, no real progress with the Evernote editor for a longer time .. and when I registered several updates of that important 'evernote for apple watch' app).

 

Many thanks for fixing the indentation issue anyway! :-)

Link to post

I can verify the latest build works for me.

 

@gru034 let's keep this issue about just the indentation problem as originally reported. If you want to make a feature request please open up a new forum post. Working for a product company I can tell you there's no more sure fire way to get a suggestion or request ignored than tacking it on to another post, it ends up getting lost.

Link to post

The indent issue is NOT fixed in EN Mac 6.0.10, running Mac OS X Mavericks (10.9.5).

 

Initially, the indents are preserved.  But after a sync, the indents are removed.

 

Did you open up a support ticket? Please let me know the ticket number. I'm happy to escalate it. 

Link to post
  • Level 5*

 

The indent issue is NOT fixed in EN Mac 6.0.10, running Mac OS X Mavericks (10.9.5).

 

Initially, the indents are preserved.  But after a sync, the indents are removed.

 

Did you open up a support ticket? Please let me know the ticket number. I'm happy to escalate it. 

 

 

Lawlitta,

 

Thanks for your help.

 

Note that this is with latest versions:

EN Mac 6.0.11

Mac OS X Yosemite (10.10.3)

 

Ticket# 1047098 - BUG: Note Loses Indents from Paste after Sync

 

 

 

EN Mac 6.0.11

Mac OS X Yosemite (10.10.3)

 

Steps to Reproduce:

1. Open AppleScript editor, and copy code that has indents

2. Create new EN Note

3. Paste into Note body

4. Observe that indents are retained.

5. Click on another note, then click on the original Note

6. Observe that indents are retained.

7. Click on Sync icon/button in toolbar.

8. After sync competes, observed that all indents are lost.

Activity Log file is attached.

 

Link to post

 

 

The indent issue is NOT fixed in EN Mac 6.0.10, running Mac OS X Mavericks (10.9.5).

 

Initially, the indents are preserved.  But after a sync, the indents are removed.

 

Did you open up a support ticket? Please let me know the ticket number. I'm happy to escalate it. 

 

 

Lawlitta,

 

Thanks for your help.

 

Note that this is with latest versions:

EN Mac 6.0.11

Mac OS X Yosemite (10.10.3)

 

Ticket# 1047098 - BUG: Note Loses Indents from Paste after Sync

 

 

 

EN Mac 6.0.11

Mac OS X Yosemite (10.10.3)

 

Steps to Reproduce:

1. Open AppleScript editor, and copy code that has indents

2. Create new EN Note

3. Paste into Note body

4. Observe that indents are retained.

5. Click on another note, then click on the original Note

6. Observe that indents are retained.

7. Click on Sync icon/button in toolbar.

8. After sync competes, observed that all indents are lost.

Activity Log file is attached.

 

 

You bet. I've escalated your ticket to urgent status and a support representative should reach out with help shortly. Thanks for your patience!

Link to post
  • 4 months later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...