Jump to content

Sharing notebook (Premium to Free) - problem with certain destination email address

Recommended Posts

I'm revisiting sharing notebooks, something I've done sparingly up until now. Of course it's all changed and it's all Work Chat now. I can remember when it was all fields.


My scenario is to share a notebook from my premium account to a non-premium colleague.


To test this I tried sharing the notebook from a Windows client using my home premium personal address to another email address - my Exchange one at work.


I right-clicked on the notebook name, selected Share Notebook, and entered my work email address. This appeared to go ok although some of the terminology strikes me as a little odd; I don't want to chat, I want to share. But I guess that's just semantics.


I checked my email account at work and found an email saying:



Dougie Nisbet shared a notebook with you
Dougie Nisbet is using chat to share work with you. Click below to read and reply to this chat.


This was all looking quite promising so I clicked on the link and, as expected, had to create a new Free EN account.


However, after doing that I could find no sign of the shared notebook.


I tried repeating the process but that got a little messy and confusing and it wasn't at all clear if anything was being sent. I'd enter the email address again and click on Send and nothing would happen.


So on a hunch I decided to try with a different (new) email address. I repeated the process, this time sharing the notebook with a gmail address I have.


Same thing, got the email, clicked on the link, opened up a browser, created a new free EN account. And that worked just fine. I could see the notebook.


So .... some sort of problem with the first (Exchange) email address then? Perhaps I'd mistyped or got something wrong that I was unaware off.


I tried to repeat Sharing the notebook to the Exchange address but nothing would happen. No useful feedback, diagnostics, or activity I clicked on Send. (attachment 1)


So I had a look at the Modify Sharing options. This doesn't recognise my exchange address, but does see my gmail address. (attachment 2)


I tried Sending Reminder by clicking on the incongruous 'User Name' entry (it ticks itself) (attachment 3) only to get the slightly strange error that User Name is not an email address (attachment 4)


Ok so I'm guessing at some sort of EN bug here. I switch if off and on again (I do work in tech support) but that doesn't fix it, so I'm out of ideas. Perhaps it's the platform?


I try sharing it on my Mac - the OSX seems a bit cleaner and looks promising, but no email appears.


On a hunch I log into my account on the web interface and try sharing the notebook from there. This gets a bit interesting when I enter the email address, producing the error

"You have entered an invalid email address". (attachment 5).


I'm not sure what's going on here but I suspect there's some corruption somewhere in my account in its treatment of the storage of the exchange email address. I've done some more tests with a couple of other accounts, setting up new free EN accounts and they're fine.


As a final test I've just repeated the whole thing with a fresh Exchange address, tested it, and that's working fine!


Right, (forgive me for showing the unreconstructed workings of my head but this has been driving me nuts all day and I'm trying to work through it all again methodically to reproduce it ...)


So back to the original dodgy exchange address. (The one I want to work). I'm unable to reshare the notebook to it.


Logging in to that account shows it can't see the notebook.


In summary, I seem to have an email address that EN thinks is in the twilight zone. Can I delete it and start again?











Link to comment
  • Level 5*

Hi.  I think the system is confused because of the random "user name" box you have in some of those screens.  AFAIK you should only see the email(s) you're sharing with,  plus the name of the notebook.  I think the problem with sending is because (obviously) 'user name' isn't a valid email address.  Next time you try to share,  try deleting all email addresses and any other comments from the box except for the notebook name,  and then add back the address you're sharing with.

Link to comment

Yes I think the 'User Name' box isn't helping although I don't know whether it's actually the root problem. Perhaps it's associated with the dougien@balticmill.com address. I can't see how to remove it.  Repeating the Share Notebook (or Modify) process does not offer any options to remove email addresses.

Link to comment

It's not possible to select the entry on its own when selecting 'Share Notebook'. Ticking the checkbox for 'User Name' selects all the other tickboxes at the same time. It isn't possible to select just 'User Name'. Furthermore, there is no option to delete an entry in the 'Share Notebook' dialogue. Pressing Delete or Backspace has no effect.


If I investigate 'Modify Sharing', the problem email address dougien@balticmill.com is not displayed (attachment). However trying to share to this email address causes the errors described.


This is on Windows. I've had similar lack of success in OSX and the web interface.


Link to comment
  • Level 5*

So - I went through the sharing process from one email address to two others,  but couldn't find any way to derail the process.  I accepted the invitation from another account and found my test notebook easily.  I don;t know of a way to test if there's an issue with this email address unfortunately.  As a premium user you can get some help over the Chat option after reporting a problem here - https://evernote.com/contact/support/  

Link to comment

yes, good point. Ironically the problem email address isn't having any practical impact as it's something I only attempted to test sharing. Like you, I can add new and share with new user accounts without a problem so I'm rather puzzled about what has gone so awry with this particular email address. I shall log a support ticket.

Link to comment
  • 2 weeks later...

Hello Doug,


I just tried with the latest Windows client.  While I was able to share, I was also able to see the User Name entry.  The "send reminder" feature shouldn't be there and is a bug.  I don't think this is the root of the issue though.  I will report this issue to our Windows PM.


To further diagnose the issue, try the following:


Is the first email address you sent to your registered email address for your Premium account?

To verify this,  login to your web client and go to:  Account Settings > Profile and scroll to the bottom of the screen to the Email addresses section


If you see multiple emails that you don't expect to be associated with your Premium account, this is probably the reason why your first Free account isn't getting the notebook sharing.


The way Work Chat and sharing via Work Chat works is by tying permission information to what we call identities.  An identity can be an email address or phone number.  Its just a means to identify someone via a communications channel.  


When you first share or invite someone to Work Chat, we need to safely bind that identity to an Evernote account.  Normally this shouldn't be an issue since you are sending to another person but when testing with yourself you need to be careful you don't claim the identity with the account from which you sent the original invitation.  This can happen if you click on the link and happen to be logged into the web client in your browser.  You should be able to see these identities in the Profile section of the account settings page.  


If you do see an email that shouldn't be associated with your account, you can just click on the Remove link below the email.  This may not provide any feedback (bug is filed) but it should disassociate the identity from your account.  I believe you can reload the screen to ensure that it is removed.  


Once this is done, you can re-share and it should work.  

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...