Jump to content

Notes take 10 minutes to show up in Web

Recommended Posts

Notes created in any client (mobile, desktop, Scannable, or web) show up immediately in the desktop or mobile clients, but don't show up in the notes list for at least 10 minutes in the web app. Even if I create a new note in the web app, it doesn't show in the list in the web app, but it will show up in the desktop app.

  • Like 1
Link to post

Any ideas? This is starting to make Evernote unusable for me. There's currently a note that I created in scannable 27 minutes ago that is in my iPhone Evernote but won't appear in Web.


EDIT: It's been 6 hours and that note has still not appeared in Evernote Web.

Link to post

It's been very inconsistent for me lately... sometimes the note appears immediately, and sometimes it takes a few minutes to update. I can't find a pattern.

This happens with new notes and when moving notes.


The only thing I can think of is that the web beta's updates go through a different server than the release version, and takes them a bit of time to sync. If this is true, then there's nothing we can do about the issue as users, and Evernote has to do some improvements on their side.

Link to post
  • Level 5*

1: are you sure that notes are being synced to Evernote properly? For example, on the Windows client you can check Help / Activity log to see whether there are sync problems. BTW, the initial 10 minutes noted might be explainable by your desktop client's auto-sync behavior. Unless you're manually forcing a sync, then waiting to see when it appears to the web client, that may be the initial cause, and the long long wait time (the scannable note) may be a separate issue.


2: For the supposition that Evernote is using different servers for the standard web client and the beta, that should be easily testable by checking with both. I'm doubting that this is the case, however: Evernote is not keeping separate versions of your notes database on separate servers just to accommodate the web beta; both web clients are accessing the same note database, and probably using the same Evernote API.

Link to post



I created the note in Scannable, which means for it to appear in my iPhone Evernote app (which it does), it has to have uploaded to the server. Actually, I tried reverting to the old version of the web client, and the note is there. Which means that it's an issue with the Beta app not showing the note for some reason. So perhaps the Web beta is not properly refreshing/accessing my data on the note database.

  • Like 2
Link to post


Refreshing does not help.  Changing notebooks on a note often leads to no movement to the correct notebook.  Sometimes the only place to view the new note is in All Notes because it doesn't appear in the original or subsequent notebook.  I've tried to be cognizant of the sync cycle when a note is modified.  It appears to sync correctly (little green check mark) and still the note does not move.  Refreshing after one or more of these steps doesn't help the problem.


Today, as I clipped webpages, they were not deposited in the assigned notebook.  I could only see them in All Notes.  But the notes had the correct designation they just didn't land where they should have.

Link to post

A little bit of background to help get to the bottom of this issue:


All of our (native) clients use the same service backend as the web client (both beta and old). Clients sync directly to the server every so often or when you hit the sync button. The web client is synchronous - meaning any changes you make there are reflected on the servers immediately (caveat: the autosave on the note you're currently editing is on a timer in your browser). Keep in mind that you'll have to sync your client to see changes made on web, and you'll also have to refresh the web client (in most cases).


Keeping that in mind, here are a few things you can try:

1. Make sure the app where you made the changes/created the note is synced. You can view it on web to see if the changes have been applied to the service. There should be no difference between the old and beta web clients - note that you should be looking at the same filter in both cases (e.g. "all notes" or notes in a specific notebook).

2. If you're fully synced and you still don't see the notes in the web client, go to all notes and make sure that you're ordering notes by last created or last updated. Try scrolling up and down a few to ensure that the note is actually missing. Make sure you have refreshed the web client.

3. If you still don't see your notes on the web, there's a possibility that your search index is corrupted. This is pretty rare but is possible - the simplest way to test this is by copying either the public share url (it should be in the share dropdown - you can always unshare the note later) or copying the note link using one of the native clients. Try navigating to that url in your browser - if you see the note there and you're sure it's not showing up in the web client, there is a chance that your search index is corrupted. You'll need to contact support and have them trigger a reindexing of your account - it's a fairly computationally intensive process so we restrict the frequency of reindexing. Our servers also do search index corruption detection and reindexes accounts that it can identify.

  • Like 1
Link to post
  • 1 month later...

Yes - I can confirm that I'm still facing this issue.


While I was in the Notes list (i.e. all notes), I created two notes in my default notebook. I got the messages saying that they were created in the default notebook, but I cannot see them in either view (default notebook or all notes).

This was over 10 minutes ago. I can see them on my Android device, but still nothing in the Web Beta.

Link to post
  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...