Jump to content

Persistent sync error

Recommended Posts

Syncing my account shows a sync error icon at the top of the screen but there is no way to know which Note is causing the problem.  I have generated a lot of content on my desktop and only some of it is being synced to the cloud.  I can generated and sync all content on my iPad and iPhone using the same wireless connection.  There seems to be an issue with notes created using the web clipper predominantly but not exclusively.  What used to be a rock solid platform is now extremely unreliable.


Can you define a marker for notes that have not synced or provide a dropdown list of the notes in error so they can be investigated and corrected?  How else do i fix this problem?  I have cleared my Trash folder in the hopes that the errror was ther but to no avail.


Here is the offending lines from the Activity Log, everything upstream of this apears to be syncing correctly.


06:12:35 [5964] 42% Submitting a batch of 10 note calls, size=1.2MB
06:12:36 [13912] 42% Submitting a batch of 17 note calls, size=1.3MB
06:13:32 [13912] 42% No more data to read.
06:13:55 [5964] 42% No more data to read.
06:13:58 [13436] Client synchronization finished, status: failed
06:13:58 [13436] * 4 items received
06:13:58 [13436] * elapsed time: 1m 36s



Link to comment

Good morning from the UK Rod and welcome to the forums,


It would be a good idea to put the version of software you are running.


I have seen this happen again recently with version Continued clicking on the 'Sync' button seems to eventually get rid of it.


Best regards



Link to comment

Thanks Chris


I'm running the latest version of the Windows app  Reading through the activity log even further i'm seeing new errors coming up, specifically about missing notes (i believe).  The iPhone and iPad version of the databasse are in sync with the cloud but the Windows desktop version has a lot of notes that will not sync because of these constant failures.  Now I'm in the highlands of Papua New Guinea so the internet is more of an information super goat track here, but unless i can eliminate these offending files from the database i will never be able to syncronise these notes.  For example resource "7" does not exist on any of my devices or the cloud but the system is trying to download it.


Can anyone offer any way of correcting this issue?


05:33:10 [3068] 74% Submitting a batch of 9 note calls, size=1.3MB
05:33:24 [3068] 74% EDAMNotFoundException: id="Note.guid" key="25900571-e6a7-482c-94f3-a66035786971"
05:33:24 [3068] 74% Retrieving 8 resources
05:33:24 [3068] 74% Retrieving resource "7"
05:33:24 [3068] 74% * guid={2a7d7e82-a7d1-49c6-978d-03a3abb7f2b2}
05:33:24 [3068] 74% Retrieving resource, total size=986124
05:33:24 [3068] 74% * guid={2a7d7e82-a7d1-49c6-978d-03a3abb7f2b2}
05:33:24 [3068] 74% * note={48d1aecc-7ee2-4789-a2d3-7e24475efa91}
05:33:24 [3068] 74% * resource data, size=985483
05:33:24 [3068] 74% * resource recognition data, size=641
05:33:24 [3068] 76% Retrieving resource ""
05:33:24 [3068] 76% * guid={c7dfc015-5546-46d6-9f27-b1e046064bff}
05:33:24 [3068] 76% Retrieving resource, total size=110420
05:33:24 [3068] 76% * guid={c7dfc015-5546-46d6-9f27-b1e046064bff}
05:33:24 [3068] 76% * note={48d1aecc-7ee2-4789-a2d3-7e24475efa91}
05:33:24 [3068] 76% * resource data, size=106132
05:33:24 [3068] 76% * resource recognition data, size=4288
05:33:29 [3068] 77% Submitting a batch of 2 resource calls, size=1.0MB
05:33:29 [3068] 77% EDAMNotFoundException: id="Resource.guid" key="2a7d7e82-a7d1-49c6-978d-03a3abb7f2b2"
05:34:19 [2636] Client synchronization finished, status: failed

Link to comment

Hi Rod


I am having the same problem, and it has been an ongoing issue for me since some time in November - seemed to occur after I had updated from 5.6.4 to 5.7.2 to (274061).

I have a mission-critical (and revenue producing) application based on Evernote which primarily runs on my desktop but also needs to sync to one or more laptops.

For a while at the beginning of the week, none of my systems would sync, now at least my desktop synchronises - but my laptops still refuse to synch - they seem to partially sync, but never quite catch up with my desktop.

This seems to be a Windows problem - I notice you report that your iPad and iPhone sync OK - and the copy of Evernote I am running on an Android tablet seems to be syncing OK but owing to the screen size, it really doesn't work as a production system.

I have at least managed to open a ticket with support and have sent them Activity Logs - but so far no substantive response (apart from the automated response "we have received your request" and the allocation of a ticket #).

I don't think I am working quite as near to the edge of the earth as you are, but I still have some ongoing ADSL problems, although I don't think this is the problem - have tried 3G (still won't sync) and have also tried hardwired ethernet rather than a WiFi connection, and that doesn't sort the problem out either. Other applications I have working in the cloud (eg. Dropbox) seem to work fine - so it does rather seem (by a process of elimination) that this is an Evernote problem - and it's disappointing that nothing seems to be happening to resolve the issue (particular since I recently ponied up a year's subscription to beceome a Professional User!).

If I get any response to my open ticket I will share it with you here.




Link to comment

Thanks for the response FerociousFeline, I look forward to any updates.


I'd just like to add to the anomalies i am seeing in this sync issue

  • notes created or edited on my iPhone or iPad are able to sync across all devices (including my laptop)
  • notes created or edited on my Windows laptop are never seen on other devices

Given that, and the information below, I'm starting to believe that the Windows version of the database has been corrupted resulting in unreadable content.  It is therefore not able to share that information to the cloud.  Now this may be a single note or a range of notes.  I think my only option is to determine which notes are out of sync with the cloud and export them as an enex file for import again later.  It's not a simple process so any input from Evernote Developers would be appreciated - hint hint.

I did export a series of notes earlier and this took the sync from 47% when it crashed to 71%. 


Is there any way to map the GUID numbers in the activity log to a single note?  Since i can see the GUID of the offending note this would certainly help.  Anyone?


Link to comment

Hi Rod


No response from Support (which, as a Professional User does not impress me too much) but I do rather think that between the two of us, we have rather nailed this down to a Windows-specific problem - you are OK with iPad/iPhone, and I'm OK with Android. So now the question that begs to be answered is whether the database corruption is server-based or client-based - and since we are both syncing OK on non-windows platforms, I am inclined to think it might be a client-based problem. Out of the swirling mists of the past I do seem to remember deleting the entire Evernote Data Folder off one of my laptops, and replacing it with contents from the Data Folder from my desktop - and that seemed to solve the problem.

This is not something I would be too willing to do on an operational system, but I do have a couple of laptops that are no longer operational but which are running Evernote - so I think I will try this on one of them to see whether it breaks the log-jam. I'm not about to try it right now (local time is nearly midnight and I am tired and have just got back from dinner), but I'll try it in the morning and get back to you.

As I indicated earlier, I am somewhat less than impressed with EN's lack of support, but I really don't feel like re-engineering my operational system onto another platform at this particular moment in time.

Link to comment



I am getting closer here. 

  • I tracked down one note that was causing issues using its GUID and deleted it from the system
    • This meant the sync could get up to 86% before it crashed
  • I found the next note and the problem list and from the resources list the particular photo in the note that was causing the issue.
    • I tried deleting the photo and resync – same issue
    • I exported the note to an enex file and then deleted it – same issue.  In fact the system is still telling me the note is there.   It has been deleted from the Windows machine and from the rest separately.  There must be corruption in the Windows database for it to look for a file that doesn’t exist.  It was removed from the trash file.
  • Closer but still stuck with a database that will receive files from other machines but cannot sync notes created locally to the cloud.  I go back to my original statement that the local database is corrupted and needs to be repaired for this to work correctly.
  • Tonight I will try syncing my MacBook version of the DB to the cloud to see if there are any issues – if not I can definitely tell where the problem is.

Wish me luck.

Link to comment

OK, to add the final update to this saga

  • Sync to and from Evernote on the MacBook worked flawlessly
  • Sync to and from iPhone works
  • Sync to and from iPad work
  • Sync to and from Windows laptop has persistent errors that crash the sync
    • All attempts at sourcing and removing the offending note(s) have ultimately been fruitless
    • The error is pointing to a note that has already been removed from the database - note={25900571-e6a7-482c-94f3-a66035786971}
    • I include the offending parts of the Activity Log in the hopes that someone from Evernote can point me in the direction of a solution
    • 05:19:02 [1168] 88% Retrieving resource, total size=619963
      05:19:02 [1168] 88% * guid={4d45d4b8-8c91-4cb0-8f9b-1b912b71346f}
      05:19:02 [1168] 88% * note={25900571-e6a7-482c-94f3-a66035786971}
      05:19:02 [1168] 88% * resource data, size=615229
      05:19:02 [1168] 88% * resource recognition data, size=4734
      05:19:05 [8184] 89% Submitting a batch of 2 resource calls, size=1.1MB
      05:19:05 [8184] 89% EDAMNotFoundException: id="Resource.guid" key="2a7d7e82-a7d1-49c6-978d-03a3abb7f2b2"
      05:19:06 [1168] 89% Submitting a batch of 10 note calls, size=1.4MB
      05:19:09 [1168] 89% EDAMNotFoundException: id="Note.guid" key="25900571-e6a7-482c-94f3-a66035786971"
      05:19:12 [5452] Client synchronization finished, status: failed
      05:19:12 [5452] * 6 items received
      05:19:12 [5452] * elapsed time: 38s
  • What is a EDAMNotFoundException?  Why does the sync crash on this point and not simply accept the error and move on?
  • I now have a Windows database that has about 75 notes that are not synced to the cloud, although i have no way of determining exactly which notes are in limbo.  If it was as simple as having a list of the offending notes then i would simply export them all to an ENEX file and reimport in a functioning database.  But as it is i am guaranteed to miss an important note doing it manually.
  • HELP Evernote Developers.......
Link to comment
  • Level 5*

The Support team don't respond to help requests through the forums - please see here for support tickets - https://evernote.com/contact/support/  - there's a Chat option for premium subscribers.


However - if you open Evernote and go to List View,  you should see all your notes.  One of the column headings is Sync.  If you don't see it,  right-click in the column heading bar and choose that option from the list.  If you sort that column by clicking on the heading,  you'll get some entries with dots in that column sorted to the top.  They are your unsynced notes.  If they're in different notebooks,  add a temporary tag with the notebook name to each note (you can select a group of notes and add a tag to all).  Export those notes to an ENEX file - check the options when exporting to ensure that tags are included.


The Sync column doesn't identify notes store in Local (unsynced) Notebooks - if you have any of those notebooks,  export all their contents to separate ENEX  files.


Then (in Windows) just find your Database folder.  File > Exit Evernote and rename that folder to Database.old.  Restart Evernote and the database folder will be recreated from the server.  It can take a while...

Link to comment

Hi Rod


Just to report back on my post #7 above:


My Desktop system seems to be syncing OK now (which is a big relief because that's where most of my work happens). Pulled out one of my older laptops, and that would not sync - got to about 42% and then failed - no great surprise.


So, followed the following procedure:

  1. Shut down and restarted both systems (this is to make sure that EN actually shuts down - also, go to Tools -> Options -> General  and uncheck "Launch Evernote at Windows login"
  2. Also in Options -> General I have relocated my "Evernote local files" into a folder within the "Documents\My Documents" folder (This simply makes them easier to get at (rather than having to burrow into "Program Files (x86) folder" on my C: drive - also makes them easier to back up)
  3. Without starting Evernote, I copied the folder \Evernote\Databases on my Desktop system onto a flash drive
  4. Transferred flash drive to my laptop, located the Evernote folder, and deleted the database folder on the laptop's hard drive, and replaced it with the database folder from my Desktop system.
  5. Started Evernote on the laptop, and it picks up newly copied database folder (I think I may have needed to enter my Evernote password to get into it) - and Lo and Behold! - there are all my notes with the same note count as my Desktop system (1647 notes).
  6. What caused a certain amount of panic is that the list of Notebooks that normally appears in the left-hand pane wasn't there - solved that by going to View -> Left Panel -> Check Show Notebooks.
  7. Started Evernote on Desktop and modified a note, followed by forced sync
  8. On laptop, forced sync - and - Lo and Behold! - Modified note from Desktop was where it should be.

For the technically inquisitive - both systems are running EN, My Desktop is running Windows 7 64-bit, and the laptop is running Windows XP (yeh - well - I did say that it's no longer used for day-to-day operations didn't I?)


Now - this is not something I want to do every time I want to use Evernote on my laptop, and I'm not sure whether it would work if I copied the database from a Mac and transferred it to a Windows system (Apple always add a few files into their folders). But it does seem to have sorted out the corrupted database file on my laptop, albeit in rather a forceful way.


It certainly reduces my anxiety level somewhat - but it doesn't reduce my huge irritation that EN Support really doesn't seem to be doing very much at all. May be they are indeed beavering away trying to sort out the problem, and I respect gazumped's comment that "Forums are not the place to sort out specific user problems" - but this is such a wide-spread problem (I count five forums specifically raising the sync issue) that I really think that some input from Support to the forums would not just be a courtesy - it's an absolute necessity.


I am not a database specialist, nor am I a cloud support engineer, but I do rather wonder whether the EN development team have failed to build enough resilience into their communication protocols. I do know (or think I know) that Rod Dempsey lives somewhere near a goat track in Peru. I live in a metropolis, but am right at the end of four miles of copper linking me to to the local telephone exchange, and I am subject regular ADSL drop outs (the dial tone is there, but the ADSL just disappears). And it is nigh impossible to communicate with my Telco that this is Not Good Enough. 

With a wry smile, I note C6REW's comment (and also I think Gazumped) that if you keep hitting the sync button often enough, then eventually it all comes right. May be that's so, but I didn't sign up to pit my wits against a collection of 0's and 1's - I signed up because I actually need to do something rather more productive.

The other thought that crosses my mind is to wonder whether the folk in Redmond aren't actually solving one problem by creating a totally different problem with their first-Tuesday patches. I used to take an interest in what they were fixing, but now I just download and install - with my fingers crossed.


And on that philosophical note, I will take my leave and get on with some Real Work!

Link to comment

Thanks to all that have been helping on this one.  I've got some thing to try now after the input from FerociousFeline and Gazumped.  Up until this month i have been throwing informaton into Evernote on the assumption that everthing would work perfectly, it's only now that i realise that nothing is perfect and one cannot assume.

I am going to try exporting the enex file and importing into my MacBook database - can I do that???  This should then sync the info to the cloud and other devices.  I'll start small and work back from there. The connection speed at the edge of the goat track (in Papua New Guinea) would see me old and grey before i downloaded all again.  I fly home on Wednesday for a break so this may not be completed before then given my other commitments but i will update on the success or not of my efforts.

Lukim yu (see you later in tok pisin)

Link to comment

Ooops! That was bit of a gross geographical error - I would guess that it's pretty difficult to get further away from Papua New Guinea than Peru - but I would further guess that the state of their respective telecom networks could be similar (with a rapid disclaimer that no disparagement intended!). Maybe a quick attempt at synchonisation when you reach civilisation (!) would be interesting? Travel Safely!

Link to comment

Just in case you are reading this discussion forum and are suffering Evernote Sync problems yourself, please be aware that there are a number of other discussion forums dealing with the same problem.


Could I suggest that we all register collective displeasure at the apparent lack of support from Evernote on a single discussion forum? The one that seems the most active can be found at:




Look forward to seeing you there!

Link to comment
  • 2 weeks later...

For the first time since i started using Evernote back in 2008, I faced the dreaded sync issue. It started back in November of 2014 but I hardly noticed it much & attributed it various other factors as internet problems or system problems etc & usually a restart of the system or an idle internet connection caused evernote to sync properly. 


Since the 20th of Jan 2015, the sync has been problematic to the point where I believe my monthly upload limit of 60MB has been reached due to the sync being tried again & again & failing again & again with no reason being given. I checked the logs & still faced the same issue. Finally I was forced to search through the evernote forums & try everything that worked for others before I came to a temporary solutions. The steps I followed are listed below


1. Backed up the entire evernote folder & deleted the database & synced a new one with some success. (60%)


2. Uninstalled evernote & deleted all traces of it from the drive & from the registry.


3. Re-installed & re-synced the entire database with even more success. (90%)


4. I changed the view to list view to see which files were not synced & to gauge their sizes. 


5. I compared the files on the client with the ones on the web to discover the files which evernote couldn't sync.


6. I deleted those files off the web & the sync completed successfully.


7. Exported some files to the desktop & many other files were deleted off the client & removed from the trash also.


8. Went to options & moved the database from the default location to a new Evernote folder in Documents.


9. Clicked sync & the sync completed successfully.


10. Using the extension clipped 2 articles which were not syncing properly from the web to the client & tried syncing again with success.


11. Imported 2 evernote files from the desktop & tried syncing which failed again & again.


12. Finally resorted to continuously pressing the sync button for a while till the sync completed successfully. (was watching the activity log all the while)


13. End result - sync is still bonky & i have 2MB upload limit left for 21 days till the monthly reset.



Additional Info:


Running latest version of evernote on Windows 8.1(64bit)


Over 90% of files are clipped to evernote using the extension for Chrome


Close to 400 files are being synced over 7 notebooks (including Trash)
Link to comment

Deepest sympathy raghu102! I had much the same experience, starting at much the same time.

This problem is spread across several discussion forums (for example,


https://discussion.evernote.com/topic/80258-evernote-for-windows-582-beta/#entry339085  )

A number of causes have been suggested (very large indiviual notes ( >100Mb) and also poor network problems). Recently I have noticed some anecdotal evidence that Evernote Clipper and embedded URL's might be a partial cause of the problem. Rather than use Clipper, I am using an extension to Firefox called "Clearly" which seems "cleaner" than Clipper (though not quite as much control - you have to watch which notebook it saves the clipped article to and move it to the required notebook.

The other solution that worked for me is that I managed to get one system to synchronise, and then copied the database folder to another system that was persistently refusing to synchronise - and that solved the my problem. See note #15 above. And I am no longer having sync problems. I don't feel comfortable resorting to such techniques - but it has certainly saved me a lot of heartache.

From all accounts the Support Team are continuing to work on this problem - but it seems to persist for some users. I rather feel that slow connection speed is part of the problem. So I'm now keeping my fingers crossed that I am somehow back in business with systems that synchronise. However, continuous typing with my fingers crossed is very awkward - so I hope Support come up with a definitive fix Real Soon!


Good Luck!

Link to comment

Greetings all,


Update.  I removed the offending notes from the database on my work computer, as above, and took the exported file home with me.  I imported the file into the database at home and synced it back to the cloud.  I have checked the database on my computer at work and everything is now back online and up to date.



That said, why is this so difficult?  Evernote, you have a great product but this is letting the team down.

Link to comment

I am primarily using Evernote web clipper to save things to the server & syncing with 1 Windows desktop & 1 android phone.


The phone also had sync issues at the same time as the desktop version but after uninstalling & re-installing the app, it started syncing properly once I forced it to sync from 'Account' tab under 'Settings' in android. The desktop unfortunately still won't sync properly & takes multiple retries of clicking sync continuously to finally complete properly.


From all the threads & the multiple comments, it seems like the Evernote desktop client for Windows is the one having problems as I have narrowed it down below

1. The web clipper saves properly to the server & can be immediately viewed on the web client & the android app. 

2. The syncing problem is between files saved by the web clipper (server) to the desktop & new files created on the desktop to the server.


Since I use a single workstation for all my needs, the best option right now seems to work with the web clipper, web client & android app only.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...