Jump to content

Overzealous Tag AutoComplete


Go to solution Solved by BSR,

Recommended Posts

I have a bunch of tags with a common prefix "ABC-". If I am adding a tag to a note and type "ABC" I get a list of all of the tags that have that prefix and I can select one of the items in the list. But if I type the hyphen "ABC-" it autocompletes with the first full item in the list and now I have to backspace over a bunch of characters. There is no obvious reason why "ABC" and "ABC-" should autocomplete differently. This strikes me as a bug.

  • Like 1
Link to comment
  • 1 year later...

This. This right here. It drives me absolutely insane.

To reiterate the issue: When you type a hyphen into the tag field, autocomplete fires, accepting the top suggestion, injecting it into the tag field, and moving your cursor to the end of the line so you can begin typing the next tag. Well I wasn't done typing this tag! Why does typing a hyphen mean I'm done typing out a tag? Why would you assume the first alphabetical autocomplete option is the right one? It's a madhouse! A MADHOOOUSE!

In short: I expect to be able to type hyphens freely into the tag field without anything clever happening. Typing a hyphen shouldn't do anything automatically. I would expect autocomplete to fire when I type RETURN or COMMA or perhaps TAB. All of these seem pretty typical. Firing autocomplete when the user types a character commonly found in a tag name seems absolutely crazy to me.

Here's a video of me being driven to distraction by Evernote's overzealous tag completion: https://cl.ly/3N3h1k2K3N3d

(Also: This happens on all Mac clients but just so I don't get asked, I happen to be using v6.8 Beta 2.)
(Also also: This does not happen on iOS, where things behave as I would expect. Namely, the result of typing a hyphen is that autocomplete suggestions update, just as if I'd typed any other standard character.)

  • Like 1
Link to comment
  • Evernote Staff
  • Solution
On 12/29/2014 at 3:45 PM, LSS1 said:

Sorry..... you are right. I am using the MAC client, version 6.0.5, on Yosemite.

Hi there @LSS1; please try updating your EN Mac version and letting me know if the issue persists in version 6.7.1. However, since you are on version 6.0.5, you will need to use the following steps to get on the latest version as there was a known issue to our development team in updating from version 6.0.x where a reinstall is required to get on the latest version.

How to reinstall Evernote

20 hours ago, escapist said:

This. This right here. It drives me absolutely insane.

To reiterate the issue: When you type a hyphen into the tag field, autocomplete fires, accepting the top suggestion, injecting it into the tag field, and moving your cursor to the end of the line so you can begin typing the next tag. Well I wasn't done typing this tag! Why does typing a hyphen mean I'm done typing out a tag? Why would you assume the first alphabetical autocomplete option is the right one? It's a madhouse! A MADHOOOUSE!

In short: I expect to be able to type hyphens freely into the tag field without anything clever happening. Typing a hyphen shouldn't do anything automatically. I would expect autocomplete to fire when I type RETURN or COMMA or perhaps TAB. All of these seem pretty typical. Firing autocomplete when the user types a character commonly found in a tag name seems absolutely crazy to me.

Here's a video of me being driven to distraction by Evernote's overzealous tag completion: https://cl.ly/3N3h1k2K3N3d

(Also: This happens on all Mac clients but just so I don't get asked, I happen to be using v6.8 Beta 2.)
(Also also: This does not happen on iOS, where things behave as I would expect. Namely, the result of typing a hyphen is that autocomplete suggestions update, just as if I'd typed any other standard character.)

Hi @escapist; sorry to hear about the issue you are experiencing with the beta. Please route any issues you experience with the beta to our Mac Product Feedback thread for that version so our Product team can review it before the general release of 6.8.

https://discussion.evernote.com/forum/218-mac-product-feedback/

I appreciate your consideration and thank you for your patience. Let me know if you have any questions in the meantime.

Link to comment

Hi BSR... I have been running an updated EN for a long time -- my original post was in Dec 2014 (!!!!).

I am current at version 6.8 beta 2.... The problem has persisted through all of the versions.

Honestly it annoys me pretty much every day and it has for a long time but I had forgotten that I even made this post (18 months ago).

Link to comment
  • Evernote Staff
On 7/14/2016 at 5:08 PM, LSS1 said:

Hi BSR... I have been running an updated EN for a long time -- my original post was in Dec 2014 (!!!!).

I am current at version 6.8 beta 2.... The problem has persisted through all of the versions.

Honestly it annoys me pretty much every day and it has for a long time but I had forgotten that I even made this post (18 months ago).

Hi there @LSS1;

Thanks for reporting this. I definitely understand how this could be frustrating. Please direct any issues you are experience with the beta to the beta thread below so our Product Team can review it before the general release of version 6.8:

 

Thanks for your patience and cooperation!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...