Jump to content
Magnus Lindstaf

safari Text not clipped on some sites

Recommended Posts

Safari version 7.1.2 (9537.85.11.5)

Web clipper version 6.2.4 (fc552eb/1.1.0.775)

I run OS X with version 10.9.5 (Mavericks) 

 

--

 

I have an issue clipping certain pages, often recipe pages with an ingredients list. I always try to clip in "simplified article" mode, so I get all the formatting correct when I check the note on different devices.

 

A month or two ago, the web clipper started to act strangely. It stopped clipping the amounts of ingredients on a lot of sites (e.g. wouldn't clip "1" in the phrase "1 tomato") and now I've noted that it sometimes refuses to clip certain words altogether.

 

Take this recipe as an example: http://www.ica.se/recept/kryddkaka-med-lingonfrosting-718257/ (Sorry, it's in Swedish but I guess it's more or less the same formate as any recipe anywhere :) )

 

When clipping with "simplified article", it will clip all the ingredients except for "2 ägg" which is just lost. I've tried to take a look at the HTML to see if there is anything strange in the code, but "2 ägg" seems to be marked up with the same <span> as the rest of the ingredients.

 

Also, none of the amounts of the ingredients are clipped, which is annoying.

 

Do you know if there has been an update to the web clipper the last 30-60 days that has refined the algorithm on what is being clipped? Like I said, I've been starting to have this issue on a lot of different sites, both Swedish and US ones the last month or so.

 

Thanks for your help in advance, and have a marry Christmas! 

 

/Magnus

Share this post


Link to post

I think some pages that require a login have a setting that does not allow clipping...

Your attached webpage does have a log in option... So maybe its private content that you are not allowed to keep or 'clip'...

 

Is that a paid subscription web page maybe?

 

 

So you get a different clipping because you dont have access to save that particular article...

Share this post


Link to post

This is something that can happen depending on how well our algorithm parse the source page. I've logged this as a bug for improvement. No ETA at the moment. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...