Jump to content
  • 0

Evernote doesn't even connect

Alexander M.


Hello everyone,


I have been experiencing some issues with EN lately, resulting in a complete inability to connect EN to the internet on my mac.


My OS is OSX 10.10.1 and i tried the following on a Mac Pro and a Macbook Air:


EN 6.03

EN 6.04 b2

Webclipper 6.2.4

Safari 8.02



The issue is simple, yet bothersome:


Safari doesn't even load the evernote homepage, which I tried repeatedly with different internet connections.

All versions of EN that I tried out can't connect to the servers, giving me a timeout.

Webclipper gave syncing timeout and after reinstall can't log in anymore.

Tried deactivating any firewall component that might restrict access to no avail.


All browser features working perfectly well in Google Chrome from the same computers.


Any advice anyone please?

Thanks in advance,


Link to comment

1 reply to this idea

Recommended Posts

  • Level 5*

Sounds like more of a network and/or Internet issue.


I'd try the standard stuff:

  1. Restart your Mac
  2. Unplug/plugin all network cables -- make sure they are seated properly
  3. Restart your cable/DSL modem
  4. Restart your Router
  5. Restart your wi-fi router/access point
  6. Call your ISP support
Link to comment


This topic is now archived and is closed to further replies.

  • Create New...