Jump to content
Due to limited staffing, chat support will be unavailable from Thursday, July 2 at 5:30 PM (CDT) to Monday, July 20 at 8 AM (CDT). This will allow us to reply to your email requests as quickly as possible. Thank you for understanding. ×
  • 1
customer101

mac Autocorrect - Turn off on Mac

Idea

Hi,

 

Is there a way to turn off autocorrect on Evernote Mac?

 

When you're typing company names, it's often a "new found" name and it does not need to be autocorrected. Especially on the Mac. I know what I'm typing, even in high speed. On a portable device I can imagine autocorrect being more useful.

 

Otherwise, this would be a simple feature request:

"disable Autocorrect on Mac"

Share this post


Link to post

24 replies to this idea

Recommended Posts

  • 1

To remove this function, you will need to go into your Mac System Preferences > Language & Region > Keyboard Preferences... > Text > deselect Correct spelling automatically

 

This will turn off auto-correct across your entire desktop. 

  • Like 1

Share this post


Link to post
  • 0

Does evernote use mac's built in autocorrect? or does it just reference the setting? I have so many frustrations using Evernote when it autocorrects when I do not want it to. I do not have this frustration in any other mac application. I do not want to turn off autocorrect for the entire OS, just for this app. It seems silly that Evernote does not provide an override setting for this.

  • Like 3

Share this post


Link to post
  • 0

I agree. I think this is especially annoying for researchers (like me) who often deal with unusual words and need spelling to be precise. Please can Evernote introduce an override option for autocorrect?

Share this post


Link to post
  • 0

This was bothering me too!  But, good news: If you right-click anywhere in a note and mouse over 'Spelling and Grammar,' there should be an option titled 'Correct Spelling Automatically.' If you uncheck that, it should stop autocorrecting.

 

Happy typing! 

PS - I've only done this on a Mac, so no word on whether it would work the same on a PC. If anyone could confirm, that would be great!

  • Like 5

Share this post


Link to post
  • 0

EN Windows only has Tools > Options > Note > Check spelling as you type..  right-clicking a misspelled word gets you options of 'ignore' or 'add to dictionary' which then kills future flags for that word.

Share this post


Link to post
  • 0

I got here from Google looking for the same thing. FYI you can disable autocorrect for an individual note (I have no idea if this setting is sticky across devices - I'm only testing from my Mac for now but I have xplatform on Windows, iOS and Android).

 

  1. Make sure app focus is in the note itself
  2. Edit => Spelling and Grammar => Correct Spelling Automatically (click to uncheck that option)

I also found the same general menu has access to the spelling library, which may or may not be OSX global (I don't know). It does have ways to learn new words, which could potentially solve global issues with frequently mis-guessed autocorrect words. This is actually the feature I want as I am happy to add the occasional custom term to my library and thus leave autocorrect on.

  • Like 1

Share this post


Link to post
  • 0

I like the way other applications handle auto-correct on the Mac.   Hitting "Command-Z" (undo) after autocorrect changes something, will undo the autocorrect action.   I understand you can press "escape" to cancel the auto correct action, but the problem is you do not know that it is going to auto correct until it is too late (the response time for the dropdown list of spelling options is slower than other apps) 

 

I dont want to globally shut off auto correct on my laptop just to stop it within oneapp... (even though its an awesome app!)

 

Thanks evernote!

 

Share this post


Link to post
  • 0

+1 on the request for an app-internal setting to turn on or off autocorrect across notes. It's particularly problematic for those of us taking notes on topics with acronyms and jargon, or writing notes in multiple languages.

Share this post


Link to post
  • 0

Have you guys tried turning off spell checking and autocorrect by right-clicking on any word in a Note, and unchecking those items:

 

EN-Mac-6011-Spelling-Correct.gif

Share this post


Link to post
  • 0

Thanks for the suggestion JMichael. 

 

Turning off "correct spelling automatically" as you suggested fixed the problem. (I'll see if the setting stays across notes and after I restart EN, but I'm optimistic.)

 

Still, I think the functionality should be clearly listed under Parameters/ Settings.

  • Like 2

Share this post


Link to post
  • 0

I keep typing the name "Tarah" and Evernote changes it to "Sarah" every time.  Not helpful.

 

Thanks to all of you who pointed out the right-click menu fix.  Though I agree that it would be less confusing if there were a global setting to turn off autocorrect.  

Share this post


Link to post
  • 0

I don't mind spell checking and autocomplete, but you should be able to add words or acronyms and not have it constantly changing KML to what it THINKS you meant to type over and over.  it's really annoying!

Share this post


Link to post
  • 0

right-clicking a misspelled word gets you options of 'ignore' or 'add to dictionary' which then kills future flags for that word.

I like this; is there a keyboard shortcut for it?  ( EN disallows "gen'l", replacing it with "gentle")

FWIW some apps recognize when I reject a correction.  When I undo the apps correction or backspace to the auto-corrected word, the app "gets the message" that I don't want that word corrected.  I encourage EN adopt this function for Mac.

Share this post


Link to post
  • 0

No shortcut that I'm aware of.  You might be able to set up a script or use AHK or a text expander to carry out a series of keystrokes either to 'void' an incorrect correction,  or insert the proper word without the autocorrect second-guessing you... maybe?  Experimentation required I think for the work-around!

Share this post


Link to post
  • 0
On 6/20/2015 at 9:15 PM, JMichaelTX said:

Have you guys tried turning off spell checking and autocorrect by right-clicking on any word in a Note, and unchecking those items:

 

EN-Mac-6011-Spelling-Correct.gif

This helped for the text inside the editor. However, in the tag field autocorrection could not be turned off at the same time. Or where to turn that one off? 

I suppose there are more chances many jargon in the tag field than in the text field even you're only typing english.

 

Thanks evernote, please help to fix this. I typed "M". 

Snip20160222_6.png.bc911eefb65cc3ca53a4f

Share this post


Link to post
  • 0
12 hours ago, kangqiao said:

However, in the tag field autocorrection could not be turned off at the same time. Or where to turn that one off?

In the Tag field it is auto-completion that you are seeing, not auto-correction.

Tag auto-completion is an essential feature to make tag selection work accurately and fast, and many, if not most, of us rely on it.

I don't see the issue in your example screenshot:

  • It is showing a list of all tags that start with the characters you have typed so far
  • It has picked one that best matches what you have typed
  • If you want that tag, just press RETURN
  • If not, either keep typing for other matches, or just arrow down to the choice you want and press RETURN
  • If you want to create and assign a new tag, press ESC to clear the auto-completion, and type the name of the new tag.

 

Share this post


Link to post
  • 0

I like having autocorrect but wish it was easier to undo. A single key (or just CMD Z) to undo the correction would save me constant frustration at having to mouseover the word, right-click and undo it. ...and have to do that EVERY time I type the word (such as brand names and corporate lingo, both of which I use all the time).

And +1 for learning words and adding to dictionary automatically.

Share this post


Link to post
  • 0

I love Evernote, but the auto-correct that Evernote uses seriously needs some repair! It won't take NO for answer!
 It is extremely annoying. Thanks to those that suggested the workaround of right clicking on the note - spelling and grammar - turn autocorrect off.
Better would be:
1. A better functioning auto-correct spelling.
a. If i backspace and retype what I had, accept that!
b. If I hit Cmd-Z, accept that I don't want the correction.
2. Add an Evernote preference to disable auto-correct spelling.

But...as I said, I do LOVE Evernote. It's one of my essential apps!
 

Share this post


Link to post
  • 0

I'll second this as well - I don't want to turn off auto-correct, but right now it is WAY too aggressive in Evernote.  As other posters have said, it is far easier to reject corrections in other applications, where in Evernote it is very difficult.  I've resorted to typing the sentence, then going back to fix errors, being careful not to press the spacebar which will trigger a re-"correction".

Here's a very concrete example:

  • Type this:  Tukey
  • Press the spacebar, and Evernote "corrects" to "Turkey"
  • Backspace over the r, leaving just "Tu" and type "key"
  • Press the spacebar

In Evernote, "Tukey" is again replaced by "Turkey".  No matter now many times I take the above correction step, Evernote is steadfast that I'm wrong and it is right.  In Mail, which in theory uses the same Mac-wide autocorrect engine, "Tukey" is left and is underlined in red after my correction, which is the correct behavior

So, please don't add a special "disable spelling" for Evernote, just make it behave well as it does in other apps.  This is just a bug that needs to be fixed.

 

  • Like 1

Share this post


Link to post
  • 0

Another long-time user here. I've had this problem for a while, and a Google search lead me to this page. Glad I'm not the only one. It's incredibly frustrating when I take the time to spell someone's name right, only to have autocorrect fix it to something else. Maybe it is a Mac feature, but it doesn't seem to happen in any other app.

I just tried unchecking "Correct Spelling Automatically." After a quick test, that seems to work in notes. It doesn't seem to work in the web clipper.

Share this post


Link to post
  • 0

Another +1 for this working better; it's a constant frustration to type an abbreviation like mds and have it correct to mrs _after_ i leave the word, and then for evernote to practically insist that i do not really mean mds. turning off auto-correct per-note does not work for me as 1) that's tedious and 2) i do actually want it to correct real mispelings ( <-- like that one). Word used to have a second setting to automatically correct common things like teh or hsa for you, if you were prone to those; this was customizable from the user end like a customizable dictionary, and I found it highly useful. Not useful enough to go back in time and look for it, haha.

Summary: please, please, a global setting for turning off auto-correct my spelling, for the entire app, in its various iterations. Which, given my day job, means that I understand that this will require lots of code changes. Sorry about that...  ;)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...