Jump to content
  • 0

Evernote 6 Mac - any tag search in notebook not working



I upgraded to EN 6 a couple of days ago.  I have just upgraded to 6.0.3 and this problem is still present.


I have a number of saved searches that are in the format

   Notebook:<notebook name> any: Tag:<tag name> Tag:<tag name>


(That is, any documents in this specific notebook that have any of these tags)


These searches now all return the notes that are in the specified notebook OR have any of the tags.


I also tried doing the same thing manually.


Search for <tag> returned 462 documents.

Search for <notebook> <tag> returned 403 documents (so 59 documents not in <notebook>)

Search for <notebook> returned 2954 documents

Search for <notebook> any: <tag> returned 3013 documents (include 59 documents not in <notebook>)

Adding another <tag> on the end jut makes the error worse


These searches were working fine until I upgraded.


Has the search syntax with ANY: been changed?

Link to comment

5 replies to this idea

Recommended Posts

Are there any plans to fix this?  Where does it fit on the development schedule?


I can't recall what version I was using before I upgraded (it was whatever I had downloaded from the Mac App Store).  So I guess yesterday was just a bad day for me.   Not only did I get all the issues of a ".0" release but also a few older issues that I had missed.  Off to rework my workflow (again) ... sigh.



Link to comment


I have just tried to implement a "notebook:<notebook name> any: tag:<tag name 1> tag:<tag name 2>" search after reading about the syntax within the forums, but was frustrated by it returning items outside of the notebook. Now I see it's a known issue. It makes sense for the any: command to work only after the notebook: command, so if this is fixed it would be helpful. 

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...