Jump to content
  • 0

Corrupt File - error on MAC



Running Evernote 1.5.2 - Mac Snow Leopard 10.6.2 - been having no problems to date. No apparent reason on startup got following error:

The file “Evernote.sql” couldn’t be opened because it isn’t in the correct format.

The file might be corrupted, truncated, or in an unexpected format.

Sync on the web is intact thankfully.

Anybody got a fix for it please?

Link to comment

4 replies to this idea

Recommended Posts

Please try the following:

Please try moving your Evernote database directory so that Evernote will regenerate a new local database by copying your notes back down from the service. To do this:

Quit Evernote.

In the finder, open the "Library" folder in your home directory. (This is in the directory with your name, NOT at the top level of your hard drive.)

Navigate to "Application Support"

Move the "Evernote" directory from that location to a different place (like the desktop)

Start Evernote, provide your username and password again if needed

This will synchronize all of your notes from the service and create a new local database.

*If you do have some unsynchronized notes, you can go to the Note List view, sort by the "Sync" column, and export any notes that have a * in that column to .enex format before following the above instructions. Once those instructions are finished, you can then import the .enex files you created to restore these exported notes.

Link to comment

I had exactly the same problem today and Engberg's solution worked perfectly for me. Many thanks! :D

My problem occurred after trying to web clip a page using the Firefox Evernote add-on. Something went loopy and the page started to be clipped multiple times. The only way I could find to stop it was to reboot, very unusual on a MAC!

Link to comment

I recently experienced the same problem with a corrupted Evernote.sql file. But my problem is that I do not sync my notes online, so I could not use that solution. Instead, I tried the approach described at MacWorld for repairing Safari sqlite database files. The procedure is described here:


Of course, you need to substitute your Evernote.sql file in the proper places (some basic knowledge of Terminal is necessary). And I performed the dump on a copy of it rather than the original, and then moved the repaired output file into place. Depending upon how you launched sqlite3 you may need to repair the owner:group (using sudo chown) on the output file for Evernote to see it properly. But this worked fine for me. Now my Evernote.sql file loads correctly and all of my notes are back in their correct Notebooks. I hope this helps other users who have had the same problem.

Link to comment

I had the same problem today but not sure why it happened. I opened Evernote in my iMAC running Maverick and could see the notes but could not access any notebook. I did something different to the recommendations above. Just use your time machine and restore the Evernote folder in your user Library (not the computer library) from a week earlier. It worked perfectly and I only  had to synchronize the few new notes that I had from last week (not the entire library). Hope this helps. 

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...