Jump to content

"Not a valid PDF" on Android and iOS


Recommended Posts

Hello, I am starting to work on my paperless system with Evernote premium. It has been going well except one problem.

 

A PDF file can be opened successfully with Evernote on my PC, but when I try to open the same file on my Android phone or my iPad, it can't be opened, mentioning "file is not a valid PDF". This problem only happens to one particular PDF file out of the manys in my database so far.

 

I wonder if anyone encountered such a problem before? What caused this and how it can be avoided? What I am worrying now is the other PDF files in my database... and also the reliability of using Evernote to store my database containing many PDFs :(

 

Link to comment

Jefito: the PDF can be opened on my PC, so at least on my PC it is not corrupted. I imported the file to Evernote on my PC, so i think it's the original imported file... so the file got corrupted when sync to the server? Can this actually happen? And I tried different apps opening the PDF, still no luck.... 

 

ScottLougheed: no it is not encrypted...

Link to comment
  • 3 weeks later...

Hi all

 

I have the same problem. Windows not problem, Android on Nexus 7 and other device with Android 4.4.2.

 

Tried to open with 5 different apps.

 

It seems that the evernote app is not downloading the attachment correctly or doesn't verify it after download. Because 1 out of 10 tries work, especially on smaller PDFs.

 

Anyway, quite annoying.

 

cheers

sto

Link to comment
  • 1 month later...

I have no problems reading PDF on PC, can send same file to both of my android devices and open with any reader except Evernote.  I am testing this and Onenote and Evernote great except this one issue but it is huge.  I get error I have wrong processor for architecture,  have not found any help for this error.  I have not dug that deep but if I can not make PDFs work across devices it is a showstopper.  Any hints on where to look would be appreciated.

Link to comment
  • 2 weeks later...

I, too, have this problem.  I believe I can reliably open the files with Skitch, however.  Unfortunately, Skitch is not a desirable PDF viewer.

 

Evernote appears to corrupt the PDF file BUT it's readable using the **Evernote** PDF reader.  On Evernote's part this is either sloppy or deliberate; either way it's infuriating.

 

Anyway, try opening the files with Skitch.  It's my work around.

 

 

Link to comment
  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...