Jump to content

Recommended Posts

No problems here. Newly entered text wraps to the note window size, and when I change the note window size after entering text, the text re-wraps based on the new size. 

 

What kind of text are you placing in the note? Are you copying it from some other application, or is it coming from a web clipping? Those might be more complicated and you might be seeing a big. My testing was  with plain, manually entered text. 

Link to post

For me it is all text ... plain text typed in as well as some notes I copied and pasted from a Skype chat ... 

I had those notes there previously before I updated this morning and they wrapped correctly ... but now, even if I just type in regular text, it will not wrap at the window boundary.

 

And when I tried to highlight the text I typed in to test the wrapping, the app slows down and beachballs  :-(

 

... and ... it's now crashing .... 

Link to post

Yep I restarted the App and did all the usual basic troubleshooting things ... it's weird there is just no more wrapping ... as I type the horizontal scroll bar just keeps going and that changes the "center of the page" so that all the center-aligned titles I have on my page are now pushed way out of view ... I'm gonna have to back up all my notes and move to Google Docs til the fix this

Link to post

Ewww, yah this is really bad ... Every time I highlight any text the app beachballs and stops responding .. then I have to Force Quit and it dumps a crash report .... this is a pretty bad update .... no other apps on my system are having performance problems and this happened right after I upgraded to the new version ... pretty sure this is isolated to the update at this point .... but it's definitely killing my ability to get work done today ...

Link to post

I have the same problem too after updating to v5.7.0 for Mac.

 

The text is not soft wrapping properly and extends outside the right border. Interestingly enough it DOES word wrap when you move the borders, but only outside a certain fixed width. Within that fixed width it doesn't wrap when you move the borders closer to each other.

 

I'm on a MBP with Yosemite 10.10, and it looks like this:

Dtn23cn.jpg

Link to post

Now I uninstalled 5.7 and went back to 5.6.2, and the problem I described in the previous post does not happen now. So it must be something that has been introduced somewhere between 5.6.2 and 5.7. Just FYI.

Link to post

I'm seeing the exact same problem with 5.7.0 that pcf reported, on Mavericks 10.9.5.  

 

I tried downgrading, but I got an error, "Your local Evernote data is being managed by a newer version of Evernote. Please use the latest version.".  I found some instructions on this site for clearing out local data by searching for that message, and I might try that later.

 

To be clear, as pcf stated, there is wrapping as long as the note window is above a certain fixed width, but Evernote is a lot less useful to me now that I can't open a note in a separate window and make that window narrow to fit next to whatever application I'm working in.

Link to post

pcf- thanks for the link to the older versions.  I got it installed and went back to the previous working version.

For Mac users, you have to delete the app in the /Applications folder as well as the Evernote folders and helper URLs in the /Library/Application\Support/ Directories

Then you can install an older version ... it does a data migration and then you're good to go

Link to post

I did some troubleshooting on the text wrapping.  I made a copy of a note with the problem and deleted all long URLs from the note, and then I was able to make the window narrow with no horizontal scrollbar.  Pasting a long URL into the note made the horizontal scrollbar come back.  

 

I think Evernote is somehow basing whether to use a horizontal scrollbar on the widest thing in the note, and then applying that decision to all the other paragraphs.

Link to post

riyi - interesting ... I'm guessing that any long string of text with no spaces would probably have the same effect ... Not that I want to "upgrade" and do any more testing LOL .... Seems like this would be a basic QA boundary test though ... before releasing a new build to customers ....

Link to post

With 5.7.0 and even with the downgrade to 5.6.2 - every time I highlight text in a note the application "beachballs" on mac for at least 30 seconds ... the performance of the app is terrible at this point ... practically unusable ... there seems to be a host of cascading issues here that are killing my productivity ... I spent 2 hours yesterday fixing this stuff and still having collateral issues

 

It's still a formatting issue, this time with adding Horizontal Rules to the page ...

I use a Horizontal Rule to separate my daily work objectives ... and lately the spacing on the Horizontal Rule is 3x what it used to be when you use more than one ... so I decided to copy a Horizontal Rule I used previously and the Evernote App goes into a 30 second lag while the app beachballs, just trying to copy a simple LINE.

 

The app has some SERIOUS FORMATTING ISSUES

 

If this keeps up I will need to move everything away from Evernote and find a new system.  I've been using Evernote for more than 3 years but this is getting ridiculous.

Link to post
  • 3 weeks later...
  • Level 5*

This problem is still there in 6.x version. Unreal. I'm getting tired of filing bug reports. It's never ending.

 

I agree, it's a PITA.   ;)

But it's the best way to put pressure on Evernote to make the fix.

 

So, I encourage everyone who has this issue to Submit a BUG report via an EN Support Ticket. In the Support Form, select "Report a bug, crash, or data lost", and start the Ticket Title with "BUG:  " to make it clear.  Reporting a bug should be available to all users, including Free Account owners.

Link to post

I feel like using EN is like having a second job in Quality Assurance given the number of bugs I've reported. We're having word wrapping bugs at this stage in an apps life cycle! Obviously nobody is doing any regression testing on this product even though so many people depend on this actually working. It's pretty ridiculous.

Link to post
  • 4 weeks later...
  • 4 weeks later...

I'm having the same issue, but discovered that selecting "Simplify Formatting" from the "Format" menu fixed my note. Not sure if doing this would have any other adverse effects for some types of notes (I've never used the Simplify Formatting option), but in my case it simply fixed the text wrapping problem. I suppose it does some refreshing/cleaning of the note's formatting which seems to fix whatever text wrapping problem was apparently introduced in a recent update.

Link to post
  • Level 5*

"Simplify Formatting" might be bad for any links you have in your text,  but it will retain the content of the web address.

 

Since this is a Mac thread, I'll report that I find that "Simplify Formatting" does NOT remove the HTML hyperlinks in Ver 6.0.3.

 

"Simplify Formatting" is just that, it simplifies the formatting, but does NOT remove all of it.  I find it is greatly helpful to cleaning up complex web pages that I have clipped.

Link to post
  • Level 5*

Wasn't sure of the effect,  hence 'might' - I have used "remove formatting" and temporarily lost important information from a clip that was link-heavy.  Good to confirm that 'simplify' isn't quite so extreme.

Link to post
  • 2 months later...

My text-wrap problem affected only one note in a notebook.  I SOLVED THE PROBLEM :) by finding that paragraph, selecting it, and choosing FORMAT>STYLE>CLEAR

 

Some character formatting was lost  (probably font name and size); the bad paragraph had been assembled from text clipped from various sources including the web.

 

If you don't have critical formatting, you could doubtless select all text in the note and clear style rather than identifying the bad paragraph(s).

 

I filed a bug report.

 

 

 

 

Link to post
  • 5 months later...
  • Evernote Staff

@J Black What version of Evernote are you experiencing this issue on? Is this affecting all notes, or just some? Have you tried any of the troubleshooting steps discussed above?

Link to post

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...