Jump to content

Setup error opening log file

Recommended Posts

When I try to run the latest installation file on Windows 8.1, I get


"(.\bootstrapper.cpp:915) 0x656:Error opening installation log file. Verify that the specified log file location exists and that you can write to it."


I have deleted all earlier versions, and am using a fresh download of Evernote_5.6.4.4632.exe. I would gladly create the required file location, but have no idea what it might be. Any clues would be appreciated - I really love my Evernote!!

Link to comment
  • Ex Employees

Please create a support ticket for this issue at www.evernote.com/support. Make sure you include the error message '"(.\bootstrapper.cpp:915) 0x656:Error

Once you've done this, please message back your ticket # for further review. 

Link to comment

Hi, Kelvinlamky - Many installation programs, including Evernote, create files that can often tell a software developer what a program was doing when it encountered a problem. Typically, these are called log files, such as EvernoteSetup.log and EvernoteSetupMSI.log.


I received an email from a support person at Evernote requesting copies of my log files, and for my case located them in C:\Users\<myname>\AppData\Local\Temp. This is a normally-hidden folder; to get there, you may have to modify your "View" options to see hidden/system files and folders. Once there, I found the Evernote log files, but could neither open them nor attach them to an email. To fix this requires some medium-level skills to take ownership of the files, which I did to provide full access to them. Once I did that, I had no problem restarting and completing the installation - and attaching the files to an email.


If this explanation helps, you can probably get your immediate problem fixed. If this explanation is meaningless, you'll need to wait until Evernote comes up with a fix. Hope it helps either way :-) KenNaples

Link to comment
  • 1 month later...

Was this ever resolved?  I have the same issue on Win 7 going back to August.  No resolution after several detailed efforts by Evernote support.  


Evernote Web is pretty, but it's not nearly as functional as the native app.  


No issues w/ my Mac OS or iOS devices.  

Link to comment
  • 1 month later...

Any help on this?  I'm having a similar problem on a Windows 7 Home Premium Service Pack 1 PC.  Evernote has been running fine until I tried to update to Evernote_5.8.1.6061.exe which seemed to install sucessfully to "C:\Users\"user"\Documents\Downloads\.  When I try to run the Evernote_5.8.1.6061.exe program it hangs and I get error messages:


  • "Error opening installation log file.  Verify that the specified log file location exists and is writable.", and

  • (.\Bootstrapper.cpp:915) 0x656:Error opeing installation log file. Verify that the specified log file location exists and that you can write to it.

I've tried:



Not sure what else to try at this point.

Link to comment

The issue remains in Evernote 5.8.1 (which now installs itself in "C:\Users\<MyName>\AppData\Local\Apps\Evernote\Evernote" instead of somewhere under "C:\Program Files (x86)" - but that's another issue entirely). If you really want Evernote, which I do, you need to locate the files for EvernoteSetup.log and EvernoteSetupMSI.log. The first clue will be when you attempt to open these - although they are text documents, you will not have permission to open them. The work-around requires some detailed trips down the security rabbit hole: you will need to take ownership of each of these files, then set "Security" permissions for the "Administrators" group to have "Full control". Evernote will then complete installation. Since pushing the wrong button during these steps can cause major havoc to your system, I'm reluctant to post any more detailed instructions. Clearly, this only affects a subset of Evernote customers, or the problem would be fixed by now. Too bad for those of us who are affected. Cheers!

Link to comment

H'mmm ... I performed a search on my hard (C:\) drive for both EvernoteSetup.log and EvernoteSetupMSI.log files ... on both searches Explorer comes back with a message "No items match your search" so I don't believe those two files exist on my system.


... so I'm still stuck.


Appreciate your help ... any other ideas of what to try?



Link to comment
  • 1 month later...

Just one more hapless user trying to get my updates back to a working status.  I see that the issue is now assigned to support ticket #737412, so maybe something will happen without me having to tear into my system, but I still have two questions.


  1. Is the current status of support tickets posted anywhere so that paying "customers" are not left floundering in the dark?  Or are we expected to just wait silently until the powers that be decide to throw a littlle information our way?  I'm just trying to say that their customers deserve to have what information is available.  That would help us to decide whether to wait or go it alone.
  2. I don't recall having an option to install in a directory of my choosing.  Is this my poor memory or the actual case?  The reason I ask is that I believe that my tags were wiped out by a maintenance program.  Am I wrong in thinking that this occured because the files are stored in the hidden "appdata"?  Something wiped them out and I didn't know where they were stored until after I started to research it.  Putting it in a hidden file may seem right for protection, but I would much rather have them in a place where other programs know to keep their hands off.  Is there a better place to install?
Link to comment
  • Level 5*

There's no way that I know of to check on a ticket status. The usual thing, in my experience, is for the support folks to take them up in order, and proceed from there. At this point, the impression from what people in the forums report is that it can be several days before you get a response, and you should factor in the fact that they don't cover weekends usually. If you don't get a response for a few days, feel free to post back here, and maybe we can help shake things loose.


The AppData folder in your Users directory is hidden by default by Windows; see http://windows.microsoft.com/en-us/windows-8/what-appdata-folder (also applies to earlier versions of Windows, I believe). Its express purpose is to hold application data. Other programs shouldn't be messing with it. The fact that it's hidden is just to keep people from casually accessing it from Explorer; it is a known quantity, though, so it's not intended as an actual security feature, more of a convenience.

Link to comment
  • 1 month later...

Dear all,


I have been struggling with this issue for a while now including a less enlightning intermezzo with the evernote support. But that is another story.


Today I downloaded the installer from the evernote website and wanted to give it another try. Launching the installer after the download threw the classical "log file not writable" / "bootstrap" error.


I came across this post and was able to locate the "log file" in C:\Users\<myname>\AppData\Local\Temp as KenNaples pointed out above.

I am not sure that this is the cure (as I tried several things) but Evernote installed the update without throwing any of the "log file not writable" / "bootstrap" error.


Working on a Windows 8 laptop with no admin rights i checked the properties of the logfile, EvernoteSetup.log, and unchecked "hidden".

Next I looked up the ownership of the file by right-clicking >> security >> username --> (to change permission, click) edit. This opened a permission window which had all boxes checked besides "special permission".

I (did not do anything, but) closed this window with OK, and exited the properties dialogue window with OK.


Next to the log file i realised the Evernote.msi. Clicking on it, launched the installation process and it completed without further ado.


I have no evidence that the unhidding, and properties OK-OK helped resolving the issue ...

But with my next update / version re-install, I will certainly start from here and avoid the downloaded Evernote_n.n.n.xxxx.exe.


Hope this helps! It worked for me.



P.S. Of course I would also appreciate, if somebody at evernote would really resolve this ticket. I had my fist in the pockets since almost a year now ...


Good luck, if you copy this "procedure".

Link to comment

Thank you Rainer-RQ ... I've been having the exact same problem on a Windows 7 Home Premium laptop since January 2015 ... a bit of a long time for a productivity tool to be down.


I followed your suggestions and voila ... solved! ... I still don't understand why, but I guess that's not important at this point..


Makes me wonder how may other folks have been having this same problem.  Evernote's been aware of thie issue, but ???


Anyway, very greatful for your sharing your solution ... maybe it'll help some other folks too  :o)



Link to comment
  • 2 months later...

I took the scorched earth approach.  De-installed Evernote, deleted all the Evernote log files etc. under "C:\Users\<MyName>\AppData\Local\Apps\Evernote\Evernote", rebooted,installed the new version and I was good to go.  This is after several months of no support from support....premium user?  What's that worth?



Link to comment
  • 11 months later...

Do not be afraid to delete everything Directly in the Temp Folder, I do it all the time for other reasons. This is the same Temp folder that you should evacuate whenever you get a "Spidey Tingle" that you have a Virus or Malware. Deleting it wont permanently harm anything, you may loose history, cookies, the last thing you ate with your browser... It's like a colonic cleansing for your computer. Just make sure you have all applications off or it may give you a warning that it is about to delete the data you are using at the time. Maybe you should shut down and restart your computer before you do this, you might want to close things running in the background or simply ignore their files. I don't want to scare you, but you run a slight, insignificant risk of deleting more than you planned to do so every time you delete a file. Be aware of what you are doing, since the risk is much, much worse if you aren't paying attention, then you could pull a "TOBY". Other than that, have at it, there's nothing really at risk. You might have to reinitialize certain programs, nothing really dangerous or needed in there. 

Evernote, like other programs, use these temporary places to sort of store data that you're sorting through and making changes to at various levels of the Open Systems Interconnect Model. This information is just a copy of what you are using at the time and really never gets erased. 

What Evernote is having a problem with is that it assigns random names to these files to ensure that several users on the same Machine can have separation in their data. 

Evernote installers should look for these files and delete them automatically. Mind you, I believe Evernote developers have thought about this and is just not fully supported to some of these Legacy Windows System Installer platforms. So, my suggestion, with my Bachelors of Science in Information Systems and a National Science Foundation Award for Excellence in Science and Mathematics ISSSS to simply recommend these users to delete the correct Temp files, with a Popup, instead of a cryptic error message.

Remember I need a real job Evernote... Hook me Up. 

Link to comment
  • 3 weeks later...
  • Level 5*

In Windows,  Evernote doesn't use the Temp folder for anything significant.  If you want to free up space on your hard drive,  exit Evernote and then delete everything in the Databases/Attachments folder.  If you want to get a speed boost,  try uninstalling and reinstalling your app.  Everything else is just window-dressing...

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...