Jump to content

Clipper not working: "Cannot create. Unspecified error"


Recommended Posts

I just tried clipping pages, urls, selections from several webpages and keep getting the same error message: "Cannot Create. Unspecified Error." I'm running the latest version of Firefox in an up-to-date version of Windows 7. I deleted and reloaded the Evernote web clipper extension. Same error. I'd be grateful for any suggestions as to how to cure this problem. Thanks.

Link to comment

I assume you are using the current production version 5.9.1.


I recommend installing the new version currently in beta available here: https://www.evernote.com/shard/s13/sh/2549631c-cebf-4b21-9518-95a2081bbc15/0c8e2fd9221398e819b141a600acf7dc

If there's a client side bug we will not be able to fix it in the current version and we think this error has been fixed in the new. 


Please let me know if the new one resolves it. 

Link to comment

Thanks for the reply. I followed your instructions and installed the new beta version. I tried selecting some text and then clicked on save selection in the Evernote context menu. I then got an image showing that it was saving the clipping, but it did not in fact save it. Then I tried clipping the URL and got the same error message I described earlier. Then I tried restarting Firefox. Now Evernote is completely gone from the context menu. Any ideas what the problem is? Thanks!

Link to comment

Hi Leeyo,

Not sure whats going on but the only thing I can think of to try is to re-install Firefox itself and then try again. We cannot see anything like this in our testing on either the current production or next version of Firefox Web Clipper. 

Link to comment
  • 3 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...