Jump to content
rubs

safari Web Clipper not working on Yosemite 10.10 Safari 8.0

Recommended Posts

Web Clipper functionality has been wiped out after updating to OS X Yosemite 10.10 (b4), using Safari 8.0 (10538.46). 

 

First time clicked an error pops up. No action happens every following click.

 

Reinstalling it doesn't help much. 

Share this post


Link to post

That's pretty much to be expected. Evernote generally doesn't support a beta OS.

Share this post


Link to post

I had the same issue but a few restarts later, it's working fine now.

It's working as good as it was before under Mavericks.

 

I read somewhere, that for some extensions, you do need to set your Safari preferences to ALWAYS allow cookies.

 

Very happy as this was quite important. If now only Skitch would work .....

  • Like 1

Share this post


Link to post

We've tested Safari Web Clipper extensively against Yosemite beta's and most recently the GA release and not found any issues. It's possible that when upgrading some of your Safari settings may be resets or updated, we've seen reports about Adblock blocking the Web Clipper after updating. 

Share this post


Link to post

Adding my voice, while I am THRILLED that we can finally add to EN from safari in ios8. however, I am not so pleased that EN cannot be added to the "share" options in Safari for Yosemite.

 

I'm sure it will come, one day, but meanwhile I think EN and every other app I use on the Mac looks fantastic in 10.10

Share this post


Link to post

Same problem. Running OS X Yosemite 10.10, Safari 8.0, re downloaded web clipper today 6.2.4. Still doesn't work. Functionality disappeared after Yosemite update. Any suggestions? The web clipper has often failed to work after new mac upgrade, then returned to function after a couple of weeks. I depend heavily on this function.

NB works fine with Firefox. I'm changing browsers.

  • Like 1

Share this post


Link to post

I was having the same issue, then went to Safari Preferences | Extensions | Web Clipper and disabled it and re-enabled again. Now working fine. Not sure if this was the issue but simple enough to try.

Share this post


Link to post

Sensational. Just had to turn off 'extensions are created by third-party developers...' button then turn it on again, then restart safari. Thanks! :)

  • Like 2

Share this post


Link to post

Yes that worked for me, (enabling it in prefs.) Having it is the share menu would be great too, then it would match ios

Share this post


Link to post

Doesn't work for me,

disabling extensions, disabling Ad-Block, safari restart, os restart...

 

i still cant clip from the web.

 

thanks.

Share this post


Link to post

Go to safari/preferences... "Extensions are created by third-party developers to customise and enhance your web experience". Go to the grey/white button next to this text and turn it off. Dialogue box will change, all your extensions will disappear. Then turn button on again. All your extensions will reappear. Worked for me  ;)

  • Like 1

Share this post


Link to post

That's all I can suggest. It works fine in Firefox. Consider moving browsers. EN always fixes this bug after system upgrades but you have to survive in the meantime. :lol:

Share this post


Link to post

FF? just for that? i think i'll pass ;)

My best current solution is to use the "Share To Mail" button on safari to the "Evernote upload".

Over the mail app there are similar options of simplifying the article, link, full etc.

 

thanks for your concern :)

Share this post


Link to post

That's all I can suggest. It works fine in Firefox. Consider moving browsers. EN always fixes this bug after system upgrades but you have to survive in the meantime. :lol:

Switching browsers? I use Safari for regular browsing, Chrome for development. Would never use Firefox.

Evernote just got to figure this out and get it working.

Share this post


Link to post

I tried to Clip this page and guess what??

 

"Cannot save clip" Error.

 

it looks like our feedback it taken very seriously by EN

 

thanks for solutions and feedback ! not!

Share this post


Link to post

I was having the same issue, then went to Safari Preferences | Extensions | Web Clipper and disabled it and re-enabled again. Now working fine. Not sure if this was the issue but simple enough to try.

Thanks.  Worked for me also.

Share this post


Link to post

We cannot find anything wrong with the Web Clipper 6.2.4 for Safari at the moment. I recommend uninstalling > re-installing  > restarting the system unless you haven't tried that. 

 

Other known issue have been:

- Adblock or popup blockers preventing the Clipper UI from showing. 

- Some user have had their Safari preferences changed after updating to 10.10 so check that you allow cookies from Evernote and that you allow Javascript. 

 

If the Clipper will not start on some URLs but not all then it may be a CSP issue as described here: 

https://discussion.evernote.com/topic/66224-safari-clipper-and-content-security-policy-csp-issue/

Share this post


Link to post

We cannot find anything wrong with the Web Clipper 6.2.4 for Safari at the moment. I recommend uninstalling > re-installing  > restarting the system unless you haven't tried that. 

 

 

 

Was experiencing the same issue and this solved the problem for me. 

Share this post


Link to post

I was having the same problems described in this thread (OSX Yosemite, Safari 8.0, Evernote Web Clipper 6.2.4).  Suspecting one of the other extensions, I have gone through the following process disabling one extension at a time:

  1. Disable other extension
  2. Remove and reinstall Evernote Web Clipper
  3. Reboot
  4. Test

This process of elimination has resulted in the "JavaScript Blocker" extension being identified as the culprit.  I haven't been able to determine if it is something local with my configuration of that extension or a more pervasive issue with the extension itself.  If it does turn out to be something with the extension itself, I will raise a bug with the developers.

 

Here's a list of my current extensions with a Evernote Web Clipper functioning correctly (Safari 8.0, Yosemite 10.10):

  • Adblock 2.12.1
  • 1Password 4.2.5
  • Evernote Web Clipper 6.2.4
  • DISABLED JavaScript Blocker 4.1.16c

Share this post


Link to post

I Disables all other extensions, un-istalled EN clipper re-intalled it, re-booted the system and i still always get the "Cannot Save Clip" error.

i have cookies allowed for all, Java script enabled.

Share this post


Link to post

On advice in this thread, I went into Safari/Preferences/Extensions.  Evidently, upgrading Safari turns off the Webclipper extension.  Turn it back on and it seems to work fine.

Share this post


Link to post

I am having the same problems as it seems do others.  Web clipper is just not working.  Nothing happens even though I have tried everything on this blog.  Any other suggestions.  I have emailed a couple of pages but it is so much better to be able to use web clipper.  Thanks.

Share this post


Link to post

Safari 8.0 auf OS X 10.10 with current web clipper.

 

Try to use web clipper on https://evernote.com/webclipper/

 

Error Console provides the following output:

 

[Warning] Invalid CSS property declaration at: ; (style.css, line 1554)

[Warning] Unexpected CSS token: : (style.css, line 1690)
[Warning] Unexpected CSS token: : (style.css, line 2753)
[Warning] Unexpected CSS token: : (style.css, line 2771)
[Warning] Invalid CSS property declaration at: * (products.css, line 1)
[Warning] Unexpected CSS token: : (products.css, line 1)
[Warning] Invalid CSS property declaration at: * (products.css, line 1, x2)
[Warning] Unexpected CSS token: : (products.css, line 1, x5)
[Warning] Invalid CSS property declaration at: * (products.css, line 1)
[Warning] Unexpected CSS token: : (products.css, line 1, x2)
[Warning] Invalid CSS property declaration at: * (products.css, line 1, x4)
[Error] Failed to load resource: the server responded with a status of 403 (Forbidden) (jquery.min.map, line 0)
[Error] Failed to load resource: The file “messages.json” couldn’t be opened because there is no such file. (messages.json, line 0)
 
Used on a side on this forum:
 
[Warning] Unexpected CSS token: : (editor.css, line 731)
[Warning] Unexpected CSS token: : (editor.css, line 736)
[Warning] Unexpected CSS token: : (editor.css, line 805)
[Warning] Unexpected CSS token: : (editor.css, line 809)
[Warning] Unexpected CSS token: ; (editor.css, line 814)
[Warning] Unexpected CSS token: : (editor.css, line 875)
[Warning] Unexpected CSS token: ; (editor.css, line 879)
[Warning] Unexpected CSS token: : (editor.css, line 1041)
[Warning] Unexpected CSS token: : (editor.css, line 1045)
[Warning] Unexpected CSS token: ; (editor.css, line 1049)
[Warning] Unexpected CSS token: : (editor.css, line 1061)
[Warning] Unexpected CSS token: : (editor.css, line 1065)
[Warning] Unexpected CSS token: ; (editor.css, line 1069)
[Warning] Invalid CSS property declaration at: * (74735-how-serious-do-en-take-en-business, line 7)
[Warning] Invalid CSS property declaration at: * (contents.css, line 56)
[Error] Failed to load resource: The file “messages.json” couldn’t be opened because there is no such file. (messages.json, line 0)
[Error] Failed to load resource: The file “messages.json” couldn’t be opened because there is no such file. (messages.json, line 0)
 
 
Perhaps that helps to identify the problem...

Share this post


Link to post

I agree with xwoker, cleared cache, quit safari, relaunched, and (probably this was it) logged back into the extension.  Works fine now.  I have OSX10.10 EN5.7, Safari 8.

Share this post


Link to post

I found that the Safari update had enabled "Turn off extensions to save power" which had disabled the evernote clipper.  Went to Preferences/Advanced and unchecked this choice, clipper worked again instantly.  

Share this post


Link to post

I've experienced the same issue with OSX 10.10 and Safari 8.0.

Disabling and enabling didn't work.

What did work: 

- in the "privacy" settings of Safari choose "always allow cookies"

- then use the EN webclipper to save a webpage

- then return the the Safari settings and reset the original privacy settings.

Now it works like a charm

Share this post


Link to post

For me, it was Adblock blocking the web clipper "popup". I went to evernote.com, clicked the Adblock toolbar button, and clicked "don't run on pages on this domain." Now it's working fine.

Share this post


Link to post

For me, Disconnect appears to be the extension that conflicts with the Evernote web clipper. It would be terrific if they worked together. The problem does not appear on all sites or all the time.

 

[update] Although turning off Disconnect worked. The problem returned even with no extensions on.

Share this post


Link to post

I've experienced the same issue with OSX 10.10 and Safari 8.0.

Disabling and enabling didn't work.

What did work: 

- in the "privacy" settings of Safari choose "always allow cookies"

- then use the EN webclipper to save a webpage

- then return the the Safari settings and reset the original privacy settings.

Now it works like a charm

This is the only thing that worked for me too!

Share this post


Link to post

In addition to occasionally not having the functionality and the going through all the hoops mentioned above, I find that the web clipper extension in safari severely slows down the loading of some sites such as LinkedIn.  As a result, I have shut off web clipper extension.  This is one of the main features I like about Evernote, so unless it is fixed, my use of Evernote is going to drop dramatically.

Share this post


Link to post

I found that the Safari update had enabled "Turn off extensions to save power" which had disabled the evernote clipper.  Went to Preferences/Advanced and unchecked this choice, clipper worked again instantly.  " 

 

 

This worked right away for me. 

 

Cheers. 

Share this post


Link to post
On 1 August 2014 at 10:40 PM, bukmba said:

I had the same issue but a few restarts later, it's working fine now.

It's working as good as it was before under Mavericks.

 

I read somewhere, that for some extensions, you do need to set your Safari preferences to ALWAYS allow cookies.

 

Very happy as this was quite important. If now only Skitch would work .....

Thank you - "set your Safari preferences to ALWAYS allow cookies" worked for me

  • Like 1

Share this post


Link to post

Hello Astahr,

Can you explain how you can download Version 6.2.4, as I just downloaded the latest and it was 6.2.3, or so it said on my screen?

Share this post


Link to post

Also, the tip to "always allow" in Safari / Preferences / General / Cookies and Website data......Always allow

is the ONLY piece of advice that has made ANY difference !!!!!

Thanks to Longreach................your not in QLD are you??

The dot on the Web Clipper icon goes away when you make this selection, BUT, I am not too sure for the sake of Web Clipper that I want to leave "ALWAYS ALLOW", as a security option, and feel Evernote can do better than to have supposedly valuable customers be vulnerable. They should fix it, and then email us all so we can change back our security settings. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...