Jump to content

Changing a note's notebook with Applescript does not sync properly


Recommended Posts

I have a script that moves the currently selected note to a notebook called "Notes". It is mapped to ctrl-opt-f using "FastScripts" so I can quickly file things. I have been using it since 25 Jun 2014 with no trouble.
 
Since 23 Jul 2014, moving notes with this script causes the change to "Notes" notebook to not sync. The note is still in "Notes" on the Mac client (5.5.2 (402634 Direct)) where I used the script, but not on any of the other clients (other Mac, iOS, web).
I have confirmed this through repeated experiments.
 
Here are the tests I did to confirm this:
  1. View a set of notes in the "Incoming" notebook in Mac Evernote client
  2. Change the notebook of "Note 1" to "Notes", using the drop down list to left of tags
  3. Sync Mac, then sync iPad
  4. "Note 1" shows up in "Notes" on iPad 
  5. Change the notebook of "Note 2" to "Notes" using ctrl-cmd-m, then selecting "Notes" from the drop down list
  6. Sync Mac, then sync iPad
  7. "Note 2" shows up in "Notes" on iPad

    –– Everything is fine up to here ––
     
  8. Change the notebook of "Note 3" to "Notes" using ctrl-opt-f that calls the attached script
  9. Sync Mac, then sync iPad
  10. "Note 3" shows up in "Incoming" on iPad, even after multiple re-syncs. It should be in "Notes"

I raised this as ticket # 655982 , and received the following reply from support, so I assume they will not investigate further. My script is attached. Has anyone seen anything like this before?

 

 

Hi, my name is Jason. Thanks for contacting Evernote Support.

Thank you for this feedback. I recommend that you bring this to our developer support forums. We have an active, supportive developer community here at Evernote. The best place to get support and feedback while working on your projects is our Developer forums.
Please let me know if you need any additional assistance.
Regards,
Jason C.
 

post-93880-0-04103800-1406299454_thumb.p

Link to post
  • Level 5*

Extropy, I can confirm the behavior you are seeing.  I believe this is a BUG, and suggest that you respond to the Evernote Support email reporting it as a BUG.

 

It seems that EN Mac 5.5.2 does NOT register that a change has been made to the Note when the Note is moved to a different Notebook via Applescript.

 

I tested this using EN Mac, EN Web, and EN iPhone.  It is clear that the change/move in the Note was NOT reported to the Evernote Cloud/Service.

Link to post
  • 3 months later...

Has this been resolved?

 

I'm looking for a new solution as with the latest update I cannot script the "move to notebook: done" via the menubar as it always opens up the new notebook search window now. I have a workaround right now, but it feels to slow (keyboard maestro opens that search dialog and types in the name + return...)

Link to post

I just did the following test. It still isn't fixed:

 

  1. Move a note from "Incoming" to "Notes" notebook using Applescript on MacBook
  2. Sync MacBook
  3. Sync iPad → Note still in "Incoming"
  4. Edit note on iPad
  5. Sync iPad
  6. Sync MacBook → The note syncs back to MacBook with correct edits, but moved back to "Incoming"
Link to post
  • 3 weeks later...
  • 1 month later...

This is still broken in Evernote (Mac) 6.0.5.

 

Additional observation:

 

If I move a note using the script shown above, it shows as being in the "Notes" notebook on the Mac where I moved it, but stays in "Incoming" notebook on all other synced systems (iOS and Windows verified, didn't check web but assume it is still in "Incoming" there).

 

If I the use the "Move to Notebook" GUI function in Evernote, and select "Notes" notebook, even though it already has a checkmark next to it, then sync, the note is moved correctly across all synced platforms.

Link to post
  • 3 months later...

Tried to check the status of the old ticket, #655982. I had received a response from Jason at Evernote support that the bug had been verified and passed to the developers. I tried to contact Evernote regarding the old ticket, and received a canned response that the ticket number is invalid.

 

This is one of the recurring problems with Evernote support. We have no visibility into the status of tickets, even after they have been validated by support. For the new ticket, all I have received is a request for description, logs, etc. I do not intend to resubmit this information, so I expect the new ticket will be dropped, too.

 

In short, an unsatisfying support experience:

  1. Submit ticket
  2. Redirect to developer forum for confirmation
  3. Provide confirmation
  4. Receive confirmation from Evernote that the bug has been reproduced
  5. Wait 10 months and several versions
  6. ...
  7. Still not fixed, ticket has been closed

:(

Link to post

I also have a ticket number to share in which the problem is described as well as it refers to this post: #1055346
Seth from the support team is about to submit it to the developers and was not able to find the bug in their bug-report system. Maybe it got lost! Let's see if we have more luck this time. I'm positive on that!

Link to post
  • 6 months later...
  • 1 month later...

Hooray!

I don't know when it happened, but this finally appears to be fixed. Just verified with Evernote for Mac 6.4 (452969 Direct) and Evernote on iPad version 7.9.2.318622 as follows:

  1. Create "Test Note" in "Incoming" notebook on Mac
  2. Sync Mac
  3. Sync iPad
  4. Use Applescript (I bind mine to ctrl-alt-n) to move "Test Note" to "Notes" notebook on Mac
  5. Sync Mac
  6. Sync iPad
  7. Verify "Test Note" is in "Notes" notebook on iPad and Mac
  8. :)
  9. Create "Test Note" in "Incoming" notebook on iPad
  10. Sync iPad
  11. Sync Mac
  12. Use Applescript (I bind mine to ctrl-alt-n) to move "Test Note" to "Notes" notebook on Mac
  13. Sync Mac
  14. Sync iPad
  15. Verify "Test Note" is in "Notes" notebook on iPad and Mac
  16. :)

 

Link to post

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...