Jump to content

Web Clipper doesn't work with latest Google Chrome & Chromium


Recommended Posts

I am having the same problem, with the 1807 build of Canary - it just updated to 1809 yesterday and still having the same problem.  When I click on the Web Clipper nothing happens.


I am on Mac osX 10.9.1


Interestingly, when the extension first installs, the toolbar appears as part of the demo - then it vanishes and the button is bricked.





Link to comment
  • 5 months later...
  • Level 5*

I am using chrome version 35.0.1916.153 m on Windows 7 and webclipper is not working.  

Same version, same OS, working fine for me. When you say "not working", what does that mean? In other words, what did you do, and what happened?
Link to comment

Hi guys,


just updated (automatically) my Chrome to Version 36.0.1985.125 m and apparently the Chrome Add-on of Clipper does not work anymore with that version!!


Need help!


Thank you in advance for your support,


Best Regards,



Link to comment
We just released a fix to patch this error popup. 

Users should get auto updated to the latest version 6.2.1 which has the fix applied either in the background or on Chrome restart. 


To force updates manually:

1) Visit chrome://extensions and set it to developer mode and push the button 'Update Extensions Now' at the top of the page. 


And then verify you are running 6.2.1


Sorry for the inconvenience. 

Link to comment
  • 1 month later...
  • 2 weeks later...

I'm having the same problem: evernote web clipper doesnt work. only when I uninstall the clipper and install again it works. but that means I have to do this every day

i use chrome version 37.0.2062.124 m

evernote (272632)

please help because I really like working with evernote

Link to comment


Can you describe in more detail what is not working for you?

- Do you see the Web Clipper button in the Chrome toolbar?

- After installing it do you restart Chrome?

- What happens when you click the toolbar button?

- Is it broken on all pages or a few?

- Do you get any error messages?

Link to comment

I too just noticed the web clipper is not working...I've tried on 10 or so various websites. At first nothing happened so I uninstalled and re-installed the clipper. Then I got this error message:

"The Clipper couldn't start on this page. Reload the page and try again. If that doesn't help, contact customer support."


Here are a few of the websites I tried:




I'm using:

Mac 10.6

Chrome Version 37.0.2062.124

Evernote: 6.2.6(5e9ac9e/




Link to comment


This topic is now archived and is closed to further replies.

  • Create New...