Jump to content

Safari Web Clipper not doing anything when clicked


Recommended Posts

just going to add my name to this list... SUPER FRUSTRATING.


I've tried it on a wide variety of sites just to see what is working what is not.  

Currently the weirdest - Twitter NOPE. Facebook WORKS.


Uninstalled. Updated. Reinstalled. Still the same. Again...SUPER FRUSTRATING


And now I had to spend time finding this forum just to find out that this has been going on for over a year...Yikes. Great idea and tool if I could count on it. 

Link to comment
  • 2 weeks later...

I've used the Evernote web clipper with Safari for years. Never a problem. Now suddenly it simply stops working altogether. I click the icon on the Safari tool bar and nothing at all happens (other than the icon flashing once very quickly).


I uninstalled the web clipper, downloaded a fresh version, and reinstalled it. Nothing. Did all the usual shut downs and restarts of everything. Nothing.


No change in operating system (10.10.2), no change in Safari (8.04), no new extensions at all, and a just-downloaded fresh copy of the web clipper extension. The darn thing just won't work anymore. At all. Ever. On anything.


I'd really appreciate some suggestions here, friends....

Link to comment
  • 1 month later...

Same situation here -- Evernote web clipper works for a while then suddenly all functionality ceases after zero changes/updates to Safari or the OS. Can't trust it to work when needed.


MacBook Pro/retina 13-inch late 2013; Safari 8.0.5; Yosemite 10.10.3.

Link to comment
  • 2 weeks later...

Just chiming in to say, AdBlock extension was definitely causing my issue.


Evernote extension had installed fine, I signed in with my credentials, etc. but when it came time to actually use it, nothing at all would happen when I clicked the clipper button.


I paused the AdBlock extension, refreshed the page I was trying to clip (just pausing AdBlock was not enough), and then the clipper worked perfectly.


Safari version: 8.0.6 (10600.6.3)

OSX version: 10.10.3 (14D136)


Other extensions loaded which do not seem to conflict w/ Evernote: Pinterest, 1Password


Since Evernote clipping is more essential to my workflow than ad blocking, I'm just going to leave adblock turned off until the conflict can be resolved (if ever).

Link to comment
  • 2 months later...

Me too. Nothing happening when clicking the icon..

I have only 4 extensions installed (no AdBlock):

- Lastpass

- Pinterest

- Pocket

- Evernote


Pinterest also gives me the same issue. And it only ever happens in Safari, in Chrome it always works.


Safari version: 8.0.8 (10600.8.9)

OS X version: 10.10.5

Link to comment
  • 2 weeks later...
  • 3 months later...
  • 1 month later...

I have used clipper successfully with Firefox, but lately I cannot clip anything. I choose the kind of "clip" and then the color wheel spins and no note is created.  It opens my desktop version, but there's nothing to follow through as far as making a new note for the new clipped item. I have recently reinstalled clipper several times.


Link to comment
  • 3 weeks later...

I have this same behaviour on Mozilla Firefox, all versions up to and including 44.0.2 on Windows.  So browsed into this forum. The Web Clipper just stops working in Firefox browser windows. But sometimes I can open the target URL a new window, and then the Clipper works fine from a new, freshly-opened window.

But sure would be nice if Evernote could fix it so the Web Clipper add-on works 100% of the time!

Link to comment
  • 5 months later...
  • 5 months later...
On 6/3/2016 at 9:22 AM, parttimemarried said:


|| Safari >> Preferences >> Security >> Plug-in Settings >> Allow 'discussion.evernote.com' for all

>> Restart Safari >> Done. ||


Aditya :)

That WORKED perfectly for me as well, after having tried all other measures I read in this and Apple's forums.

Link to comment
  • 1 month later...
On 8/23/2016 at 6:43 AM, Sans Culottes said:

Removed Adblock Plus and web clipper works

I had removed Adblock Plus and replaced it with Disconnect. But this comment was enough for me to try whitelisting evernote.com in Disconnect and it appears that the clipper is now working again. No more random log outs and having to log back in. At least for the 15-20 minutes after signing in again.

So I would assert that any ad blocker, tracking remover might cause problems with the clipper. It seems to only happen for me on Safari. But I don't use Chrome or Firefox enough to know for sure.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...