Jump to content

selection of text for copy/paste not working in editor

Recommended Posts



Does anyone else have this problem as well? I am not able to select text when in edit mode. When I do a double tap on a word, I can see that the word is highlighted for a split second and that the markers for the left and right edge of the selection are visible. But the selection and the markers go away instantly and so I am not able to copy/paste anything in the edtior.

Maybe I am doing it wrong? I tried a lot. Tap, tap and hold, double tap, double tap and hold,triple dap and so forth. It's a pain to write some text (shopping lists, etc.) without copy/paste.


The phone I am using is a Sony Xperia T with Android 4.1.2.


Please help and many thanks in advance.

Link to comment
  • 3 weeks later...
  • Level 5

I had this problem too, on a Samsung Galaxy S4. However, I've found that recent updates of Evernote have fixed it for me. My phone is updated to Android 4.3, and the Evernote Android app v. 5.6.1 (free version). I hope it's not an Xperia issue. If updating the software doesn't help, you should probably submit a support ticket. I did find them fairly response to the ticket I submitted last fall.

Link to comment
  • 5 weeks later...

I have the same problem in mine, Xperia L, Android 4.2.2. When using the regular Android Keyboard is perfect: you can use the dictionary (highlighting of the word), put the cursor where you want, tap & hold, move the markers and so on! The thing is that the Xperia is very quick and precise, it's a shame that we are forced to use another just for Evernote while it functions very well in any other app of the phone :(. It's a strange behaviour.

Link to comment
  • 2 months later...

Yep - I have same issue.


Sony Xperia Z1 - Android 4.3, Evernote 5.8.1 - can't select in edit mode, using default Xperia International keyboard.

Sony Xperia Tablet Z - Android 4.2.2 (Sony upgrade to 4.3 was a train wreck) , Evernote 5.8.1, using default Xperia International keyboard.


I haven't tried with a different keyboard, as changing from a perfectly good keyboard just for this one app seems a bit crazy to me.


Can this be fixed by Evernote? Or is it Sony's problem? (Or worse, each blaming the other!)

Link to comment

I wish they would fix this. I kind of gave up hope though. That bug has been in Evernote since ever. I updated my Xperia T to Andriod 4.3 in the mean time. Evernote currently 5.8.1.



Can this be fixed by Evernote? Or is it Sony's problem? (Or worse, each blaming the other!)


Who knows. Since Evernote is the only App that shows this problem, I would say Evernote is not necessarily innocent.

Link to comment

I've noticed it's only partially working for me. I can Select text, but if there is a line break of any kind, it only allows me to Select up until the end of the one I'm in.

For example, if I have two bullet points (or paragraphs or check boxes), I can only Select and Copy one at a time. As a workaround, I've been creating temporary email drafts into which I:

● Type and/or paste text from elsewhere.

● Then when I have everything I want for that note, I Select everything and Copy and Paste it into Evernote.

● Then I delete the draft email.

It's definitely a bit of a PITA, but not being a power user when using the Android app, I'm surviving. I save any heavy usage for the Windows application.

Cheers. :)

Link to comment
  • 1 month later...

29 may 14



i was also suffering from this select/copy/paste problem on my xperia z tablet (up to and including android 4.4.2) when using evernote, and only when using evernote... i also registered a support ticket...


then i discovered the app SWIFTKEY and the problem was gone... have only been using the trial version to date, however i will switch to the full version so i can continue to use evernote in the way it was envisioned...



Link to comment

Thanks graham!


That works for me as well. So it seems like the problem is a combination of the Xperia keyboard software and Evernote. Nevertheless, I think the Evernote developers should look into this. Because Evernote is the only app I ever used which has troubles with the Xperia keyboard. I really don't want to use SwiftKey just to circumvent a bug in Evernote.

So if any Evernote developer is reading this. Pretty please with sugar on top, could you check this out. This bug is ancient.



Link to comment
  • 1 year later...

hi clive...

i had copy/paste trouble using evernote on a sony xperia tablet z2... after installing the swiftkey keyboard the problem went away... copy/paste functions as follows:


  1. double-tap on a word that is more or less in the middle of the text you want to copy... 
  2. you should now see two green markers appear... 
  3. press and drag each marker in turn to the desired position... 
  4. at the top of your screen you should see various menu choices eg, select all, cut copy etc... 
  5. tap on "copy" then tap on the position in the text you want to copy to... 
  6. a popup command "paste"will appear directly above the position on the screen you just tapped, tap on it...
  7. eh voila, the text has been copied...

have fun, regards

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...