Jump to content
  • 0

An internal database error has occurred that prevents



My Evernote(mac) had errors with the following notification.
"An internal database error has occurred that prevents Evernote from functioning properly. "
I tried many times.But it can't work.How to solve this problem?

I wrote to Evernote.They just sent me the ticket confirmation,but no reply until now.....

Link to comment

8 replies to this idea

Recommended Posts

Started having this problem as well after a recent Evernote update.  My macbook is running OSX Mavericks.  There is a tech note on resolving this that suggests moving the application support folder to the desktop but it does not resolve the problem - attempting to launch evernote again just makes a new support directory and the same error is displayed.

Link to comment

Praise Evernote again.They've given me the feedback after I sent the log file.very helpful.

Therefore,I paste their email content.Hope this will help other guys who have similar problems.


Hello dragonet,

The log indicates that some of the Database files has been corrupted, please follow the next steps to rebuild then correct this error:

(If you are unable to open Evernote at all, you may skip to step 2.)

If you have some important Local Only or unsynced notes, be sure to read the directions at the end of this email to safeguard your information. Otherwise please try the following:

Please try moving your Evernote database directory so that Evernote will regenerate a new local database by copying your notes back down from the service. To do this:

1. Quit Evernote from the Elephant in the Menubar.


2. Your database is in a hidden directory. You can access it by opening the Finder, then selecting "Go" from the top menu and hitting the "Option" key. Once you have done that, you'll see the "Library" folder pop up.
Select it.

![Hidden Folder](http://asset1.cbsistatic.com/cnwk.1d/i/tim/2011/07/22/GoMenu_270x448.png)

3. Then, go to:
~/Library/Containers/com.evernote.Evernote/Data/Library/Application Support/Evernote/accounts/ and move the "your username" directory to another place.
4. Once you've done that, please *also* go to:
~Library/Application Support/Evernote/accounts/Evernote/<your username> and move the "your username" directory to another place. If you are directed to "merge/replace/keep", choose to "Keep a Copy".
Note: You may not have a directory in both places. Please remove whichever ones you *do* have, and make sure that you no longer have either before moving forward. If you are directed to "merge/replace/keep", choose to "Keep a Copy".
5. Then, try opening Evernote again. All of your notes from the service will now synchronize and create a new local database.
*If you have any Local Only notebooks, switch to List View, then select the notebook name and select all notes (CMD+A or CTRL+A), then export the notes to .enex format, exporting tags if desired. If you have some unsynchronized notes, go to "All Notes" and, also in List View, sort by the "Sync" column, and export any notes that have a * in that column to .enex format.

Link to comment

The above did not work - but helped....

First: This pertains to:

OS X 10.8.5 set up for multiple users.


I tried all of the above steps that @dragonet supplied but the problem did not resolve.


I moved the ~Library/Application Support/Evernote/accounts/Evernote/<your username> folder to another location

Then I deleted ~Library/Application Support/Evernote/accounts/Evernote/

(~/Library/Containers/com.evernote.Evernote/Data/ was not on my computer - but I'd delete that too - after backing it up!)


Downloaded the latest version of Evernote for Mac (5.5.2 402634 Direct) and installed per instructions

Opened - provided my credentials and Evernote re-synched and all is well.


Deleted my backed up Evernote files from the (corrupted?) version.


Thanks @dragonet! Knowing where things were hidden helped to clear the corruption.  In a rather brute force way.... :-)

Link to comment

I am having the same problem with 'Internal database error' running OS X Yosemite.


Tried following the above instructions to no avail.  I do not have a ~/Library/Containers/com.evernote.Evernote/Data/Library/Application Support/Evernote/accounts/ folder.


Anyone any other suggestions.  I do not have any local files so would be happy to completely delete Evernote on my Mac and re-install and re-sync.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...