Jump to content

Updating to v 5 - PDFs have not been indexed

Recommended Posts

Hey all, 


I have numerous PDF's scanned into Evernote, that aren't indexed.  Some have been in EN for a month (I am a premium member).  I have tried logging out of the windows client and logging back in, I also deleted and redownloaded the database file.  So far no luck.


I have seen other similar issues on the forum, but can't really tell if they have been resolved.  This is a pretty important issue, because I can't edit the pdfs in skitch as I should.


Any help would be appreciated


Also, yes I have chatted with support and started a ticket last week.  No answers yet.


Thanks SB

Link to comment
  • 3 weeks later...
  • 3 weeks later...

I have exactly the same problem, and support has not been able to help really, other than give me the criteria under which a PDF wont be indexed.  Pretty disappointed with this tbh and with my premium member renewal coming up soon i am wondering if I am going to bother.


Any progress for either of you two?

Link to comment

Yes, Support got back to me, they said, that Evernote sometimes SAYS that it isn't indexed but in fact it really is, which can be prooved by doing a search. Support told me to send a PDF that doesn't get indexed to them to review.


What criteria were you given?

Link to comment

Hi, They gave me these details




I have just uploaded a new PDF which i didn't create, and I am giving it a few minutes for it to get "indexed" however I seem to be having this issue with images as well, jpgs for example. 


I will search in a few minutes through Evernote web to see if the PDF is searchable, but I feel this is something more. 

Link to comment

OK so the plot thickens.


See this Skitch capture




It shows an unsynced note being picked up in a search on my widows desktop. So how did this note get picked up when it hadn't been indexed, you can see the string P5B being found. 


However , the skitch note itself does NOT get picked up in a search either in the web version of Evernote or the desktop version, WTF!!

Link to comment
  • 1 month later...

I took a screen capture and immediately added text to the image using the "Markup" option.  I noticed that the image never got indexed.  Subsequent screen captures that weren't "marked up" got properly indexed. (270046) Evernote premium user

Link to comment
  • Level 5*

I suggest a support ticket to register the problem and workarounds for the moment - but keep checking the note in case it shows up after a day or two or three;  notes with text content shouldn't avoid or delay OCR but maybe they go into a different queue.  There are a few workarounds if you need them..

Link to comment



After some time away from Evernote, I have been catching up this weekend. I decided that I was going to take the plunge and put some sensitive(ish) pdfs into Evernote, but decided to encrypt and password protect the PDFs beforehand. Then I realised that there was an update and updated to v5 and later 5.0.3. I've just tried to return to those pdfs and discovered that none of them have been indexed, despite me syncing multiple times. Thankfully, they're available on the web-based version and also on my phone (so presumably also on my tablet), so the problem seems to be with the Windows version. Does anyone have any suggestions for how I might be able to resolve this, please? I'm just about to raise a support ticket, but wondered if I was just being clueless. The pdfs are of varying sizes. There's two or three of 4.3MBs as I combined a bunch of PDFs into one, but the same problem occurs with a pdf sized 8KB, so I don't think it's a size issue.


Thanks in advance, hopefully!! I can reupload them if needed as I have the backups, but don't want to have to do the same every time I update Evernote...

Link to comment
  • Level 5*

Hi - when you say "have not been indexed" do you mean that you can see these PDFs in the note but can't search for their content? - If they are encrypted,  that's only to be expected;  Evernote don't have any access to the content at all..

Link to comment

No, I can't see the PDFs in the note at all. Which I thought originally was fine, as with encrypted pdfs I have only ever seen a pdf with a blank front page in the Windows versino. But it doesn't appear as though they are there at all because there's no 'Open With' or doubleclick option to open them in Adobe Reader. I can't see them as an attachment as I can in the mobile and web-based browsers, I just have a black line and a seemingly empty note. In the Info: Attachment Status it states that "1 PDF has not been indexed".


ETA: Okay, now I feel silly. I closed down Evernote properly by clicking File > Exit and now I have a 'Save Attachments' option which works correctly. Thanks and sorry!

Link to comment
  • 4 weeks later...
  • 2 months later...

I am also a Premium user.


I observe that my notes containing a pdf (or several), all specify that the pdf has NOT been indexed.


But if I make a search on specific terms in thoses PDFs, they're all found as expected, as was reported earlier.


I'm not sure what's to make of this, but it all appears to be OK, except the unsettling messages about indexation not taking place.

Link to comment
  • 3 years later...


This topic is now archived and is closed to further replies.

  • Create New...