Jump to content

Cross-hair Snapshot not working properly on Mac (Mavericks) ?

Paul Winterhalder

Recommended Posts



Anyone having an issue with the cross-hair screenshot not working properly on Mavericks anymore?


Sure - it works if I drag and select an area...  but if I just click on a window it no longer captures that window by default... (instead it seems to capture an image of the cursor?)


Anybody else having this issue...  seems to have just cropped up a week or two ago for me?  (Don't recall if there was a software update then?)


Or has this functionality changed intentionally?  (I hope not).



Link to comment

Hi Paul,

Can you tell me what versions of OS X and Skitch you are running? What is your hardware setup? Someone else had seen this once but was unable to reproduce it.




Mac OS X 10.9 (13A3017)

MacBook Pro Retina 15-inch, Late 2013

16 GB Ram

Oh - and I've got the laptop set up with 2 additional monitors (one connected via the VGA adapter, one straight via HDMI)


Skitch 2.7 (263181)


..And...  I just went to do another capture - and it worked!!!!  Sheesh!!!!  (Note sure why it's working now - I've tried on a bunch of different windows and its currently working for me)


I'm a developer too - I know how frustrating *intermittent* defects can be to find and fix!!!


I'll let you know if it happens again - and see if I can figure out *when* it's happening...

Link to comment

Thanks - I like the setup!


...but - it's looking like maybe it's part of the problem?


I came into work today, woke up my laptop (it had been suspended, not powered down, in my laptop bag) - and tried skitch again...  (stitch had still been running)


Anyway, was getting just the captured cursor again...


So then I tried capturing different windows on the screen to see if I could get different behaviour...


Then when I went to capture a screen on my left-most monitor (my laptop screen is set up in the middle) - the capture came up blank...  hmm, interesting....


So then I started capturing across the different screens - and it appears that when I moved skitch itself over to the right-most monitor - it started capturing screens again.  But capturing from the center switched from being cursor to being a blank image...


Anyway - lots of clicking back and forth to see if I can figure anything out...  and well, it's confusing...  :)


It seems that I'll have runs where it's only capturing a cursor, then it'll capture a blank screen, and then it will work fine for a run...


It may have *something* to do with whether the window to be captured is active or not.  I was repeatedly trying to capture a window (and only getting the cursor), when I realized the window I was clicking on to capture wasn't active...  Once I made it active, I *was* able to capture the window...   must this doesn't seem to be 100% effective (a few minutes later, it was giving me just the cursor capture again - and even when I made the window active it wouldn't capture)...


Anyway, I'm definitely guessing that my multi-monitor setup may be part of the issue - and possibly the active state of the window - but who knows?!!


Good luck - hope that helps! (confusing as it is!)



Link to comment
  • 2 weeks later...

I had a similar problem - Cross hair captures not working on Mavericks.

I found that the problem went away when I closed a VirtualBox machine that I had been running. I had the VirtualBox machine (linux) running with all its 'additions' - to allow dynamic screen resizing, etc. I'm wondering if this interfered with Skitch's ability to capture the screen.





Link to comment
  • 1 month later...

I am no developer, and do not know why all of a sudden, when I make a snapshot I get the bar above the picture, with title etc. as if it was a Finder window. I am either on a Mac Air 11" late 2011, OS 10.8.5, or on a MacBook Pro 15" late 2013.  I updated Skitch yesterday, and this has been happening on both computers since. Thanks for your help.

Link to comment
  • 4 weeks later...

I have a somewhat similar set up to ldekay.... 2.7 GHz 15" Macbook Pro Retina attached to an external monitor connected via a display adapter, running OS 10.9.2.


In my case, the Timed Crosshair Snapshot just behaves like a normal Crosshair Snapshot... no countdown, no delay. Any ideas about how to get to work again?

Link to comment

I'm getting the same thing.  Dual monitor, and I have some VirtualBoxes running in the background (which I cannot stop) and unless I select a specific area for my screenshot, I just get the cursor captured.


Latest Mavericks and latest Skitch Version 2.7.2 (263461).

Link to comment
  • 2 months later...

This happens consistently for me.  It's really annoying, and I'm reminded of it every time I look at evernote with my dozens images of a mouse cursor lol.  Anyone have a fix?


Skitch Version: Version 2.7.2 (263461)

Mac Version: OS X 10.9.2 (13C64)



Let me know if I can do anything to help debug this problem.  

Link to comment
  • 3 weeks later...

I contacted customer support about this issue and then told me to reinstall the app and it fixed the issue!  After you delete the app, be sure to empty your trash and make sure the Skitch Helper (menu bar app) is also closed.  


We believe that reinstalling the latest Mac version may address the issue that you reported. Please perform the following steps:

  1. Quit Skitch
  2. Drag the Skitch application to the system Trash
  3. Reboot your Mac
  4. Download and install the latest version of the Mac client: http://itunes.apple.com/us/app/skitch/id425955336?mt=12

Let us know how this works for you.

I appreciate your consideration, and thank you for using Skitch!


Link to comment
  • 1 year later...

How is this still ***** broken 2 years later? I remember having this same issue 2 years ago.


And why am I still forced to click "Discard Current Sketch Note". I don't save my screenshots into Evernote. I have never saved my screenshots into Evernote, and I never will.


I uninstalled and re-installed it with the App Store. And that installed it into the Downloads the folder? What the hell? I've never seen an application do that. Why didn't it put itself in the Applications folder? I had to use spotlight to figure out where it went.


Wow, Evernote really fucked this product up when they got their hands on it. I remember how wonderful it was before then. Now they're dragging it down with their own product.




Macbook Pro 2015 Retina

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...