Jump to content

(Archived) Bug: Voice notes recorded in Android app not appearing elsewhere


Recommended Posts

After searching elsewhere and on this forum, I haven't seen this particular issue, though I do agree that, while very useful as it, the voice notes feature should be a made more robust as is planned.


I've created several notes with voice recordings on the same day.  I created these all using the Android app's built in voice note recorder activated from the "list" homescreen widget. Typically I would use the voice recording button on the widget to automatically create a new note and start voice recording immediately.  I would record a minute or so of voice and then end the recording.  It would show as added to the note in the app, and I would give it a subject. Sometimes I would add body text to the note, but sometimes I would save the note with just the recording and subject text.


These voice notes are all still available to play through the Android app.  However, I've synced my account and looked at these notes both on the web interface and in the newest version of the Windows application. In both the web interface and in Windows, only the notes to which I also added body text in addition to the subject line show the voice note, although the snippet in the note list does show an attachment of X kilobytes in size. I was able to export the invisible audio file to my desktop as .amr in from the couple of the notes I tried this with.  It seems the clips are there on the servers - there is a bug in the Windows and web applications that prevents them from showing/being playable in the note unless there is body text to go with them. 


I had read about some people having a bug where content isn't saved when they edit a note on Android that shows the "unsupported content" warning, but this seems to be different since the voice notes seem to still be saved and playable on the Android app.


Can anyone help me shed light on this, or if it's simply a bug, can any Evernote folks out there add it to the punchlist? Adding a little body text isn't a big deal, but it should ideally work without this.


Thanks a lot!

Link to comment
  • Level 5*

Hi.  It may not be relevant but AMR files probably aren't natively playable anywhere except your Android device.  Did you say that you can play these in Evernote on your desktop provided there is supporting text in the note?

Link to comment

I've noticed the same issue only with notes created on my android phone  - after the update to v 5 - older audio notes are fine. I can see the voice attachment on my android phone and on my ipad - but not within windows.


However - on a note which appears empty - if you double click in the top lefthand part of the note where the voice file should be you can play it within windows just fine. - So the attachment is there it's just a ghost.


Secondary little bug "sometimes" fully closing down EN and opening again - can cause the file attachment to show but for me this has been hit and miss.

Link to comment

Thanks, gazumped and Denise. @Denise: haven't tried to click the empty space, will give that a shot, although would still love to see this fixed!


@gazumped: They aren't natively playable in the browser, but they are playable in the Windows app where they appear in a little embedded player. This has the same functionality as the Android app, though at least one of them is sort of stuffed under the toolbar and not reachable. I don't know if the Windows application includes the player natively or if it relies on Java etc., but it seems native.


In the web interface, the ones that do have text in the body show a VLC plugin embedded player - one for each recording - but they don't actually play, but this isn't an Evernote issue, this is because of my broken plugin.  However, you can still see they are there.

Link to comment
  • 2 months later...
If you are seeing a greyed out box with a puzzle piece in your evernote on Chrome browser from audio files created on your TABLET/PHONE(in my case my android Galaxy S3, AUSUS Transformer Tablet and Galaxy Note 3 although I suspect it happens on most if not all android mobiles.) The box states, "No plug-in to display this content."...
I have contacted Evernote support and they offered their usual apologies and claimed they looked for a workaround, but I think they are confusing workaround with a fix. Well, they offered neither, so it doesn't matter.
I am merely posting this bit so you don't waste your time with support.
...I searched the Evernote Knowledge Base and found not a mention. Not saying that there isn't one, but I was unable to find one.
Which kind of indicates one of two things. 
1) They didn't add the issue into their knowledge base...
2) Their knowledge base doesn't have a good search engine.
Also took me a bit to find this with the blog, but here I am and here we are.
Chrome doesn't offer a solution either.
Here are two tedious workarounds and a more simple solution.
Tedious Workaround 1:
The only thing I have been able to figure out while still using Chrome.
  • Right-click on the puzzle piece or the greyed out area.
  • Click on inspect element. (a new window will open up)
  • Click on the puzzle piece or the greyed out area to make sure it is highlighted in the new window.
  • Find the amr link in that window. Right-click it and click open link in new tab. If a menu opens up that doesn't have "open link in new tab" available(seldom happens). Leave the window, come back and try again.

​This will open your player and the file should play outside of Chrome.


Tedious Workaround 2:
  • Open note in Evernote on Chrome, click share and email the file to yourself. The email will have the amr sound file attached.
It should automatically play it with your quicktime player or VLC.
More simple Solution:
  • Use evernote in a different browser.
I haven't tried IE, Safari or firefox, but it works in Opera Browser.
Good Luck
Link to comment


This topic is now archived and is closed to further replies.

  • Create New...