Jump to content

(Archived) New bug in Evernote Windows v5?

Jose Mora

Recommended Posts

What happens is that when I copy from an original note to a template, everything is fine - until I try to do the second note, or try to sync.  Then invariably it stalls and crashes.  This is now happening on both my desktop and my laptop.

But - get this - that very same note that stalled and crashed, works perfectly when I re-open the program - and then the next one stalls and crashes.   So, I basically stall and crash after each note.

Rather than go to tech support, I will need to rely on my problem-solving methodology to try to pinpoint what is triggering this.

The pattern is very reliable and repetitive.  This means that it has a very specific trigger.   I just don't yet know what it is.

So far Evernote v5 has not handled templates very well at all!
Link to comment

The above failure occurred on two different computers, over three different days, and was very repeatable.  However, I tried to replicate it this afternoon, and everything worked perfectly.


This time, I wrote my exact steps (no change from when it was stalling and crashing).


(1) Select and open a note in its original state, with no template. In this case, it is an email that created using Clip to Evernote.  This email was dated Sept. 25th.  The note was created Sept. 26th.
(2) Select and copy the corresponding template.  In this case it is an email template specific to that client.  This template was created May 16, 2013, and was last modified May 28, 2013.  It has been used successfully over those months.  I am copying this from the templates notebook to the Inbox notebook.
(3) Open the template from the Inbox.
(4) Using dual monitors, expand both to full screen side-by-side.  Note: the copy of the template has today's date since date updates automatically.
(5) Copy title from original to template
(6) Change date on template to Sep 25th, date of email.
(7) Use Ctrl+A, Ctrl+C, and Ctrl+V to copy email body onto designated area of template.
(8) Tag template to indicate that it is now in use with correct contents, and untag it from the templates list.
(9) Delete the original note
10) Close the template
NOTE: Up to this point, everything has worked as expected.  I will now attempt to repeat with the next note.
11) Open note. This is another email, but uses a different email template (OK)
12) Copy template (OK)
13) Open template from Inbox (OK)
14) Expand both side-by-side (OK)
15) Copy title from original to template (OK)

16) Manually adjust date to date of original email [This step would consistently fail this morning and last week] [This afternoon it works perfectly]
17) Copy body from original to template (OK)
18) Delete template (OK)


Since this afternoon it worked perfectly, my hypothesis is that there was something else running in the background that would have caused the problem.


I went to process a new email using Clipper, and suddenly Clipper crashed.  The emails in question from last week were created using Clipper.  


I'm now wondering if Clipper was a contributing factor to this problem.  Not yet sure, but if it happens again, I will report on it.

Link to comment

Let's revisit the observations so far, and consider a new hypothesis:

- The exact same set-up works for a while, then fails to work
- This happens on two computers
- This has happened in three different cities, each with its own internet connection
- When it happens, the triggers can be (a) copying a note, (B) changing the date, © deleting a note, etc.
- I have observed delays from the time I send an email from Evernote to the time that email appears in my Gmail inbox.  Sometimes it happens right away, other times hours later

Can rule out:
- Corrupted notes.  If my notes are corrupted, the same notes would consistently fail
- Other background programs.  Possibly, but I have had all other programs shut off and have had crashes, yet other times, many other programs running and no crashes.
- Internet connection.  Evernote has failed under an excellent internet connection, and has worked during slow connection times

NOTE:  *_All (100%) of my notes contain hyperlinks.  This means that almost any change to the title or date, will trigger some kind of "checking in" with Evernote's server in order to sync and have the current version of that note.  I have observed that I cannot use Evernote hyperlinks when I am in a flight or when it is not connected to the internet.

New Hypothesis
What is happening is a result of my notes and hyperlinks having to "check in" with Evernote's servers.  Evernote's servers will have times of heavy traffic, or times of slow traffic.  When there is heavy traffic, the requests will time out, leading to a stall or crash.  Since my local Evernote is trying to "call home" it finally gives up.
Also, since Clipper must also "call home" in order to transfer the clipped content onto Evernote, it is part of the same failure mode.
The fact that the new Clipper has been found to be unreliable, means that the traffic is heavier through Evernote's servers is heavier than usual.
I believe Evernote needs to look into its bandwidth, especially given the upgrades and increased demands for "calling home."
Link to comment

OK, here we go again.  I am going through a similar process as above and every second note is stalling.


It makes no difference if I exit and re-open Evernote, or if I sync between these notes.  As soon as I touch the title of every second note, Evernote stalls indefinitely.


I cannot explain this particular pattern, but it has now been going on for several hours.  


Needless to say, my productivity is at a snails pace - as it has been for most of last month.

Link to comment

Now - GET THIS!  Since my last comment, I suddenly was able to process about 10 notes in a row with no problem whatsoever!  The problem seems to happen all morning, and into the early afternoon - then suddenly around 2:40 pm - it clears up!


I have made it a point to be extremely consistent in my settings and routine.  In fact, this time I even tried opening up 5 notes at a time, and it worked perfectly.


So, whatever is happening is happening at two different locations, two different computers.  The only commonality is that it is my synced database and that it is communicating with the Evernote servers.


Why is it happening in the same failure mode, during the same times of the day?!?!


Is there some kind of batch-process that Evernote runs at this time?  I am on Eastern Daylight time, so this would be around 11:45 Pacific Time (Evernote's).


Or ... is another app running a batch process that hogs Evernote's bandwith during this time?

Link to comment

Two new unexpected crashes just happened.  During one, I was checking a tag on and another tag off, when Evernote crash.  That same note worked just fine after I re-opened Evernote.


Then, another crash happened ten minutes later as I was closing a note. 


In both cases I sent an updated email to tech support with the attached Activity Log.

Link to comment

OK, now another indefinite stall on another note.  All notes went gray.  Folks, I've now been dealing with these issues for over a month.   I feel that I've spent more time working for Evernote than I've had Evernote working for me.

Link to comment

OK, now a similar issue on the same procedure as described above at step (5) Copy title from original to template.


I clicked Ctrl+C on the original note, then tried to paste it onto the title of the template note by clicking Ctrl+V, and it won't accept the Ctrl+V command.  I can edit the template title, just not paste over it.


And then, as I was typing this, I looked back and the template's note screen turned blank and grayed out. Evernote (Not Responding)


I think I'm now seeing "Evernote (Not Responding)" in my sleep.

Link to comment

Oh, what a lovely day.  Just had yet another crash, this time with the pop-up window.  All I did was highlight a few notes.


Did I mention that I have my own job to do and my own life to live, and neither is about working for Evernote? 

Link to comment

It is important to note that while the morning and early afternoon failures were very consistent and repeatable, every 2nd note, the ones of the late afternoon were very random and haphazard.  The actual mode of failure from the morning and early afternoon did not repeat, even when I repeated the procedure above - with the exception of the title paste freeze that occurred.  

Link to comment

OK, this is another interesting observation- I am finding duplicates of notes that I know I did not create! 


Is there some kind of duplicating process that goes on when a note is deleted, or its title (or date, or header information) is modified?


Sometimes these show up as conflicts, other times they do not.

Link to comment

Working at my desktop this morning.  Had one initial crash, but things are working smoothly right now - no sign of the "2nd note syndrome" even though I'm following the same workflow.


I will continue to report on any failures as they happen.

Link to comment

This morning has been surprisingly event-free!  The same processes that were giving me trouble yesterday, worked just fine.  You could say it is a different computer, but recall that two days ago I was having constant trouble right here on my desk-top.


Whatever this problem is, it appears, then mysteriously disappears.


I'm going to begin entering my own date and time stamp, since I notice this one says 04:57, yet I have 11:57.


Wednesday, October 02, 2013 11:57 Eastern Time

Link to comment

OK, I guess it heard me.  Just had a stall.  I was trying to copy an internal (green) hyper link from one note to another and it stalled.  My guess is that it was one of these "phone home" situations and when it did not hear back from the server, it stalled indefinitely.

Link to comment

Wednesday, October 02, 2013 13:31


And another.  All I did was to touch the windows and they faded out and it stalled.


I guess I just need to work from midnight until noon so that I can accommodate my life around the convenience of Evernote's servers!

Link to comment

Wednesday, October 02, 2013 14:39 (2:39 pm) New York Time


I stepped away for a while, and just returned to continue with Evernote.  A couple of good notes, then ...


All I was doing was looking at a list of notes, moving my mouse over them, when suddenly the notes grayed out and the system went into a stall.

Link to comment

Wednesday, October 02, 2013 16:22 (4:22 pm) New York time


I had just finished processing a few notes, and tried to sync.  Sure enough, the sync stalled indefinitely.


I am sending Evernote Tech Support an Activity Log with each stall.

Link to comment

Wednesday, October 02, 2013 16:53 New York time


I was in the process of completing mutual hyperlinks between two notes, when Evernote went into an indefinite stall.


Look for Activity Log with the same time stamp.

Link to comment

Wednesday, October 02, 2013 17:23 New York Time


This time, I had a list of notes, and I clicked on one to open it.  The frame and title were there, but the content was not.  Yet, I could see the note from the list with the display at the bottom that it had the content.  The open frame with the title then grayed out and Evernote went into an indefinite stall.


Activity Log to follow.

Link to comment

Wednesday, October 02, 2013 17:32


Stall during a search


I had selected a saved search, and then entered a key word to narrow down the search.  The search stalled, and the screen grayed out.  Then Evernote went into an indefinite stall.


Activity log to follow.

Link to comment

Thursday, October 03, 2013 10:48


I had 5 notes open, and was opening up and copying templates for each one, while closing the original notes for which I had a template.  I copied one template successfully, but when I went to open the next one, Evernote went into an indefinite stall.


Activity Log sent with prefix of 2013-10-03 1048

Link to comment

Thursday, October 03, 2013 10:57


Well, that didn't take long.  Now we see the other mode of failure.


I had opened up one of the original notes, and made of copy of its template.  I then went to copy the title from the original to the copy of the template. 


I selected Ctrl+C after highlighting the title of the original, then Ctrl+V over the title of the copy of the template.


The copy of the template would not accept the paste command.


However, I was able to manually modify its title.


And, of course, as I was typing this, I see the blue circle of an indefinite stall.


Activity Log sent to Tech Support with a prefix of 2013-10-03 1057

Link to comment

Thursday, October 03, 2013 11:44 


After processing several notes successfully, with no glitches whatsoever, I copied a title from one note to another, and the target note, after accepting the title, grayed out and Evernote went into an indefinite stall.


Activity Log sent with prefix of 2013-10-03 1144.

Link to comment

Thursday, October 03, 2013 11:49


Just to summarize:


- Same computer

- Same software

- Same procedure

- Same types of notes

- Same internet connection



- Different computer

- Two different cities in two different states

- Same set of notes

- Same pattern of "works, then doesn't work"


Has all kinds of stalls and crashes, then suddenly works okay for about 45 minutes, then has stalls and crashes, then works okay for several hours.


Just wanted to point that out in case someone is going along the path of "there must be something wrong with this guy's computer(s) or software(s), or his internet connection(s)."

Link to comment

Thursday, October 03, 2013 14:25  


After running smoothly for over two hours, Evernote went into an indefinite stall.  I had just opened seven (7) notes at the same time, and was about to change the tags on one of them.


Activity Log submitted with prefix of 2013-10-03 1425

Link to comment

Thursday, October 03, 2013 15:12


Took a break to see if system settled down.  Opened same notes.  One processed successfully, the next went into a stall.


I think at this point I've sent in enough Activity Logs.  However, I will keep entering the stalls and crashes here.

Link to comment

Thursday, October 03, 2013 20:24


I had been away for a few hours, so just started using Evernote again.  Processed a couple of notes successfully, then as I was making a search from a saved search and adding some words in the search box, Evernote went into an indefinite stall.

Link to comment

I don't think there are any specific steps that reproduce your crashes. What version are you on? We've made some crash fixes in the past two weeks and just pushed out an update today. Let me know if it gets any better

Link to comment

Thursday, October 03, 2013 21:42


Hi, dlu,


Ok, I just downloaded version (269382) and have processed about 10 notes without any trouble.


Interestingly enough, it went into a few stalls, but then recovered!  I had not seen that in quite a while!  :-)


I'll report on any new issues.

Link to comment

Friday, October 04, 2013 7:45


I've been working for about an hour now, following my usual work flow and Evernote's performance has been rock solid (knock on wood).  This is with version (269392).

Link to comment

Friday, October 04, 2013 8:27  Very noticeable difference!  The same search steps that would previously trigger an indefinite stall, do still cause a temporary stall, but this time, the system recovers from it.  This is definitely a more robust version.

Link to comment

Friday, October 04, 2013 8:37


OK, I haven't seen anything like this in quite a while!!!  I just opened several windows, was clicking, editing, and closing windows so fast that I was sure I had tripped up the system.


It began to to a stall ... I thought it was down for the count ... and just like a champ, it recovered, got back up and was right back in the fight!!!


It's seems like a long time since I've had something positive to say.

Link to comment

Friday, October 04, 2013 8:53 


Just got through the rest of my work flow in record time.  Amazing.   If I didn't love Evernote so much when it does work, I would not get so frustrated and angry when it doesn't.


One major advantage (when it works) is the ability to open up each note as a separate window and move it around.  I tried to do that with OneNote, and it could not be done.  


This allows me to use dual monitors, and process my workflow very quickly.  Once I complete a step for a particular note, I close that one, and go to the next.  I try not to open more than 10 at a time.  Of course, when I am caught up, there aren't ten there to begin with because everything is moving quickly through my workflow.  

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...