Jump to content

(Archived) Pdf "thinks" indefinitely, doesn't load


Recommended Posts


When I open skitch, the pdf I want to open and edit just thinks indefinitely--I can't open it or delete it or do anything to any of my notes because that one sits there with the load wheel. I've waited on it to load for hours, and nothing. Please help, I need to be able to edit it, or delete it, or do something to it asap....Skitch is useless like this :(

Link to comment

@splendidleigh - Have you tried killing the app and then starting again? Depending upon your version of iOS double tap on the home button while on your home screen. This should bring up a scrollable list (iOS7), or a tray with icons (iOS6), of your active programs. Find Skitch in that list and if on iOS 7 simply swipe upwards; on iOS6 old and tap and "X" that appears. You can also try restarting your phone.


That will remove Skitch fully from memory and stop whatever activity it was trying. You should be able to start Skitch again.


At this point you can try again, or if this PDF continues to be problematic, log into your Evernote account (if you have it saved there) and try deleting the PDF from there.


What exactly is in this PDF? Is it a large set of images or video? 

Link to comment

Yes, I tried exiting the program completely, several times, and it never made a difference. 


It was just a text file, a journal article--nothing too big. I did end up deleting it from my Evernote account. Unfortunately this meant I lost all of my annotations made in Skitch.  Oh well.


Thanks for the reply.  

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...