Jump to content

(Archived) Web Clipper for Firefox - 2 problems


Recommended Posts

Today, I encountered the same issue with my web clipper extension in Firefox on 2 separate machines, one a Mac, and the other a PC running Windows XP Pro.

First, if you all included this as a "new feature" but I used to just click the little extension and it would automatically create a web version of the page I was on and place it into my Evernote notebook. Now, if I don't select anything, it comes up with a message about a "quick note," and if I actually want to save something I have to manually select it. I think this sucks, personally. I would at least like to see if there is a way to set up what I would like as a default - either the "quick note" or the "auto web clip."

Second issue is a technical glitch that I experienced on both machines. After selecting text and creating a note, the back button on the browser no longer works. I have to manually go back to the home page of the website and navigate back to where I was.

Let me know your thoughts and recommendations.

Thank you,


Link to comment

We added the "quick note" feature based on feedback from a lot of users, but we're looking at ways to offer whole-page clipping as well without making the interface complicated.

Your second issue is a bug, thanks for the report.


Link to comment

Great, thanks. Being able to go into the extension (somewhere) and select if you want the button to do Page Clip, or quick note, would probably work well. Or, when the window pops up, have a method to select which one, and have it remember the last one you selected when you press the button at a later date/time.

Software is awesome though, so congrats.

Link to comment
  • 3 weeks later...

running Firefox 3.08 on mac osX-10.4.11.. web clipper doesn't work. with text highlighted, clicking on the elephant on the toolbar has no effect. I have also tried uninstalling and reinstalling the clipper yet the same problem continues. Have also tried using the Apple+mouse click menu "add to evernote" and find that nothing is added. this problem occurs consistently on different sites. Just for example you can try http://www.johnmuirhealth.com/index.php/contact_us.html

My inconvenient work around here is to always keep a browser tab open to my evernote page, then use Skitch to get a screenshot and drop the resulting jpg into my evernote notes.

appreciate your input on fixing this problem.


Link to comment


This topic is now archived and is closed to further replies.

  • Create New...