Jump to content
  • 0

(Archived) Print to PDF loosing any links?



Sometimes I want to export a note from Evernote to PDF and of course I want to retain any active link that's in that file. Usually I'd print the note to PDF from my iMac (CMD-P > PDF ...). However in the resulting PDF file, all links are lost. They do *look* like links, but there *are* no links.


Therefore, as a workaround, I copy the note's content into a new TextEdit file, and print that as PDF. A bit cumbersome, but this way it works. 


Now I wonder why Evernote doesn't export the HTML links? A bug?

Link to comment

6 replies to this idea

Recommended Posts

  • Level 5


Hi icoco,

In my case, the links in the created PDF works for links to files & URL's (web pages), but NOT for links to evernotes notes.

Yes, that is what happens here too.


Thanks for posting. I was able to reproduce this. I've reported it internally for our developers to look at.

Link to comment
  • Level 5*

Since PDFs display their content in notes,  have you tried printing to PDF / attaching to note / exporting again?


If you think this is a bug / if it is a continuing problem,  you should raise a support ticket (see below).

Link to comment

Hi gazumped, thank you for sharing your thoughts. However, I am not sure if we understand each other correctly. What I did is open the respective note in Evernote on my iMac, press CMD-P to print, choose PDF > Save as PDF ... and let go. Now I'd expect that the resulting PDF file would contain all links that were contained in the original note within Evernote. Instead the links within the file were not active; I can see them, but clicking on them does nothing.


That said, today I tried a few other notes, and now all resulting HTML links were working properly. So I guess the issue might be related somehow to that special note. I guess I'll close the case so far.

Link to comment


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...