Jump to content

(Archived) Losing Note Content With Widget


Recommended Posts

I have been losing note content while using the widget, and it finally got so awful that I decided to investigate. I managed to replicate the issue. Here's what happens:


1. Hit "Add Text Note" (plus sign) on widget

2. Create note: e.g. type "test" in the title and "test 1" in the body of the note

3. Press home button instead of the checkmark icon. "Saving note" notification is shown.

4. Now click on the note in the widget window.

5. Edit the note: e.g., type "test 2" on the second line. Press either the checkmark or the home button. "Saving note" notification is shown.

6. Now suppose you want to create a new note. Hit the plus sign on the widget again. Instead, the "test" note appears for editing with only "test 1" in the body. If you edit and save this note, the "test 2" part will be lost.


This is unacceptable. Clicking the home button instead of the check sign to save the note should not be causing you to lose data like that. Either 1) make sure that when the home button is clicked, the widget's "New Text Note" mode is exited, just like what happens with the check mark OR 2) clicking the home button should not result in saving the note -- that way you would not be able to add content to the note that is liable to easy loss until you click the checkmark. 


This must be fixed.

Link to comment
  • Level 5*

Which mobile client are you using?  I just tested this out,  and no matter how I try to jump away from the new note I still get the content - either on screen,  or saved in the note.  When I then edit the note and jump I get the additional content saved as you'd expect.  Have you tried just using the 'save' check mark when editing?

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...