Jump to content

(Archived) Screen capture not responding


LilKim

Recommended Posts

I'm after anyone out there that might have some genius idea that I haven't come up with yet.

 

Recently, my Skitch has stopped working. I am able to open the program, log on, but when I go to screen snap something nothing happens. I've tried every other kind of capture as well (fullscreen etc) and still no response in the program.

So I went off an uninstalled it and reinstalled it via the App Store (Mac style) and tried again. Still no response. I then went and uninstalled it again, and installed the direct download from Evernote-Skitch page. No luck again. I even updated it to the Beta version to see if that would help and I still can't capture anything.

Now I absolutely love this program and would really like to continue using it, however, I'm out of ideas. I haven't changed anything on my computer recently or even used Skitch for a couple of weeks due to being away.

Has anyone got any genius ideas that I could try?

Link to comment

@LilKim - Are you sure you've deleted all versions of Skitch between installs? OS X can behave oddly if you're running multiple versions of an app on the same Mac. Please make sure you've dragged any extra versions to the trash before trying another install. 

 

If that's not the case, are you running any applications that also try to do screen snapping? Or any application that might be intercepting your keyboard commands?

Link to comment

Hi Joe,

 

Yeah I made sure that I only ran one version at a time. At this point the only one I'm running is the direct download - I am a bit of a perfectionist and like things neat so I made sure I only had one version installed so I didn't confuse myself!

 

I have only ever used Skitch on my mac for screen shots as I've only moved to Mac's 1.5 years ago - before that I was all PC and someone recommended Skitch to me and I never looked back. I might have to look around at all my programs installed and see if it has a little side project of screen shots in it that might be conflicting...

Link to comment

Hi Joe,

 

I have the same problem. It was working fine up till about 2 weeks ago then the screen capture feature quit. I upgraded from 2.something to 2.5.2 (the one prior to 2.6), but that didn't fix it. I've since upgraded to the latest version and it's still the same.

 

I've checked but don't have any other earlier versions lying around. I can use 'Camera' and 'Blank', but the top 3 options (Full Screen, Screen Snap, Timed Screen Snap) do nothing.

 

If you know a fix it would be greatly appreciated. Thanks.

Link to comment

Same issue - installed from Evernote site onto OS X 10.8.4.  Image/PDF works, but none of the screen capture options do anything.

 

 

UPDATE: Uninstalled the web site version and installed from the App Store - all now working...

Link to comment

Just downloaded Skitch (using Mountain Lion 10.8.4 on a brand new MacBook Air, so the download went through the app store), and I am also having the same problem. It occurs in every browser I have tested (Safari, Chrome, Firefox).

 

The "window snapshot" and "menu snapshot" options work if I select them from the "CAPTURE" drop-down menu that appears in my menu bar. But none of the features work from the mini drop-down.

 

Currently I use SnapZ Pro, and wouldn't be too happy if I had to uninstall it because I use many of its features in addition to the screenshot option. If necessary I could disable it temporarily, but ideally I'd like to have both at my disposal depending on the project at hand.

 

Am also using Evernote and love it.

 

Thanks.

 

Link to comment

Hey all, we're digging into this but right now are having a hard time reproducing the same issue internally. We're continuing to investigate and one our QA Engineers may reach out to all of you individually in order to get some info which may help us diagnose the problem.

 

I just tested using both Skitch main app and Helper on a 10.8.4 MPBR and had no issues.

 

@KateWOM - When you did menu snapshot did you see the prompt telling you to select a menu? Did the countdown start when you selected one? If you have not tried it can you select menu snapshot and then select a menu and wait 6 secs to see if a snapshot appears?

Link to comment

Hi Joe,

To answer your question: Yes, when I tested out the "Menu Capture" option using the menu bar drop-down, I did get a window that said "Pull down a menu, then wait for the countdown to complete the capture." The clock ticked backward and then captured the menu.

Link to comment

Hey all,

We have posted a new release, 2.6.1, available for download on "evernote.com/skitch". Please download this update directly from the website as the Sparkle update most likely will not work for you if you are seeing this issue.

Thanks,

Lester

Link to comment

Wow, the fix is awesome! Thanks so much for such a fast response. And the best part is the Skitch heart icon now appears in my upper menu area. Didn't even realize that it wasn't showing before.

 

Just took a couple of "crosshair" screenshots and they worked beautifully. Hooray!

Link to comment

Sorry I've been offline for a couple of days everyone.

Can I just say - a massive shout out to the Evernote crew who were not only quick to respond but offered FANTASTIC service. Super impressed!

Thank you so very much! 

Link to comment
  • 4 weeks later...

@Joe, Yes, I'm quire sure. I was running 2.6 when the problem surfaced. I've been a long-time skitch user and when you switched to delivery via the App store, so did I. When I upgraded, the system asked if I wanted to keep both copies or replace and I chose replace. I've just used Spotlight to search again and it only shows one Skitch application. I've looked in the Application folder and see only one version (v2.6.2).

 

I had to get on with my work so I just bought Glui for $4.99. I have to say that since Evernote bought Skitch, the net result has been less than desirable.

Link to comment

@Chip - That's pretty odd that you're seeing the missing crosshairs while running Skitch from the Mac App Store. That bug was only impacting the direct download version. I'll have one of our QA Engineers reach out to you to try and get some additional information so we can investigate. 

Link to comment
  • 3 weeks later...

Same issue.

 

2.6.2 - removed and then reinstalled via the App Store.

 

Crosshair Snapshot - get the crosshairs and the shutter sound when I click 'Capture'... but nothing comes in to Skitch.

 

Fullscreen Snapshot - nothing... no sound and nada into Skitch.

 

It's been working fine and nothing material has changed in my setup. Certainly no other screen capture apps.

 

Any ideas?

 

cheers

 

Pete

Link to comment

@Chip - That's pretty odd that you're seeing the missing crosshairs while running Skitch from the Mac App Store. That bug was only impacting the direct download version. I'll have one of our QA Engineers reach out to you to try and get some additional information so we can investigate. 

 

Joe, it appears the problem seems to manifest itself after I've plugged in the Cinema LED display and may be limited to snapping the browser (maybe just Safari) though I think I tried Firefox and/or Chrome, too.

Link to comment
  • 3 weeks later...

my issue is similar but different. until I click on skitch in the dock nothing, like the crosshair snapshot in the mini menu works. it's as if skitch is not actually running even though the menu item is there. this only happens after a boot.

 

Version 2.6.2 (262912)

ML 10.8.4

Link to comment
  • 1 month later...

Hello, I'm experiencing the exact same issue as the OP. 

 

I have reinstalled countless time making sure to delete all Preference files as well. 

 

I have deleted the web version and installed the app store version, no change. 

 

I am currently running 2.7, issue first started  on 2.6

 

Mac ML 10.8.2

 

So frustrating...

Link to comment

Emilie 

 

I'm going to pass this over to one of our QA Engineers to look at but have you tried the following:

  • Deleted (even from your Trash) any old or beta copies of Skitch? <- This is very important as OS X may load up incompatible components of old or beta apps with the running version of Skitch which can result in odd behaviors.
  • Made sure none of the apps you're running in the background interfere with Skitch? See Peter's post above.

It looks like you're running an old version of 10.8. You can upgrade to later version of 10.8 or even Mavericks (it's free) and that could clear up the issue.

Link to comment

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...