Jump to content

(Archived) FireFox Error - Webclipper no longer compatible with Evernote service?


Recommended Posts

All the sudden I am getting an error that says "Webclipper no longer compatible with Evernote service. Please install the latest version" when I click the clip icon.


The problem is I'm running v5.7 which should be the latest.  I even tried re-installing the addon to no avail.


I'm using Cyberfox 21 (x64 version of Firefox) on Win7.

Link to post

Sorry for delay in answering. The Web Clipper does not currently support x64 versions of Firefox. We are working on enabling that in the near future. 


I don't think that x64 Firefox is the issue for the following reasons:


1) Because prior to this recent snafu, I'd been using Webclipper on my x64 Firefox build for months with no issues whatsoever

2) Webclipper gives me the exact same error when I run my profile under x32 Firefox

3) So far all addons (*not* plugins like Java & Adobe Acrobat, mind you) I've encountered have worked flawlessly on either x32 or x64 builds of Firefox.



Add-ons and Plugins (quoted from here: http://www.firefox64bit.com )

It should be noted that 64-bit Firefox only support 64-bit plugins, the 32-bit plugins cannot be used on 64-bit build. It can suport any addons that are compatible with the 32-bit version as these addons are not compiled but interpreted javascript.


Is there any sort of debugging I can enable to get more information about this issue?

Link to post

I just created a virgin FireFox profile, and installed the webclipper under Firefox x64.  It worked just fine, so as I mentioned above, the addon is already compatible with x64.  It seems that the "Webclipper no longer compatible" error is bogus or just some sort of default message. This leads me to believe there is something wrong with how the latest version of the addon was installed in my profile.

Can you help by giving a list of what needs to be removed from my profile to manually cleanup what appears to be a botched install?  (See here for my failed attempts to use the addon removal feature built into FireFox)

Link to post

Thx for the detailed report.

I guess what I should've said is that we do not test and officially support x64 versions yet (but working on it, I know 'native clipping' is not working in my latest tests..)


I'll have to run this by my technical team for a deeper investigation. I'll post back with my findings.

Link to post


I compared the fresh install profile to my standard profile using Winmerge and the only Evernote related difference I could see was in the evernote_webclipper.sqlite file. 


When I copied the evernote_webclipper.sqlite file from the fresh install to the profile where I was getting the error, Webclipper magically started working again in my standard profile.


I can provide you with dumps of the working & non-working data stored in the SQLite files for comparison if you want.  I'd post them here, but I'm not sure what info in the database is sensitive to my account and shouldn't be shared publicly for security reasons.  Let me know if you have an email address I should send them to, or some other private means of communication.



I know 'native clipping' is not working in my latest tests..


Also, I'd agree - native desktop clipping doesn't work for me in x64 (it's grayed out) - I've only been using the web integration for clipping.

Link to post

So, the plot thickens a bit.


I was trying to replicate the error and have determined it wasn't exactly the evernote_webclipper.sqlite but a journal file that was corrupted.  I have a file called "evernote_webclipper.sqlite-journal" that I renamed along with the "evernote_webclipper.sqlite" file.  The journal file is corrupt according to windows, and allowed me to rename it, but I cannot delete that file.  Every time I try deleting it, windows throws an error, but happily allows me to rename it.


I had renamed the file extension it to ".bad" along with the actual sqlite DB file and everything worked using either the new or old copies of the "evernote_webclipper.sqlite" file.  It appears that the corrupt journal, when found by sqlite, bugs out the addon and causes it to throw my "not compatible" error.


I could try to send you the journal file, but I don't really think it's of any use now that I've determined it's not the contents of the "evernote_webclipper.sqlite" database file, but the journal that is causing problems.  Maybe you can simply add a better error handling routine to catch a SQLite error and not give such a general response of incompatibility?

Link to post


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...