Jump to content

chrome Clipper Couldn't Start on this page......

Recommended Posts

When trying to use Chrome clipper, getting the attached message. Have tried reloading multiple times, now trying the forum. Have not tried re-booting yet, will have to wait until the end of the day for that.


Share this post

Link to post

Had the same issue for Chrome and Mac OSX 10.7.

I managed to get the Web Clipper after several attempts:

  • first try Chrome crashed when trying to start the Web Clipper, gave up
  • tried again after a week or so, and this tome go the "Clipper Couldn't start on this page"
    • After several tries, I got the Login prompt

After some digging, it turned out that my Keychain Access web password for evernote was out-dated, so I suspect this was the cause. So if you encounter the problem I suggest you clear all stored passwords and try again.

Share this post

Link to post

@stefan you were a life saver... \m/


but it started and died again...cleared the password again but still of no use!!!!



after certain digging in I realized you have to reload any pages if browser restores them or else they will show the error...

Edited by ja8zyjits

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...