Jump to content

firefox How to clip local XHTML page?

Recommended Posts

Apologies if this should be obvious to me. Having recently discovered EN and purchasing an Android tablet, I have found EN a great tool for class notes and readings in my MBA classes.

Many documents are provided to students (such as a syllabus) as a Word .doc file. Web clipper does a fine job of grabbing web pages, so I exported as XHTML from Openoffice. It opened fine in Firefox and Web Clipper offered to save it as a note, but only the URL, not the page.

Try as I might, I cannot get Web Clipper to save the actual page. Worse, it saves the URL of the local file on my desktop (e.g. file://home/marty/blah.html), making it inaccessible from my tablet. I tried a simple copy/paste but all tables and images get lost.

I could always convert to PDF but Android EN cannot render those, so they just show up as an attachment which makes browsing documents more cumbersome.

Is there a graceful way of tricking web clipper into copying actual XHTML?

Many thanks,


Share this post

Link to post

It seems I double posted my original post -- apologies.  I tried the same thing in IE 9 under Windows 7 and it tells me, "Clipping from this location is not supported."  That is the case with XHTML, HTML and MHTML (HTML archive?).  It happens when the item is on a shared drive or on the desktop.  It happens when I have a local copy of a remote page that Evernote Web Clipper would otherwise happily clip.


From what I can gather, Evernote Web Clipper refuses to clip a local page, but will happily clip the URL, an URL that is completely invalid on every other device.  I cannot make sense of this at all.  If I had a local web server configured I would use try clipping it from there.


Surely there is a reason the EN folks did this, but I cannot imagine why.

Share this post

Link to post

For the next person trying to solve this problem, it seems this is indeed a nuance of Web Clipper.  I installed a small httpd server on a virtual machine, copied over the files and they clipped just fine on the local machine's browser.


In short, Web Clipper refuses to clip local files.  If you want to clip them, copy them to another machine and access the other machine with your web browser.

Share this post

Link to post

I know this post is a bit old but I found it while searching with the same problem. There are various potential solutions that I have eventually discovered. Direct import of an html file (via the import folder in windows Evernote) only works for simple files and normally fails to include pictures and also changes the formatting. In my experience this is actually more likely to fail if you embed pictures etc in the file.

My best solution is as follows: Save the html file to dropbox. Open the file on the dropbox web interface - you need to open in a new tab in order to see it without any dropbox clutter. You can then use the webclipper.

Another solution that works is to cut and paste the file from chrome into gmail and then either use the webclipper from there or even better, if you are a premium user, e-mail into Evernote


Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...