Jump to content

(Archived) Export image is not complete


Recommended Posts

Hi guys,

I work on an image in Skitch then save and then export it to have it a JPG version which is usually smaller in size. Most of time when i export it never saves the text or notes i wrote in the image while working on it. It is strange since in my Folder i will have it with text but NOT when i export it.


I am attaching the samples of


Image edited and saved


Image exported as JPG, no text



Any help or ideas?








Link to comment

@uzapuca - I think you found a bug for us. It appears when you do the following you run into the bug:

Add text to an image (but do not save or click off of the text)

Export using the menu command

Image will export with any saved annotations, but not the text that is currently highlighted.


While we work on a fix here are a few simple workarounds:

Option A - Save your image first and then export <- This will ensure that all of your annotations are saved to the image.

Option B - Make sure you click elsewhere on the canvas after you've typed some text and then export <- This will deselect the text and allow for it to be exported.

Option C - Use the "Drag Me" tab at the bottom of the canvas window (Select JPG first if that is the format you need) and then simply drag to your desktop <- This method is working properly where all annotation objects are saved first before creating the file. 


Thanks for finding this bug and pointing it out to us. 

Link to comment
  • 4 weeks later...

Hi, this is not working for me either with version 2.0.5 (262483) on Mac OS 10.8.2.  I tried the work arounds suggested by Joe, but none of them work.  Even opening a saved skitch with text and then exporting, still product a JPEG file without text annotations.

Link to comment
  • 2 weeks later...

I just had this same experience. I worked for a long time making a series of explanatory photos for a knitting project in Skitch, using shapes, arrows and text. The shapes and arrows exported but not the text. This is true even after saving multiple times and trying multiple exports. This is certainly exasperating.

Link to comment

I found a (bad) workaround. I emailed myself the Skitch notes. They came as pdfs, which opened in Preview. I then exported the notes as jpegs, and this time, everything was there. This round robin method resulted in very poor pictures, but I really needed the textual explanatory material for my posting, so it was better to have bad pictures with the text labels than good pictures without the notes.

Link to comment
  • 2 weeks later...

I encountered this as well. Frustrating.


For the time being, my work-around is to simply do a screen capture of the image <Shift> + Command + 4. The resulting screen capture is png so I open it in Picasa and perform an export to make it a smaller file size. Of course, you don't have to go through those steps or you could set jpg as your format setting for screen grabs or use a different image editor.


BTW, I found a useful post for changing screen shot formats and saving them to a folder of my choosing. It worked perfectly for me! http://www.justinsblog.com/2012/11/28/how-to-change-screen-capture-format-on-your-mac-os-x/


Wondering when a fix will be released??



Link to comment

Please download Skitch 2.5 and see if you are having this issue. We patched a the original bug as discovered by @uzapuca. I just tested the same steps as outlined in my first post, and I did not see any issues exporting an image while text was still selected. 


You can also try using the other methods outlined above aside from File-> Export command. 

Link to comment
  • 2 weeks later...


It seems that the issue is still remaining. I am using v2.5.2 of Mac version.

I have 3 texts with an image in my Skitch and when I exported them to PNG file, the image and 2 texts were exported but the other one was not exported in the PNG file.

Then I tried to remove the text and re-create the same text and exported agin, but in turn the another text was not exported though the new text was exported.

I tried once again to re-created the failed text, and finally It worked. So strange and annoying behavior.

I am not sure but it likely happen when relatively long and big text is included in several texts and the last text among them would not be exported.

Link to comment
Maybe I can but you may reproduce the issue by yourself if the issue does not depend on my environment. The steps are as follows.
1) Make 800px x 800px PNG file with your graphics software.
2) Open it with Skitch.
3) Put 2 text line. 1 is set very big by dragging the thumb to zoom in as you usually do and other one is also somewhat big.
4) Then you save or export the image, you'll find the second text does not exists on the image.
Please refer the image in my public notebook.
My Mac OS version is 10.7.5 and it seems that Windows version does not have such a problem.
If it depends on my environment, It's OK for me. I can do with my Windows version.
Link to comment
  • 2 weeks later...

I had the same problem.  On my mac I had Skitch version 2.0..something.

I think I got this from the evernote web site. I had the app on my desktop while deciding if I liked it or not.  I guess that version doesn't auto update.


So I moved it to the trash, got a new version of skitch from the app store (2.5.2) and I can now export the image with annotations.

Link to comment


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...