Jump to content

(Archived) Leopard-specific problem


Recommended Posts

Hi, I'm running 10.5.8 and it'll be a few more months before I have time to upgrade to 10.6+

A few weeks ago Skitch 1.07 quit working in my usual user, but worked in two back-up users on my computer.  I assumed that there was a problem with my home folder, but I have since discovered that Skitch does not work in any newly created user, or for that matter, on any user on any volume running 10.5.8 on which it the app is not already installed.  And it does not work on my laptop also running 10.5.8 which did not have it installed or on a "troubleshooting" volume which has a reasonably-clean install of 10.5.8 but is rarely used and which I keep as clean as possible.  I can delete everything all the prefs, app support files etc from an old user and have skitch work as if i'd just installed it.


By "not work" I mean that the menus are greyed out.  In order to use skitch, I have to make a snapshot to get the window to open and then I can drag files into the window and use a couple of the buttons, but any menu other than the snapping commands that has to be accessed with either the menubar or a keystroke is unavailable.  (see attached image).


If it helps, when I do a new working install in one of the old  users, I get a different welcome screen - one showing arrows pointing to buttons to teach the user how to make skitch work.  When I do a new nonworking install, all I get is the attached welcome screen.


I figured out how to get versions 1.03, 1.04 and 1.06 and 1.07 fresh from your servers, but none of these worked either. 


Needless to say, I tried all the usual troubleshooting steps such as repairing permissions, resetting the permissions on my home folder, running Disk Warrior, running in "safe" mode. I deleted the app, reinstalled, deleted prefs, application support files and caches - no good.  I tried restoring prefs, application support files and caches from the user that had a working skitch on my backup volume, also no good. I have deleted all browser cookies a number of times and I don't have a skitch keychain.


So to be absolutely clear - if Skitch is not already installed and working properly in a 10.5.8 user, it doesn't work on any volume running on two different computers.


desktop running 10.5.8 "usual" user - quit working, complete reinstall of everything "skitch" won't make it work

10.5.8 desktop "backup" user that already exists - works

10.5.8 desktop newly created user - doesn't work

August backup volume "usual" user works

new user created on August backup volume - doesn't work

fresh install on troubleshooting volume - doesn't work

fresh install on laptop that had no prior installation of Skitch - doesn't work


Have you or Apple done anything to cause this issue?  (Find it hard to believe that it's Apple, since the app doesn't run on my rarely-touched troubleshooting volume.) During the time we had to go through the app store for upgrades, I always upgraded via the in-app upgrade menu and only recently got v. 1.07 directly from the Evernote site, so I don't have any "pre-Evernote" zip files.



Link to comment

@hoodsmon - There is nothing we have done since we no longer support 1.X Skitch nor do we support any version of OS X prior to 10.6.4. 


We currently only support Skitch 2.x (current version is 2.0.4) and OS X version 10.6.4 and up.


As it stands if the old version of Skitch was working for you, then it should have continued to work unless something changed about your underlying 10.5.8 system. Since we do not updated Skitch 1.X anymore, there is nothing that could have changed in Skitch 1.x to have caused this issue for you. 


If possibly I highly recommend you download the latest version of Skitch and see it will run for you, though it may have issues running on Mac's with OS X versions prior to 10.6.4.

Link to comment

for the benefit of anyone still on 10.5.8 - any version of Skitch greater than 1.07 won't launch at all, just bounces around in the dock. (And there are some versions of 1.07 that don't work on Leopard - if you drill down into the info.plist in the application itself, you can find the minimum system version).


EDIT: and I was wrong about being able to reinstall skitch on a user on which it was previously using.  I broke Skitch (permanently, I'm afraid) on multiple users with experimenting. I suspect that deleting either the preferences or support files is what breaks the app. Unfortunately, restoring all the support files from a back-up does not help.


I never synced to my online accounts, only need the annotation function so my (not too satisfactory) workaround for all of this has been to launch a screenshot with the .skitch extension or launch skitch and do a screenshot, use the buttons to accomplish what I want in terms of screen annotations and hide skitch until I need it again.


I'm just glad 1.0.12 works on 10.6+, to which I will be upgrading.  The current versions do not do what I need when I make annotated screenshots.


EDIT AGAIN:  I think I may have solved my issue.  The trick seems to be having a password in the accounts section and keeping Snitch from communicating with anything other than Skitch.com on port 443. Skitch communicating with anything else or skitch.com on port 80 on first launch seems to be what's breaking the old app. I was able to get Skitch working in four different users, but it wasn't easy. If you have Little Snitch, I **think** this might work: create a new skitch account and enter any password in the password field. Quit Skitch and launch again. If you are lucky you could get  asked only to allow connections to skitch.com on port 443 - just allow that forever. If you are unlucky and get asked to allow communications to skitch.com on port 80, say yes, quit Skitch and use Little Snitch to change the port to 443. This doesn't give old Skitch the ability to communicate with my Evernote account, but I don't need that feature.


EDIT AGAIN: It's been six months since I made the above fix and all is well with my Skitch 1 installation on Leopard. And altho Skitch 2 has finally become usable, it has a number of annoying behaviors - primarily assuming that Evernote is the center of the universe and so requiring extra clicks to dismiss attempts to conncect to Evernote. I'm still sticking with version 1 on my 10.6-10.7 installs.


EDIT AGAIN (9/2014): I just upgraded my computer from 10.5.8 to 10.8 and Skitch 1.0.7 still works (yes!) And I installed 1.0.7 on another computer running 10.5.8 "from scratch." If denying connections from Skitch other than those on port 443 was important last year, it doesn't seem to be now. I have done the install in four different users on the new computer and I'm pretty sure it works. I wrote up the steps on my google sites page.

Link to comment


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...