Jump to content

(Archived) Cannot install update


Recommended Posts

I got the message about a new version (4.6.1 build ???) available via the Evernote desktop (Windows) program. However, installing it though this popup has never worked for me in any previous versions. It keeps telling me that I need administrative rights in order to get Evernote installed properly. But during such an installing, I am unable to 'turn on' administrator-mode, so I need to cancel the installation. At this point, I can no longer use the previous version of Evernote because that was already deinstalled.

So I download the update manually from the website and try to install it regularly. This has always been effective with previous versions, untill now.

Whatever I do, start the exe file normally or as an Administrator, I keep getting the message that I need to have the right Administrator rights to install Evernote.

Does anybody have the same problem?

How do I get it to work?

I run Windows Vista btw.

Thanks in advance!

Link to comment
  • Level 5

WIN Vista is OLD. You might think about updating to Win7 (or Win8).

Still, the update should work, even in Vista.

There are probably some leftover files and/or registry entries that EN finds on your machine.

I'd suggest you use REVO uninstaller and do a clean un-install (backup your .exb file first).

Then re-install and sync. Everything should be fine.


Link to comment

I'm getting the exact same problem, though I'm running Windows 7, so I don't think it's an operating system problem. Additional notes:

1. The update version being installed is

2. The failed update apparently nuked the old version of Evernote before it hit the install problem. So that means I can't go back.

3. I tried to do a fresh install using the latest installer from the Evernote website and I hit the same error.

4. I tried to "Run as Administrator" the installer, since that's what the error says and that doesn't help.

5. I looked in Add/Remove programs to try to clean out the old version entirely and it's not listed.



Link to comment

I think I figured out the source of this problem, or at least have a lead to go on. The de-install of the old version seems to have left an orphan folder... Program Files(x86)...Evernote...Evernote...Intl. This folder doesn't have an owner (hence the admin permissions error) and I can't do anything with it (delete, rename, change ownership, etc). I tried deleting the folder from a command prompt, too. Nothing works. Help!


Link to comment

Oop. Problem solved. Should have tried the whole "when in doubt, restart your computer" troubleshooting step I always tell my in-laws to do. My helpful colleague suggested, "Restart your computer and try again. It could still be in use from the horked uninstaller".

That did it.

Link to comment

WIN Vista is OLD. You might think about updating to Win7 (or Win8).

Thank you for reminding me that I am too poor to pay for replacing an otherwise good working operating system...

There are probably some leftover files and/or registry entries that EN finds on your machine.

I'd suggest you use REVO uninstaller and do a clean un-install (backup your .exb file first).

I did the backup, used REVO and CCleaner to cleanup. But still the install didn't work.

I looked for any orphan folders, but couldn't find anything.

Restart didn't work either. :s

Link to comment

I'm using Windows 7 and have consistently had the updating problem too I don't remember actually what I did to update last time, but this time I chatted online with support and they said I should uninstall and Reinstall Evernote from Programs in Control Panel. I haven't done that yet becuase I haven't had time. But now I do and since I'm new beta tester, and didn't mention that to the support person, I'm not sure if that's what I should still do. In reading the earlier messages it mentions backing up the .exb file. I have 2 of these files, both installed on the same date (probably the date I first installed Evernote) and both small. What are they and should I do this, and is backing up just making a copy of it? Also, since I am a new beta test, I was wondering more generally what our role is? Is it just to use it a lot (because I do) and are our usage files and potential problems sent to you automatically, or should I go on the correct forum when I have a problem and report it, read the threads etc? Is there anything writttenon what beta testers should do? Thanx.

Link to comment


Did you sign up as a beta tester somehow, or are you just getting the pre-release versions because of the checked box in the EN profile? I was doing the pre-releases a few months ago, but quit just as things got messy - they took away the shared tab, fouled up search, and a lot of other "interesting" changes. Maybe I wasn't a beta tester by getting the pre-releases, I thought I was.

Anyway, I think this is the latest thread on Windows RC (Release candidate) - first link below.

They usually start a thread as they release a beta, and pin it in the green area at the top of the forum - see second link below. BUT, they don't fix the problems before they go GA on the unsuspecting users.

Guess they just can't or won't kee



After using the second link, log on and follow the Windows 4.6.1 RC thread. He might post the next beta there.

If your stuff is important, you had better keep it backed up. There should be an Evernote folder (do a search), Should do that regardless. This is no guarantee. Have seen people with lost data due to sync not working, or worse. Stuff happens.

There should be a single .EXB file. Did you sign up twice, maybe? Mine is in the DATABASES folder inside the EVERNOTE folder. There is only 1 .exb, but there is an .exb.bak, but they could have changed it since which was the last beta of 4.5.10, I believe. I'm holding where I am. I don't like disruption.

Good Luck. I think you should go to the first link above, and repost your question about betas.

dlu, is the first poster, and he should know. He seems to announce betas.

Link to comment

By the way, the .exb file is the entire database, but I back up the whole EVERNOTE folder just in case, but if you are a big user, the .exb should be growing, since it is where all your notes go. So maybe you are not looking at the correct folder. Try doing a search for EVERNOTE folders, and look at the last used date by hovering over the .exb (I'm still XP).

Uh, go to the Evernote bar and TOOLS, OPTIONS, and the Database folder location is at the bottom of that window.

Link to comment

Hi, and thanx for everyone's suggestions. I am an'official' Beta tester...but signed up and installed everything as we were leaving for a trip, and I think I forgot some of the stuff I read when I did it. There was a lot of monkeying around with installing the Hockey App and the beta versions, and I did it for several Evernote Products...some didn't install correctly on my iPad...it just got confusing and then Xmas came. But here's what I suspect...I've had to uninstall Evernote before, so I sustect that the two files may be from that...or because I kept the regular version on my iPad as well because I really do rely on it and if there's a problem with the beta one I just switch to the regular one. I now can find the Windows RC Forum...with your help, and I'm going to go work on finding the database files. I really appreciate your suggestions and help!

Link to comment


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...