Jump to content

(Archived) Skitch 2.0.3 on 10.8.2 breaks after closing window


Recommended Posts

Steps to reproduce:

1) Use keyboard shortcut to take a screenshot. Skitch window comes up.

2) Close window with Cmd-W

3) Keyboard shortcut no longer works, Skitch window has empty middle area, and Cmd-Q hangs.

Amazingly frustrating.

Quitting Skitch after each screenshot, or hiding the window with Cmd-H works works fine.

Link to comment


We think the cause of this is due to a conflict with the Helper and the Skitch App. We're working on a fix, but in the mean time you can try these work around steps to potentially resolve your issue:

  • If you have a beta version of Skitch install, trash it and only run a release version. <- Running a beta version and a release version at the same time can cause weird issues.
  • Do not try and run the Mac App Store version of Skitch and the Direct Download version at the same time. <- Apple's security model for OS X can create some conflicts between the two versions running at the same time. Only run one version.
  • Quit Skitch App and Skitch Helper (right click on the helper and select Quit). <- You should do this before running any Beta version, upgrading, or if you're trying to run 2 different versions of Skitch on the same Mac.
  • If you continue to have problems, you can disable the Helper by going to Preferences->General and unchecking the two boxes related to the Skitch Helper (found at the bottom of the screen) <- This will disable the Helper but resolve the problem completely.
  • Avoid running 1.x and 2.x at the same time as this can cause a lot of issues.

Thanks for reporting the issue, and we are actively working to resolve the conflict between the Helper and Skitch App.

Link to comment

This is exactly the same problem I have.

I've tried removing Skitch and any Skitch related stuff in Library/Application Support and Library/Caches, and the helper from the login items, then reinstalling v2.0.3 from the website, but I still find it hangs after I close the Skitch window and then go back to it - the thumbnail view is empty and the app doesn't respond.

At the moment it's completely unusable to me :/

Are there other places I need to remove Skitch related configs to completely reset it?

After the steps above it still seemed to know my Evernote account details when I started the fresh version.

Link to comment

@subblue - Have you tried disabling the helper all together from Preferences? Also do you have any other versions of Skitch running?

Try disabling the Helper and see if that fixes the issue. Also you make sure you've removed any beta copies of Skitch and if you are running both the Mac App Store and the Direct Download versions, make sure you pick one and get rid of the other. The last thing you can do is instead of closing the Skitch main window is just minimize or quit the app all together rather than closing the window and leaving the app running.

We are working on a bug fix right now to address these bugs.

Link to comment


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...