Jump to content

(Archived) Crop doesn't work well with image not captured by Skitch


Ngoc Pham

Recommended Posts

I suppose the problem related to retina display only.

When I capture a screenshot by using default Mac functionality, then open it with Skitch, I cannot properly crop the image using Skitch crop.

The first image: I selected a region like this with Crop tool.

ScreenShot2012-12-22at31931PM_zps5142607f.png

However, when I click Apply, I got this:

ScreenShot2012-12-22at32053PM_zps1bacd407.png

Link to comment

I am using 10.8.2 with the latest version of Skitch: 2.0.3. A retina macbook, in addition.

The steps to reproduce are:

1. Take a screenshot with Mac built-in tool. I used "Cmd + Shift + 4" and "Space" to capture the whole window.

2. Open up Skitch and select the captured screenshot.

3. Select Crop tool and try to crop just an area of the screenshot.

4. Apple the crop and see that the cropped area is not correct.

Don't know anyone with the same configuration to test the case :(

Link to comment
  • 4 weeks later...

Encounter the same problem, too.

The only difference is I had first two screenshots cropped fine, but when trying to crop the third screenshot file the same problem happend.

And then when I load other screenshot file it all show the same problem (including the files which was originally cropped without problems)

Link to comment

yes I am using 2.0.4

just find out that if I export the imported and uncropped screenshot

and then import the exported screenshot, the problem vanished

I have tested the cropping function on screenshots of my second display (normal LCD monitor, no retina) and it was fine

so my guess would be that there's something wrong about getting dimension datas of the screenshotted PNG files

btw the first and second tries of cropping after installing Skitch was successful

however, that was the only two successful tries.

thank you for your quick reply :D

Link to comment

@Rettamkrad, can you please post an image of what you're seeing? And the exact steps you are using to cause this bug?

I tried again on my Retina Mac and was not able to reproduce using the steps from above.

The only way we're seeing a distorted image is if you:

1) Take a screen shot using the built in OS X tools (is there a reason for doing this vs. using Skitch's screen cap tools?)

2) Start a blank canvas

3) Drag the image (which is bigger than the default blank canvas onto the blank canvas

This results in just a portion of the image being shown, but this is expected since the blank canvas is not large enough for the snap. This is by design as Skitch is not intended to be a graphic editing tool, thus we do not have a function to snap to the size of the image when dragged into a blank. If this is what you're doing, then the simply solution is to first drag the image into the library view (all of your thumbnails) and then a new Skitch Snap will be created that is the full dimensions of your image. From there you should be able to crop without any issues.

Link to comment
  • 1 month later...
  • 1 month later...

I am having the exact same problem. I open a jpeg image and try to crop, and I get only the top, left corner. I tried re-sizing first (in Skitch), made the image as small as possible, and then cropped - same result. I am using Skitch 2.0.5 on a MacBook Pro (retina) with OS 10.8.3.

Link to comment
  • 5 months later...
  • 1 month later...

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...