Jump to content

(Archived) Skitch not working on Mac OS 10.8.2


Recommended Posts

Hye everybody, Just received my new and first mac machine MBP retina with Mac OS 10.8.2 installed. I can't make the app working. I uninstalled and installed it, nothing when I click show skitch, nothing happens, just the dong (bug) sound. I'm reaaly new to mac, so I can perform some tests if you drive me to.

Thanks for your help.

Link to comment

@cybermarmotte - All versions of Skitch work on 10.8.2 and with MBPR. In fact I'm writing this on an MBPR running 10.8.2 with all shipping, beta, and alpha versions of Skitch running on it without any issues. You should submit a help ticket on our customer support site (http://evernote.com/contact/support/), but I'd recommend you try the following:

  • Uninstall all versions of Skitch
  • Run SW Update and make sure you've got all of the latest updates for OSX. On my MBPR at home I even had to reinstall 10.8.2 because the default image wasn't installed properly.
  • Reinstall the latest Skitch from the Apple Store (or from www.evernote.com/skitch).
  • Try launching Skitch and logging in

Alos make sure when you quit the Skitch app you aren't leaving the Skitch helper app running in the status bar if you are going to run two different versions. The helper apps are designed to work with the version they are installed with and may have conflicts running the beta version and live version at the same time.

If you've done all of that, or do it and it doesn't work, then file a help ticket via our support site found here: http://evernote.com/contact/support/

Link to comment
  • 2 weeks later...

I've got the same problem with Version 2.0.3 (262427) on my MBP (mid-2011) running 10.8.2.

My helper app quit letting me take crosshair snapshots and Skitch would not Quit. So I followed the advice in this forum posting and stopped the helper and then trashed the Skitch application. Then I downloaded Skitch from the app store. It worked okay yesterday.

Today, same problem: Cannot use crosshair snapshot (I don't use the other options) and when select Quit from the Skitch menu it does not. I have to force quit.

I've begun to use this regularly and hope there is a way to get this fixed.

Link to comment


We are aware of a potential problem with the Skitch Helper. Under certain circumstances (moving between accounts, or specific actions) it can cause an issue with the Skitch app that can result in some erratic behavior. Under normal usage it shouldn't cause an issue. If you are continuing to have an issue I recommend disabling the Helper and leaving Skitch running in your Dock if you need Skitch available at all times.

To do this simple go to Skitch -> Preferences and then uncheck two Skitch Helper related check boxes on the bottom.

We are going to look into a fix this week.

I apologize about the issue and appreciate your feedback.

Link to comment

Same problem here. Please fix this soon. Skitch is now unusable. I "force quite" Skitch, re-open and can only use the "Screen Snap" once before the buttons just stops working. Then I have to "force quite" Skitch again to get "Screen Snap" to work again.

Link to comment

@dsmorey - As stated we're aware of an issue like this and are looking into how we can fix it. If you can, please go to Skitch -> Preferences and then uncheck two Skitch Helper related check boxes on the bottom.

@dsmorey & @CaliberFive - If you can, can you please describe in detail what you were doing when Skitch locked up. Were you switching between accounts? Where you trying to quit the app after normal usage? Have you ever run any of our beta 2.0.3 versions of Skitch, and if so have you since deleted them since 2.0.3 has come out?

Link to comment

Sure Joe, I'll try to describe in as much details as I can...

Mac OS X 10.7.5 (Lion)

iMac 21.5"

Skitch 2.0.3 (262427)

I do have multiple users logged into this machine, but I have not switched from the other accounts, I just took the screen saver off and typed in my password to my account.

- I have both Skitch and the helper (in the menu bar) closed so that I can start from a clean slate.

- I go to Spotlight to open Skitch

- Both the dock icon come up and the helper menu icon.

- Skitch window opens by default.

- I click on "Screen Snap" in which the window disappears and the crosshairs come up (like it should)

- I am able to capture a section of the screen with the crosshairs with no problem.

- Now, from here if I bring up skitch again and try "Screen Snap" nothing happens.

- From that point I can not even close skitch anymore regularly. Sometimes the Skitch -> Quit menu item is even grayed out.

- I have to go to Activity Monitor and Force Quit Skitch.

- Then open Skitch again and now I can screen capture again, but again, only once until it locks up and I have to Force Quit again.

- I have tried logging out and back in again and still this happens every time.


Link to comment

@Joe, just noticed that the console is logging a strange error when I start Skitch from scratch and also when I try screen capture...

12/31/12 10:34:17.724 AM sandboxd: ([22193]) Skitch(22193) deny file-write-create /Users/blah/Library/Preferences/ByHost/.GlobalPreferences.821F511C-ACA7-551B-9EBE-0B9256FC00E4.plist.sb-f4a8d3b3-nb7MXt

And I'm attaching the trace...

Skitch(22193) deny file-write-create /Users/blah/Library/Preferences/ByHost/.GlobalPreferences.821F511C-ACA7-551B-9EBE-0B9256FC00E4.plist.sb-f4a8d3b3-nb7MXt

Process: Skitch [22193]
Path: /Applications/Skitch.app/Contents/MacOS/Skitch
Load Address: 0x109a91000
Identifier: Skitch
Version: ??? (???)
Code Type: X86-64 (Native)
Parent Process: launchd [137]

Date/Time: 2012-12-31 10:34:17.331 -0500
OS Version: Mac OS X 10.7.5 (11G63)
Report Version: 7

0 libsystem_kernel.dylib 0x00007fff8a6efad2 __open + 10
1 CoreFoundation 0x00007fff8fb7bba7 -[CFXPreferencesPropertyListSourceSynchronizer writePlistToDisk] + 1207
2 CoreFoundation 0x00007fff8fb445d5 -[CFXPreferencesPropertyListSourceSynchronizer synchronizeAlreadyFlocked] + 613
3 CoreFoundation 0x00007fff8fb44319 -[CFXPreferencesPropertyListSourceSynchronizer synchronize] + 425
4 CoreFoundation 0x00007fff8fb8281f __-[CFXPreferencesPropertyListSource synchronizeInBackgroundWithCompletionBlock:]_block_invoke_1 + 111
5 libdispatch.dylib 0x00007fff9501da82 _dispatch_call_block_and_release + 18
6 libdispatch.dylib 0x00007fff9501f2d2 _dispatch_queue_drain + 264
7 libdispatch.dylib 0x00007fff9501f12e _dispatch_queue_invoke + 54
8 libdispatch.dylib 0x00007fff9501e928 _dispatch_worker_thread2 + 198
9 libsystem_c.dylib 0x00007fff8cd8d3da _pthread_wqthread + 316
10 libsystem_c.dylib 0x00007fff8cd8eb85 start_wqthread + 13

Binary Images:
0x7fff8a6d9000 - 0x7fff8a6f9fff libsystem_kernel.dylib (1699.32.7 - compatibility 1.0.0) <66C9F9BD-C7B3-30D4-B1A0-03C8A6392351> /usr/lib/system/libsystem_kernel.dylib
0x7fff8cd3d000 - 0x7fff8ce1afef libsystem_c.dylib (763.13.0 - compatibility 1.0.0) <41B43515-2806-3FBC-ACF1-A16F35B7E290> /usr/lib/system/libsystem_c.dylib
0x7fff8fafb000 - 0x7fff8fccfff7 com.apple.CoreFoundation (6.7.2 - 635.21) <62A3402E-A4E7-391F-AD20-1EF20236CE1B> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x7fff9501c000 - 0x7fff9502afff libdispatch.dylib (187.10.0 - compatibility 1.0.0) <8E03C652-922A-3399-93DE-9EA0CBFA0039> /usr/lib/system/libdispatch.dylib

Link to comment

Today, 2012-12-31, Skitch 2.0.3 stopped working, as in no crosshairs, no anything. Yesterday I tried some of the suggestions in Joe's post but when I restarted my machine today Skitch would not work - period. I quit the helper, force quit Skitch (you have to wonder about quality assurance) and did this multiple times with no effect. Changed preferences, nothing.

My solution - back to 1.0.12

Much as I want to use the latest version I have no desire to troubleshoot every time I try to use it. I'll wait for the next release before trying again. :excl::(

Link to comment

Sorry to post so many times here this morning guys/gals, but I've been a developer for many years and I love when people give detailed explanations on their problems instead of things like "Hey, it's broke, please fix it.". So, I'm trying to give @Joe as much details as possible as I think of it and investigate.

@Joe, some more info. I did NOT upgrade my laptop's version of Skitch. I'm still at 2.0.2 and it works perfectly. Now one difference between my iMac and the MBP is I have Mountain Lion on my MBP. However, 2.0.2 works perfectly. I did not upgrade and will not until this is resolved with 2.0.3.

Thanks @Joe

Link to comment

@dsmorey - Thanks again for the details. We're pretty sure we've traced all of the problems with the Helper and are working to fix them right now.

If all else fails (meaning uninstalled any previous version of 2.x; not running 1.x and 2.x at the same time) then please disable the Helper which can be done by looking to Preferences->General. I know this is an inconvenience and for most users they will never have a problem, but some more advanced users may be running into the cases which cause the bug to appear.

We are working to fix the problem and will keep everyone updated.

Link to comment
  • 2 weeks later...

I would like to report my problem as well.

I have Mac OS 10.8.2. Skitch Version 2.0.3 (262427).

Cannot point out exactly when the following behavior started but it is driving me nuts:

I can open Skitch, do my thing.

I close the Skitch window.

If I open Skitch (via the Dock), Skitch opens, but window is empty. The window responds to clicks but cannot do any operations.

If I right click on the Skitch icon on the Dock to quick, it doesn't want to quick.

The only way I can make Skitch work is to Force Close, then open again.

The behavior above all repeats.


Link to comment

Version 2.0.4 is out for direct download and winding its way through Apple's review process. You can find Skitch for Mac 2.0.4 by going to www.evernote.com/skitch or if you already running the direct download version of 2.0.3 then you should get auto-updated depending upon your preference setting.

2.0.4 addresses bugs with the Helper along with several window interaction bugs. Going forward Skitch will always try to launch the correct version of Helper, but it is very important to note the following:

  • Skitch 1.x and 2.x do not work well together and should never be run at the exact sam time;
  • Do not try and run any betas at the same time as a general release version and always make sure to quit the Helper when quitting the app if you are using a beta version;
  • Due to the way Apple security works, if you run the Mac App Store and the direct download versions at the same time, Skitch has no way to control which version of the helper is run. While they might be the same exact version, Apple sandbox security may cause some weird UI interactions to occur. Try and only have one version installed.

If you are using the Mac App Store version and prefer to continue to use that version you will need to wait a little while longer as the app works its way through Apple's review process. As soon as it is finished, we'll release it.

Link to comment

I'm just here to chime in and say that Skitch simply no longer works reliably. I miss the old one where when you hit ⌘⇧5 and it acutally worked. It seems more often than not that shortcut doesn't work and a force-quit restart fixes it.. As a customer (paying) this is very disheartening.

Link to comment

@rh0dium - I'm sorry to hear that it isn't working for you. Can you send me a private message with what version of Skitch you are using and what versions you have installed, so we can try and figure out what might be the cause.

There are several conflicts when running multiple versions of Skitch on the same Mac, but that issue is due to Apple OS X security model and not Skitch. Their Sandbox security model does not let us control which version of the Helper runs and let's OS X decide. Thus if you have multipler versions of Skitch installed, Apple may pick the wrong Helper. We have added in a check in 2.0.4 (and going forward) which will do its best to ensure if you have 2 different version numbers of the direct download Skitch, then we will only run the newest Helper, but there isn't much we can do to resolve the OS X Sandbox security model between Mac App Store and direct download.

This is a known problem that affects any developer who has a Mac App Store and a direct download version of their app. The only simple workaround for us is to let multiple Skitch Helpers run at the same time, but that doesn't mean there won't be issues.

If you aren't running multiple versions, or do not have the Mac App Store and the Direct Download versions running at the same time, then please private message me so we can figure out what is going on and work to address that issue.

Link to comment

@Joe, the App Store was taking forever, so I just downloaded 2.0.4 and overwrote the one the App Store installed. Seems to be fine now. I haven't rebooted yet, but I've opened 2.0.4 and closed and re-opened and the screen capture doesn't freeze anymore.


Link to comment
  • 2 weeks later...

I have Skitch 2.0.3 and a Mac Probook 10.8.2, and I can't use Skitch anymore. I see that the Skitch 2.0.4 update is at the AppStore, but I can't quit Skitch and therefore it won't permit me to download the 2.0.4 update. What to do? Thanks.

Link to comment

Here is what worked for me: Go to Skitch Preferences and then to General. Uncheck the two boxes at the bottom ("Keep Skitch Helper running..." and ("Start the Skitch Helper..."). Then reboot your Mac and Skitch will not start up.

You should be able to go to the App Store and download and install he new version. Version 2.0.4 fixed the Skitch problems that I had.

Link to comment

CaliberFive- Thanks! Your suggestion worked, except that (and I just say this because it might help any other beginners like me) technically I had to "force quit" Skitch before I could reboot my macbook pro.

Link to comment
  • 6 months later...


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...