Jump to content

(Archived) Can't enable warning when deleting tags


Recommended Posts

I've accidentally deleted a large number of nested tags from 500 notes. From reading the forum, it sounds like there's no way to recover the tags, so I'm about to go in and start re-tagging. Before I do that, I want to make sure I can't do this again by turning on backups and enabling the warning that's apparently supposed to show when you delete a tag. However, I can't find how to enable this.

I'm looking in the registry under HKEY_CURREN_USER\Software\Evernote\Evernote\AutoResponse for the ConfirmDeleteTag key. However, all I see there is Default.

I don't remember ever telling Evernote not to display the warning, and it doesn't seem like something I would ever have wanted to do. Did the warning stop existing in the newest version of Evernote?


Edited to add update: Something very strange is happening. If I quit and restart Evernote, sometimes my old tags are there AND the warning message does come up when I delete a tag. Sometimes they are gone and there is no warning message.

Link to comment

Hi s_l, welcome to the forum :)

You appear to be looking in the correct place, and as you also appear to know, the presence of the key indicates that the message will not be shown.

There are actually two different dialogs, one for a tag (ConfirmDeleteTag), and another for multiple tags (ConfirmDeleteTags)

Since you the keys aren't there, Evernote should have shown you the message, so I don't know why it wouldn't have.

I just tested, and I get the confirmation messages.

- What version of Evernote are you using? (Help - About...)

- Can you create some test tags and try again to see if you get the message or not?

- How did exactly did you try deleting the tags?

- How were the tags nested? (i.e. how many levels, how many tags etc.)


Link to comment

Thanks for the reply! I edited my original message a few times just now because some odd things began to happen after I posted my question.

First, I shut down Evernote and restarted it. In the past I've been running it as an administrator in Windows to fix a bug. This time I tried running it as a regular user to see if that made a difference. It didn't actually seem to change anything, so I started re-organizing my notes. I may have quit and restarted it again at some point.

Then I noticed that my old tags had reappared AND the tag deleting warning message was back! At this point, I backed up my .exb file. Then I quit, restarted Evernote, and...my old tags and the warning were gone again.

I do have a backup of my .exb file from the one time I opened it when everything was working. I'm not sure if I should stop using Evernote at this point and try and restore it from the brief time when everything was there, or what. This may be one I'll need Support for, but if anyone has any ideas for me that would be great!

I'm running

Link to comment

I am not entirely certain, but I think that you may be running into problems where you are effectively editing two different database files. One residing in the Admin user account and another in the normal user account.

For Example, I just ran EN as admin (I don't normally) and it appeared to load a database that was not only in another location (the admin appdata) but an older version of the database.

Not only that, but I found that I saw messages (specifically the quit confirmation) that I had disabled for my normal account. I presume that running as admin changes the HKCU to the admin current user, which would explain my previous settings not working.

So, I would suggest picking one location - admin or non admin and stick with that.

Check the settings location for the admin account as well, since you may have disabled it there as well. (you can do this by running Regedit as admin as well)

I think this may prevent the confusion between settings and existence of tags etc. (Not 100% sure though)


Link to comment

Okay, that makes sense. When I run the program as admin, it's accessing a separate local database and a separate registry for that user. The warning was disabled there (still not sure how it was switched off in the first place) and that version of the database was synced up with the web version. Then when I ran it as the regular user, it wasn't synced and had my old tags briefly before syncing and deleting the tags. (I wish I could just run the desktop client as a regular user and not have this confusing issue, but all external links are disabled unless I'm running it as admin.)

Thanks for the help!

Link to comment

Maybe you could expand on the external links issue a bit more? Perhaps there is a solution that someone has here on the forum.

Well, if I open the Evernote desktop application as a standard Windows user, any link I click (from a note or from the banner ad in the left sidebar) does nothing. If I run Evernote as an admin, the links open in a browser as I'd expect them to. It's always worked this way since I installed Evernote a few years ago--I think I wrote in to Evernote support at the time and they told me to solve it that way.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...